none
Hyper-v role - does not work

    Question

  • I have configured Hyper-v cluster.

    In few day's role "Hyper-v" does not respond and I can't start vm, or create  new vm.

    Temporary resolution is uninstal role hyper-v, and install it again. After that hyper-v work's fine one or five days, and again does not respond.

    Then in log's i se EVENT ID: 20100 "Microsoft-Windows-Hyper-V-VMMS cannot be found".

    Please help to resolve problem.

    Windows 2012R2


    • Edited by ruarer Friday, March 3, 2017 11:01 AM
    Friday, March 3, 2017 10:58 AM

All replies

  • Hi lukasz,

    please check that the Hyper-V Virtual Machine Management Service is running.
    https://technet.microsoft.com/de-de/library/ee956894(v=ws.10).aspx

    Regards

    Sebastian

    Friday, March 3, 2017 1:06 PM
  • Hi Lukasz,

    is there a Virus Engine which is running on that hosts? If so, define exclusions.

    Regards,
    Marcel


    https://www.windowspro.de/marcel-kueppers

    I write here only in private interest

    Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.

    Friday, March 3, 2017 1:13 PM
  • @Sebastian

    Engine is running.

    @Marcel

    I don't install any anty-virus software on Hyper-v host.

    This is default configuration, only Hyper-v, and cluster role installed. Any external software is not installed.

    Friday, March 3, 2017 2:39 PM
  • Is there any GPOs that limits the ability to "Allow Logon" or "Allow Logon as a service"?

    NT Virtual Machine\Virtual Machines should be able to run.


    Andreas Sobczyk CloudMechanic.net

    Friday, March 3, 2017 4:32 PM
  • @Andreas

    I don't known that, I have to check it.

    Friday, March 3, 2017 5:11 PM
  • I don't have any GPOs to limit "Allow Logon" or "Allow Logon as a service".

    What else can provide to "Microsoft-Windows-Hyper-V-VMMS cannot be found" error?

    Monday, March 6, 2017 10:14 PM
  • Are all components of the cluster found in www.windowsservercatalog.com as being certified to run under Windows Server 2012 R2?

    Have you run the cluster validation wizard? Any warnings or errors? Do NOT discount warnings as 'just a warning'. Warnings often are highlighting issues that have the potential to create an unstable environment.


    . : | : . : | : . tim

    Tuesday, March 7, 2017 2:49 PM
  • Yes I run it, all test are passed.

    but in my enviroinment HYPER-v work's fine day, or 5 day's then i have again the same error:

    "Microsoft-Windows-Hyper-V-VMMS cannot be found"

    Then I reinstal HYPER-v role and all work's again fine, for day or 5 days...

    Error come's back like bumerang.

    Wednesday, March 8, 2017 7:26 AM
  • Okay, you answered the question about the validation wizard.  How about the answer to the question about all components being listed as certified for Windows Server 2012 R2?

    . : | : . : | : . tim

    Wednesday, March 8, 2017 2:48 PM
  • Hardware:

    2x Dell Storage NX3330

    Storage SCv2000 as storage

    It look's fine.

    Wednesday, March 8, 2017 4:40 PM
  • According to Dell's site, the Dell Storage NX3330 is a Windows Storage Server device.  That is designed to run Windows storage services.  It is not designed to run Hyper-V.  In fact, I believe one of the things about Storage Server systems is that they are not licensed to run non-storage related services.

    Sounds like you should talk with Dell about their system to see what they have to say about trying to run Hyper-V on the NX3330


    . : | : . : | : . tim

    Thursday, March 9, 2017 4:13 PM
  • Dell sell it for Hyper-v environment.

    And here is information about support hyper-v on "Windows Storage Server 2012 R2 Standard":

    https://technet.microsoft.com/en-us/library/jj643303(v=ws.11).aspx

    Friday, March 10, 2017 6:29 AM
  • Have you contacted Dell to ensure you have it configured according to their requirements for running Hyper-V?

    . : | : . : | : . tim

    Friday, March 10, 2017 2:20 PM

  • Hi,
    Are there any updates on the issue?
    You could mark the reply as answer if it is helpful.
    Best Regards,
    Leo

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 16, 2017 7:16 AM
    Moderator