OWA/OMA not working for Exchange Server 2003, Enterprise SP2


  • Dear all,

    I have an URGENT issue to resolve asap.

    I can access OWA web site....even on the exchange server i'm having "Internet Explorer cannot display the webpage".

    I have checked the services...IIS, www, etc all is running fine. When i re-start my exchnage server then OWA works.

    Please provide the solutions/suggestions asap.

    Also i have tried to test using (https://www.testexchangeconnectivity.com)....but i'm getting an error when testing for OMA.."The certificate couldn't be validated because SSL negotiation wasn't successful. This could have occurred as a result of a network error or because of a problem with the certificate installation."

    any quick reply will be much appriciated.

    Monday, September 30, 2013 9:01 AM


  • Have a look at the Default Web Site, and make sure it's listening for both port 80 and 443 traffic on 'All Unassigned' IP addresses. If it's configured to listen on a specific IP address, then it won't respond to the localhost host name on .

    OWA For SmartPhone

    Friday, October 04, 2013 9:28 AM

All replies

  • The next time you are unable to access OWA on the server, make sure the World Wide Web service is running in the services list. Maybe you previously checked it at a time when there was no problem. Look in your IE options and make sure Friendly HTTP Errors are turned off, so that you will get a bit more error detail displayed.

    OWA For SmartPhone

    Monday, September 30, 2013 9:34 AM
  • currently i'm having the issue and the service www is well running on the server.

    on iis...i try to Browse the Default Web Site but cannot. it gives me an error lik "Under Construction".

    Monday, September 30, 2013 10:59 AM
  • The 'Under Construction' page is normal for the Default Web Site - that's what is there by default, until you put some of your own pages there. What error is displayed when you go to the OWA address at https://xxxxxxxxxx/Exchange

    OWA For SmartPhone

    Monday, September 30, 2013 11:13 AM
  • when typing https://xxx/exchange, i get the error "The page cannot be displayed"......more information below

    <id id="errorExpl1">This problem can be caused by a variety of issues, including:</id>
    • Internet connectivity has been lost.
    • The website is temporarily unavailable.
    • The Domain Name Server (DNS) is not reachable.
    • The Domain Name Server (DNS) does not have a listing for the website's domain.
    • There might be a typing error in the address.
    • If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.
    Monday, September 30, 2013 1:03 PM
  • Okay, I suppose you ought to test the name resolution first. Try opening a CMD prompt window from the computer you are trying to access OWA from, and type

    ping xxx

    where xxx is the server name in your url https://xxx/exchange . You might not get a reply to the ping, but does it at least resolve to an IP address like this xxx.xxx.xxx.xxx ?

    OWA For SmartPhone

    Monday, September 30, 2013 3:29 PM
  • Hi,

    Please also check the SSL certificate of OMA.

    We can locate in IIS-->Exchange 2003 server--->Web sites--->Default web site--->OMA--->right-click and select Properties--->Directory Security--->view certificate. Please verify the hostname of owa is included in certificatedomains, and the certificate is valid and not expired.



    Tuesday, October 01, 2013 9:57 AM
  • Dear all,

    the issue is quite surprising.....just now i have reboot my exchange server, on which i have the OWA, OMA etc.

    When there is issue:

    - OWA does not work.

    - http://locahost on the ex server returns .....page cannot be displayed. why???

    - all required services are running fine, lik IIS Admin, www, etc

    -a test web site does not work

    do you think the IIS has corrupted??

    After rebooting the ex server:

    - owa works (with some slowness)

    - http://locahost on the ex server returns a page (under construction)

    - a test web site works fine.

    where is the blocking point? how to resolve this??

    now it is working since i have restarted, but i donot know how much time it will stop working.

    wat is causing this random issue??? any logs i should send?

    Wednesday, October 02, 2013 10:35 AM
  • Is there some other process which uses a webserver on the same server? This sounds like something has taken over the IIS port.

    When the problem presents itself, you can try to run a netstat -A to see if there is anything listening on ports 80/443 (don't know where your server is at).

    Also, is this a front-end / back-end Exchange 2003 setup? In this case it could very well be that the front-end server has all the services running, but the back-end connection is gone.

    Wednesday, October 02, 2013 10:41 AM
  • On my ex server, on system manager....i can see that the ex server is configured as a Back-End server.

    i have only one server under the Servers node in system center.

    I have rebooted the ex server some hours back and the owa, my test web site was working....but after some 30mins....surprisingly all STOPS working!! how comes after rebooting it works then stop working....??

    I have run netstat -a on my ex server, but cannot see any stuffs with port 80 or 443.

    currently on the ex server, when i type http://localhost , it returns me Page cannot be displayed.

    is this not related to IIS being corrupted??

    Wednesday, October 02, 2013 1:21 PM
  • Hello all,

    issue is still persisting and seems the solution is a long way ahead....

    When i try to access http://localhost i'm getting Page cannot be displayed. So i have tried to check with program might be using the port 80 on my server.

    i have used this command and see the output:

    C:\Documents and Settings\> netstat -o -n -a | findstr 0.0:80
      TCP                 LISTENING       4
      UDP           *:*                                    1960

    Port 80 is being used by Process ID 4, which is the System.

    any views? any solution from your sides??

    Thursday, October 03, 2013 6:07 AM
  • I would see if something is consuming the server memory. Use Task Manager to check the amount of memory used when you can see your IIS working okay. When IIS seems to be broken, see if the memory usage is significantly higher, and near to 100%.

    OWA For SmartPhone

    Thursday, October 03, 2013 9:12 AM
  • Hello,

    I have been able to capture the details when IIS was working and now, which is currently not working.

    I have 8GB RAM on my server.

    When IIS was working: available memory was 6790888 KB

    Now it is not working and the available ram is 6189148 KB

    The process consuming the highest memory right now is the store.exe

    Below are Checks done when IIS is broken/not working:

    - IIS admin service and its dependencies services are well running.

    - WWW service is running.

    - In IIS manager, the default web site is well started.

    - On the exchange server, I'm able to browse Internet BUT i cannot get the http://localhost page. Even locally on the server my owa link does not work.

    - Name resolution seems to be OK.

    Still I failed to figure out why IIS stops working suddenly where locally I cannot browse http://localhost

    Any solution will be much appreciated....

    Friday, October 04, 2013 4:41 AM
  • Have a look at the Default Web Site, and make sure it's listening for both port 80 and 443 traffic on 'All Unassigned' IP addresses. If it's configured to listen on a specific IP address, then it won't respond to the localhost host name on .

    OWA For SmartPhone

    Friday, October 04, 2013 9:28 AM
  • Yes Lee, i have alreayd checked this before and my default web site is well configured on "All Unassigned" IP addresses listening to port 80 and 443.

    Friday, October 04, 2013 12:25 PM
  • Hello again MaxPayne3. Sorry for the delay, but I've been away for a few days. I assume this isn't fixed yet.

    Anyway, you say that the problem can be temporarily resolved by restarting your server. How about if you do something less drastic, like an IISRESET? I don't know if you tried this (I can't see it mentioned above), but next time OWA etc. does not seem to be working, instead of rebooting, open a CMD prompt, and type IISRESET . Does that work, too? This will enable us to see if it is really an IIS problem, and not some other process on the server, since IISRESET will only restart IIS, and nothing else.

    OWA For SmartPhone

    Tuesday, October 08, 2013 10:31 AM