none
MDT 2013+WDS how to deploy fresh Windows 7 OS to Multiple Model PCs at once RRS feed

  • Question

  • Hi,

    In my present network i have multiple branded PCs and few assembled system.

    I am trying to deploy OS to 4 PCs all the 4 are different make and model, i have imported all the 4 Models Driver into my Deployment Tool-->Out of Box Drivers Like HP-15G , Lenovo V110, Intel DG61HK, Asus M5AG etc.

    When i check manually the cmd

    wmic csproduct get name

    wmic csproduct get vendor

    few motherboard shows "To Be Filled By O.E.M" error.

    Can anybody suggest me how to deploy OS for multiple model System all at once.

    Thanks in advance.


    Mohammed...

    Saturday, September 1, 2018 10:05 AM

All replies

  • Hi,

    What if you use 'wmic computersystem get model' ?

    I assume your deployment works for models not showing this message?


    Best Regards,

    Jesper Vindum, Denmark

    Systems Administrator

    Help the forum: Monitor(alert) your threads and vote helpful replies or mark them as answer, if it helps solving your problem.

    Sunday, September 2, 2018 1:32 PM
  • when i verified at client end by executing cmd wmic computersystem get model, i receives To be Filled by O.E.M, i afraid by the time of deployment driver wont be correctly installing the machine which throws the error To be Filled by O.E.M, can you please share some link how to deploy for 4 model PCs...


    Mohammed...

    Sunday, September 2, 2018 2:18 PM
  • Does it show the samme wmic output on all 4 models?

    A similar issue and possible fix is discussed here:

    https://social.technet.microsoft.com/Forums/en-US/b42f45f4-de4c-4d3c-9755-88110a63c778/mdt2010-use-motherboard-make-and-model-instead-of-default-system-make-and-model-to-select-installed?forum=mdt


    Best Regards,

    Jesper Vindum, Denmark

    Systems Administrator

    Help the forum: Monitor(alert) your threads and vote helpful replies or mark them as answer, if it helps solving your problem.

    Sunday, September 2, 2018 2:33 PM
  • Thanks for your continuous help, yah i seen the link morning i am bit confuse as the MDT we have setup in our environment didn't linked to SQL DataBase.

    Priority=...,...,MBMakeModel,MMSettings,...,...
    Properties=MBMake, MBModel
    
    [MBMakeModel]
    UserExit=MBMakeModel.vbs
    
    [MMSettings]
    SQLServer=<yourserver>
    Instance=SQLEXPRESS 'only needed if SQL Express is used
    Database=<your DB>
    NetLib=DBNMPNTW
    SQLShare=<your SQL share>
    Table=MakeModelSettings
    Parameters=MBMake, MBModel
    MBMake=Make
    MBModel=Model
    
    You migh also want to consider editing MMRoles,MMApps,MMPackages,MMAdmins wth: 
    
    Parameters=MBMake, MBModel
    MBMake=Make
    MBModel=Model
    
    
    

    Can you please share how the CustomSettings.ini for this task, as i understand in that link need to create a .vbs file and paste under DeploymentShare\Scripts after this need to edit customsetting.ini as mentioned in that post.


    Mohammed...

    Sunday, September 2, 2018 2:49 PM
  • I will have to run tests to get an overview of how it is working, but I have no way to replicate the issue.

    The only suggestion I can think of for now, is to have one image for generic driver injection, and one image with drivers included for those machines giving trouble.


    Best Regards,

    Jesper Vindum, Denmark

    Systems Administrator

    Help the forum: Monitor(alert) your threads and vote helpful replies or mark them as answer, if it helps solving your problem.

    Sunday, September 2, 2018 6:07 PM
  • So have to perform iso twice for one problematic system and one for other PCs..

    Mohammed...

    Monday, September 3, 2018 3:25 AM
  • As it looks for now, yes. If I do find a solution, I'll share it with out.

    Best Regards,

    Jesper Vindum, Denmark

    Systems Administrator

    Help the forum: Monitor(alert) your threads and vote helpful replies or mark them as answer, if it helps solving your problem.

    Tuesday, October 9, 2018 11:40 AM