none
Reinstalling DPM 2010 - problem with restore RRS feed

  • Question

  • hi,

     I have to reinstall DPM 2010 because it crashed after promoted server to AD Controller. I unistalled with option retain data and I did backup sql data. After installed DPM work ok but doesn't see old conf. I restore database from backup and DPM crashed again. It possible to connect to old agent with new instance of dpm 2010?

    I got below error after start DPM:

    The description for Event ID 999 from source MSDPM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    An unexpected error caused a failure for process 'DPMAMService'.  Restart the DPM process 'DPMAMService'.

    Problem Details:
    <FatalServiceError><__System><ID>19</ID><Seq>0</Seq><TimeCreated>2012-04-04 16:37:45</TimeCreated><Source>DpmThreadPool.cs</Source><Line>163</Line><HasError>True</HasError></__System><ExceptionType>DlsException</ExceptionType><ExceptionMessage>Exception of type 'Microsoft.Internal.EnterpriseStorage.Dls.Utils.DlsException' was thrown.</ExceptionMessage><ExceptionDetails>Microsoft.Internal.EnterpriseStorage.Dls.Utils.DlsException: Exception of type 'Microsoft.Internal.EnterpriseStorage.Dls.Utils.DlsException' was thrown.
       at Microsoft.Internal.EnterpriseStorage.Dls.UI.ObjectModel.OMCommon.DpmServer.Connect(AsyncOperation asyncOperation)
       at Microsoft.Internal.EnterpriseStorage.Dls.UI.ObjectModel.OMCommon.DpmServer.GetDpmServerObject(String serverName, AsyncOperation asyncOperation)
       at Microsoft.Internal.EnterpriseStorage.Dls.UI.ObjectModel.OMCommon.DpmServerFactory.GetServer(String serverName, AsyncOperation asyncOperation)
       at Microsoft.Internal.EnterpriseStorage.Dls.UI.AutoHeal.AutoHeal.DpmStarted()
       at Microsoft.Internal.EnterpriseStorage.Dls.EngineUICommon.DpmThreadPool.Function(Object state)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
       at System.Threading._ThreadPoolWaitCallback.PerformWaitCallbackInternal(_ThreadPoolWaitCallback tpWaitCallBack)
       at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback(Object state)
    *** Mojito error was: ConnectionToServerFailed; 0; None</ExceptionDetails></FatalServiceError>


    the message resource is present but the message is not found in the string/message table

    Wednesday, April 4, 2012 5:37 PM

All replies

  • Hi,

    Did you demote the machine back to a member server before re-installing DPM ?  Did you install the same DPM hotifixes on the new installation of DPM that were installed on the original before you restored the DPMDB ?   What procedure did you use to restore the old DPMDB to the new installation ?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, April 4, 2012 11:05 PM
    Moderator
  • First I changed sql account from MICROSOFT$ACCT$ to new sql AD account and I started sql services. Later I made backup sql, unistalled DPM and demoted AD Controller.
    I installed only one fix on old instance dpm. I have problem with backup VM on MS cluster. I didn't install it on new instance.

    I used this command to restore DB -> DpmSync –restoredb –dbloc <DPMDB file location>

    Now in log I see message with incompatible agent on server.

    Thursday, April 5, 2012 6:10 AM
  • I had also use command dpmsync -sync after that dmp start well
    Thursday, April 5, 2012 2:01 PM
  • OK - Gr8, please make sure you install the DPM QFE that was installed on the original install.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, April 5, 2012 2:28 PM
    Moderator