none
Unable to hyperlink to company applications- Office 2016 ProPlus RRS feed

  • Question

  • I am testing one of my company's applications on a Windows 10 workstation with Office 2016 Professional Plus. In the application the user can download a report to Word or Excel. When that document is opened, there are hyperlinks that link back to the application, opening a different page, passing parameters. In previous versions of Office, we were able to get around this by running the Office90FixIt.reg, which created a DWORD (ForceShellExecute) with a value of 1. This FixIt no longer works with Office 2016 Professional Plus. Is there another FixIt for this issue?
    Tuesday, January 17, 2017 6:28 PM

Answers

  • SOLVED!

    We opened a case with Microsoft.  After a day or two they asked if I could export the key from a computer working with Office 2013 and import it.  When I imported this key into the (regedit) tool, this resolved our issues and links now work from Word/Excel to our single-sign-on protected application.  We are now good with Windows 10/Office 2016. (For some they may need the 32-bit key, but this is what worked for us) 

    Contents of .reg

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet]
    "ForceShellExecute"=dword:00000001

    • Proposed as answer by J Mike Rowland Thursday, February 16, 2017 2:41 PM
    • Marked as answer by jsb2004 Thursday, February 16, 2017 8:47 PM
    Thursday, February 16, 2017 2:39 PM
  • All -
    I was able to spend more time on this issue today.
    I discovered that I had to use the 32-bit Registry Fix on our 64-bit machine with Office 2016.
    The 64-bit version of the Registry Fix DID NOT WORK on the 64 -bit machine.
    As a side note, I have used the 64-bit Registry Fix on a 64-bit machine before, just not with Office 2016... Always Office 2013.
    I hope this helps someone else that is having the same issue as I was.


    Jan B

    • Marked as answer by jsb2004 Thursday, February 16, 2017 8:46 PM
    Thursday, February 16, 2017 8:46 PM

All replies

  • Hi,

    >>which created a DWORD (ForceShellExecute) with a value of 1

    What version of Office are you using before? In which registry path is the DWORD (ForceShellExecute) created?

    Do you have Internet Explorer set as the default browser? If not, please try set it as the default browser and then see if this issue continues.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 18, 2017 5:27 AM
    Moderator
  • We have had all version of Office with 2013 as the latest and have had to use the DWORD registry fix for the past few years now. I think we started in 2014. The Registry Fix is shown below:

    32 Bit:
    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0][HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common][HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet]
    "ForceShellExecute"=dword:00000001

    64 Bit:
    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\wow6432node\Microsoft\Office\9.0][HKEY_LOCAL_MACHINE\SOFTWARE\wow6432node\Microsoft\Office\9.0\Common][HKEY_LOCAL_MACHINE\SOFTWARE\wow6432node\Microsoft\Office\9.0\Common\Internet]
    "ForceShellExecute"=dword:00000001

    We do have IE as our Default Browser.

    Thank you for responding.

    JSB

    Thursday, January 19, 2017 6:11 PM
  • Has a fix been found for Office 2016?  This is also an issue for my company.  We have been using the ForceShellExecute fix for about two years.
    Thursday, February 9, 2017 3:41 PM
  • Mike - No, I haven't been able to resolve this issue. It forces the user to login to the application each time they click a link on the spreadsheet, even if the application is already open. I've tried changing my security settings, thinking that might make a difference, but it didn't. My next step is to go to our Enterprise Access Management (secure login) group to see if they might be able to help.
    Thursday, February 9, 2017 3:59 PM
  • SOLVED!

    We opened a case with Microsoft.  After a day or two they asked if I could export the key from a computer working with Office 2013 and import it.  When I imported this key into the (regedit) tool, this resolved our issues and links now work from Word/Excel to our single-sign-on protected application.  We are now good with Windows 10/Office 2016. (For some they may need the 32-bit key, but this is what worked for us) 

    Contents of .reg

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet]
    "ForceShellExecute"=dword:00000001

    • Proposed as answer by J Mike Rowland Thursday, February 16, 2017 2:41 PM
    • Marked as answer by jsb2004 Thursday, February 16, 2017 8:47 PM
    Thursday, February 16, 2017 2:39 PM
  • Mike - I'm glad that you found a resolution for this issue.
    I tried this registry fix and it didn't work for me.
    I've reached out to our Security Group thinking it might be security settings on our newly built workstations that is keeping this from working, but then again, that wasn't an issue before.
    The workstation that I am testing on is a new build with Office 2016 being the only software added.
    I will keep trying.
    Thanks for your input.


    Jan B

    Thursday, February 16, 2017 8:25 PM
  • All -
    I was able to spend more time on this issue today.
    I discovered that I had to use the 32-bit Registry Fix on our 64-bit machine with Office 2016.
    The 64-bit version of the Registry Fix DID NOT WORK on the 64 -bit machine.
    As a side note, I have used the 64-bit Registry Fix on a 64-bit machine before, just not with Office 2016... Always Office 2013.
    I hope this helps someone else that is having the same issue as I was.


    Jan B

    • Marked as answer by jsb2004 Thursday, February 16, 2017 8:46 PM
    Thursday, February 16, 2017 8:46 PM