none
L2TP/IPsec connection Windows 10 RRS feed

  • Question

  • Hello,

    I use the L2TP/IPsec protocol for my VPN connection with preshared key.
    On my Android phone I connect with L2TP/IPsec PSK, this works fine.
    Now I wan't to setup the vpn connection on my Windows 10 notebook, but I don't get it working.
    I go to adapter option and I say I wan't to use a preshared key over a certificate. But still it is not working.
    I use MS-Chap v2 as verification type. PPTP works fine on the notebook btw.

    Monday, August 3, 2015 10:04 AM

Answers

  • Hi,

    I assume the connection is already created. Please check if following steps are already performed:

    Click on the "Internet Access" icon if system tray, you should able to find the VPN connection you created.

    Please lcick on Properties, go to Security tab. For "Type of VPN", please choose "layer 2 Tunneling Protocol with IPsec (L2TP/IPsec)".

    Then please click "Advanced Settings", enter your preshared key and click OK.


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, August 5, 2015 7:06 AM

All replies

  • I am actually having the exact same issue. In the past I had to make a registry change (https://support.microsoft.com/en-us/kb/926179) on my Windows 7 and 8.1 machines. However, since the upgrade to Windows 10, that change is not longer working.
    Tuesday, August 4, 2015 6:13 PM
  • Hi,

    I assume the connection is already created. Please check if following steps are already performed:

    Click on the "Internet Access" icon if system tray, you should able to find the VPN connection you created.

    Please lcick on Properties, go to Security tab. For "Type of VPN", please choose "layer 2 Tunneling Protocol with IPsec (L2TP/IPsec)".

    Then please click "Advanced Settings", enter your preshared key and click OK.


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, August 5, 2015 7:06 AM
  • Hi,

    same Problem here.

    I just upgraded from Win 8.1 and there the VPN Connection worked perfectly fine. Since the upgrade to Win 10, I get an error message. RasClient ID: 20227, Error No. 789

    Sunday, August 16, 2015 10:58 AM
  • This is the solution

    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\Parameters]
    "ProhibitIpSec"=dword:00000001


    Wednesday, September 30, 2015 10:41 AM
  • I found that a windows 10 service blocks L2TP/IPSEC VPN access.

    If you go to services.msc
    Find "Xbox Live Networking Services" and disable that service.

    After I did that the VPN worked for me.

    I have tried everything from adjusting firewall rules to adding the registry entry to no avail with Error 809.
    • Proposed as answer by adamwbb Wednesday, March 22, 2017 4:16 PM
    Wednesday, March 22, 2017 4:14 PM
  • Check your windows firewall, I had the same connection problem until I disabled the windows firewall and then everything worked fine.  I did some more research and found which ports needed to be opened and I wrote this guide on how to do it.

    https://www.magnumvpn.com/setup-windows-10-firewall-l2tp.html

    • Proposed as answer by np3524 Wednesday, July 19, 2017 5:12 PM
    Wednesday, July 19, 2017 5:12 PM
  • Try also making sure you are not using erroneous connection security rules that could be inadvertently blocking you like the in the picture below:



    Saturday, July 20, 2019 12:43 AM
  • I know this is an old post, but thankyou!

    I've been tearing my hair out for days trying to resolve a vpn connection issue, error 809 on windows 10 1903 build. Tweaking just about every registry setting and even repairing windows installation didn't fix it....but this did!

    Replying to say thanks, and also maybe flag this up for anyone else with the same problem!

    Wednesday, July 24, 2019 5:31 PM