Is it possible to force the EWS FIM Notification activity/Email Template to use the 'Text' BodyType property and not HTML? RRS feed

  • Question

  • What version of EWS libraries does FIM 2010 R2 Sp1 use?

    I have traced the problem with FIM 2010 R2 SP1 Notifications via EWS down to the message to the BodyType. At least with our Exchange 2013 set up we get scrambled accented chars.

    Writing a simple Powershell script to use the latest 2.2 EWS immediately highlighted the issue. Switching the BodyType has a profound effect.

    Question is.. If I want, how can I configure FIM to use Text Emails always?

    #Web Service Path

    $EWSServicePath = "C:\Program Files\Microsoft\Exchange\Web Services\2.2\Microsoft.Exchange.WebServices.dll"

    #Importing WebService DLL

    Import-Module $EWSServicePath

    #Creating Service Object

    $Service = New-Object Microsoft.Exchange.WebServices.Data.ExchangeService -ArgumentList Exchange2010_SP1

    #Setting up Credentials

    $user = "mydomain\fim.service"

    $pass = "********"   # just a test ffs

    $service.Credentials = New-Object Microsoft.Exchange.WebServices.Data.WebCredentials -ArgumentList $user, $pass

    #Setting up EWS URL for exchange.

    $EWSurl = ""   # same as FIM config

    $Service.URL = $EWSurl

    #Setting up Email message Class

    $message = New-Object Microsoft.Exchange.WebServices.Data.EmailMessage -ArgumentList $service

    $message.Subject = "This Message has been Created by EWS on my mail server"

    $message.From = "fim.service@mydomain.local"


    $message.Body = "This is Test Message öäåÖÄÅ <br>Greetings, EWS Client 2.2"

    $message.Body.BodyType = 'Text'   # works

    #$message.Body.BodyType = 'HTML'   # likes the break but scrambles the scandies



    Tuesday, May 12, 2015 11:10 AM

All replies

  • What Language Packs do you have installed in FIM? What Languages are configured on the PC's where these are being received?

    David Lundell, Get your copy of FIM Best Practices Volume 1

    Wednesday, May 13, 2015 12:33 AM