none
Hyper-V 2019 Slow Network Performance compared to 2012 R2 RRS feed

  • Question

  • We run a combination of 2012 R2 and 2019 servers in separate clusters. We are experiencing a frustrating issue with our 2019 Hyper-V Servers. VM to VM network speeds are inferior on the 2019 hosts compared to identical VMs on the 2012 R2 Servers (around 1/3 of the speed)

    We approached Microsoft and they suggested that they could see a number of network errors on the external NICs, so I approached the vendor (Dell).  They suggested a couple of firmware updates to the NICs and the FC cards, which we performed.  They also suggested a downgrade of the Intel NIC drivers – I had already tried the ones from the Intel site to see if this improved matters.

    When this didn’t fix the issue Dell then wanted to go down the route of replacing hardware, which I resisted since we were having the same performance issues on all 6 hosts & it simply isn’t possible that all the hosts have the same hardware fault.

    I then decided to create a Private VSwitch on one of the 2019 hosts.  I connected my test VMs to this switch and experienced the same poor network speeds, which leads me to believe that the issue is unrelated to the NIC hardware or drivers, but the issue lies more fundamentally with how 2019 handles VSwitch traffic compared to 2012 R2

    I have tried a number of "Fixes" suggested online, such as disabling VMQ and RSC, but these made no difference.

    Has anyone else experienced this issue?

    2019 Performance - VM to VM

    2012 Performance - VM to VM


    • Edited by PJW2020 Friday, May 1, 2020 8:20 AM
    Friday, May 1, 2020 7:33 AM

All replies

  • Hi ,

    Thanks for your posting here.

    In fact, for slow network performance issue, it is hard for us to troubleshooting from forum support level. For such case, we always need to trace process monitor to see what is actually occurring on the network. Unfortunately, analysis of network traffic is beyond our forum support level.

    If you have opened a case with Microsoft ,I would suggest you continue to follow up with your support engineer for better answers.

    It is also appreciated that the other members in our forum can share their experience with us about this issue.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Monday, May 4, 2020 3:14 AM
  • Update.

    The speed issues were fixed with the very latest (2.6.4) BIOS update for the Dell Host released 5th May 2020. The difference was night and day.

    Friday, May 15, 2020 12:48 PM