none
refinement panel problem RRS feed

  • Question

  • I created a search\result page that searches only tasks.

    i wanted to add a due date refinement to it, i created a new mapped property "MyDueDate" that include the ows_duedate(Datetime) crawled property.

    I added to the refinement panel xml the category:

      <Category    Title="due date"    Description="nothing"    Type="Microsoft.Office.Server.Search.WebControls.ManagedPropertyFilterGenerator"    MetadataThreshold="1"    NumberOfFiltersToDisplay="6"    SortBy="Custom"    ShowMoreLink="False"    MappedProperty="myduedate"    ShowCounts="Count" >
        <CustomFilters MappingType="RangeMapping" DataType="Date" ValueReference="Relative" ShowAllInMore="False">
          <CustomFilter CustomValue="past">
            <OriginalValue>..0</OriginalValue>
          </CustomFilter>
          <CustomFilter CustomValue="future">
            <OriginalValue>1..</OriginalValue>
          </CustomFilter>
          <CustomFilter CustomValue="last 24 hours">
            <OriginalValue>-1..</OriginalValue>
          </CustomFilter>
          <CustomFilter CustomValue="last week">
            <OriginalValue>-7..</OriginalValue>
          </CustomFilter>
          <CustomFilter CustomValue="last month">
            <OriginalValue>-30..</OriginalValue>
          </CustomFilter>
          <CustomFilter CustomValue="last 6 months">
            <OriginalValue>-183..</OriginalValue>
          </CustomFilter>
          <CustomFilter CustomValue="last year">
            <OriginalValue>-365..</OriginalValue>
          </CustomFilter>
          <CustomFilter CustomValue="earlier">
            <OriginalValue>..-365</OriginalValue>
          </CustomFilter>
        </CustomFilters>
      </Category>

    but i don't see "due date" in the refinement panel, although there is data in the due date field in the tasks.

    other refiners i added to this result page works properly.

    thanks for any help.

    Sunday, April 15, 2012 1:47 PM

Answers

  • It works!!! yes, it was a 'lower\upper case' reason....

    unfortunately I realized that the managed property was with upper case BiDueDate. when I made a new one - bidudate - it worked......

    although other managed properties worked with upper case too, just in the refiner xml i had to change to lower...

    anyway thanks to all.

    • Marked as answer by malche Wednesday, April 18, 2012 10:12 AM
    Wednesday, April 18, 2012 10:12 AM

All replies

  • Hi,

    Did you:

    1. Enable refinement for the managed property (and mark it as a deep refiner as well)

    2. Execute a full crawl after you mapped the crawled property to the managed property.

    Thanks,
    Mikael Svenson


    Search Enthusiast - SharePoint MVP/WCF4/ASP.Net4
    http://techmikael.blogspot.com/

    Sunday, April 15, 2012 6:10 PM
  • Hi,

    yes, I did a full crawl and the following adjustments to the Managed property:

    Monday, April 16, 2012 5:44 AM
  • In the opposite order I assume, doing the crawl after the modification.

    The next step would be to download something like http://fs4splogger.codeplex.com/ and check if the refiner is coming along the original XML from FS4SP. If it is, then the error lies with the refiner configuration. If you are not running SP1, then the casing of the managed property in the refiner config is important.

    Regards,
    Mikael Svenson


    Search Enthusiast - SharePoint MVP/WCF4/ASP.NET4
    http://techmikael.blogspot.com/
    Author of Working with FAST Search Server 2010 for SharePoint

    Monday, April 16, 2012 6:59 AM
  • The MappedProperty-attribute is case-sensitive I think, did you try MappedProperty="MyDueDate"
    Monday, April 16, 2012 10:45 AM
  • ManagedProperty should be in lower case. ensure that you unchecked the default configuration in Refinement Panel. And also ensure that you have increased the number of category to display in refinement panel webpart.


    Sriram S

    Monday, April 16, 2012 1:46 PM
  • I've tried all the advised options, but no result.

    Mikael, I tried 'FS4SPQueryLogger' and it gave me the follows:

    does it meen that the problem is in the refiner xml?

    I copied the 'write' refiner (that works with datetime) and just changed the mapped property to "biduedate" but still - nothing.

    I found something in fast's logs. Does it tell something?

    thanks in advance for any help.


    • Edited by malche Tuesday, April 17, 2012 3:01 PM
    Tuesday, April 17, 2012 3:00 PM
  • Hi,

    You are looking at the wrong place in the result xml, you should look at the refiner section which is closer to the top. Not sure what the error in the log means...

    Regards,
    Mikael Svenson


    Search Enthusiast - SharePoint MVP/WCF4/ASP.NET4
    http://techmikael.blogspot.com/
    Author of Working with FAST Search Server 2010 for SharePoint

    Tuesday, April 17, 2012 6:34 PM
  • Ok. I found the refiner section. the "biduedate" refiner does NOT exist.

    what does it mean?

    I made a new test column called "my due date", and I mapped it the same way, and it works perfectly, so why the "ows_duedate(Datetime)" does not react the same way?

    Wednesday, April 18, 2012 6:40 AM
  • Hi,

    and your new column is also of type "datetime", with the same mapping? Weird indeed.

    -m


    Search Enthusiast - SharePoint MVP/WCF4/ASP.NET4
    http://techmikael.blogspot.com/
    Author of Working with FAST Search Server 2010 for SharePoint

    Wednesday, April 18, 2012 6:44 AM
  • It works!!! yes, it was a 'lower\upper case' reason....

    unfortunately I realized that the managed property was with upper case BiDueDate. when I made a new one - bidudate - it worked......

    although other managed properties worked with upper case too, just in the refiner xml i had to change to lower...

    anyway thanks to all.

    • Marked as answer by malche Wednesday, April 18, 2012 10:12 AM
    Wednesday, April 18, 2012 10:12 AM