locked
Mount-SPContentDatabase error. RRS feed

  • Question

  • I'm trying to mount my database after a migration and get a screen full of red.

    Command I'm entering "Mount-SPContentDatabase "ShareWebDb" -WebApplication Https://ad2011:987"

    The error I'm getting, translating it from Swedish.

    Mount-SPContentDatabase : Can't find a SPWebApplication-Object with Name, Id, or URL: Https://ad2011:987.

    At line:1 char: 24

    + Mount-SPConentDatabase <<<< "SharewebDb" -Webapplication Https://ad2011:987.

       +CaterogyInfo   :InvalidData: <Microsoft.Share...ContentDatabase:SPCmdletMountContentDatabase> [Mount-SPContentDatabase],  SPCmdletPipeBindException

       +FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletMountContentDatabase

    This is my first Migration I'm running and I follow the guide to the letter. Did they perhaps miss out on telling me I need to create the object or something?

    Any help appreciated.

    /Nuc

    Thursday, March 15, 2012 10:46 AM

Answers

  •  "Mount-SPContentDatabase "ShareWebDb" -WebApplication Https://ad2011:987"

    The above command is incorrect. You have not mentioned -name parameter in the command .

    Mount-SPContentDatabase [-Name] <String> [-WebApplication] <SPWebApplicationPipeBind>

    http://technet.microsoft.com/en-us/library/ff607581.aspx


    Amrita Talreja

    • Proposed as answer by Amrita Talreja Thursday, March 15, 2012 3:28 PM
    • Marked as answer by Pengyu Zhao Sunday, March 25, 2012 6:51 AM
    Thursday, March 15, 2012 3:16 PM

All replies

  • You may have forgotten a quote before https:

    Mount-SPContentDatabase "ShareWebDb" -WebApplication "Https://ad2011:987"

    Otherwhise: is your WebApp Name really that one:

    try get-spwebapplication to find out the correct name.

    best regards
    thomas


    Thursday, March 15, 2012 10:58 AM
  • The " was only forgotten in my above post so I'm afraid it wasnt that simple.

    Get-SPWebApplication returned "remote.iosoft.local:987" Is there a way to change this name into the one I want?

    Edit: Found how I created a new application to mount it to so now its at the correct address. Thanks for the help :)


    • Edited by NuclearAnt Thursday, March 15, 2012 12:17 PM
    Thursday, March 15, 2012 11:50 AM
  • Hi!

    You can't rename the webapp. (that's what i know)

    If you're are still building up your new farm / migrating  it's the best way to delete it and to create a new webapp.

    If you don't want to recreate the webapp you only can set an Alternate Access Mapping on it, to bind it to another adress. (don't forget the IIS Binding; this has to be done manually)

    regards
    thomas

    Thursday, March 15, 2012 12:34 PM
  •  "Mount-SPContentDatabase "ShareWebDb" -WebApplication Https://ad2011:987"

    The above command is incorrect. You have not mentioned -name parameter in the command .

    Mount-SPContentDatabase [-Name] <String> [-WebApplication] <SPWebApplicationPipeBind>

    http://technet.microsoft.com/en-us/library/ff607581.aspx


    Amrita Talreja

    • Proposed as answer by Amrita Talreja Thursday, March 15, 2012 3:28 PM
    • Marked as answer by Pengyu Zhao Sunday, March 25, 2012 6:51 AM
    Thursday, March 15, 2012 3:16 PM
  • Hi,

    I second what Amrita wrote. Believe this will work.

    For checking exact syntax of any PowerShell commandlet, please use:

    Get-Help "Your CommandLet's Name"

    For seeing nice example of how to use the commandlet, please use:

    Get-Help "Your CommandLet's Name" -examples

    So in your case, if you do

    Get-Help Mount-SPContentDatabase -examples, you will see a few examples of how exactly this commandlet can be used. You can always use:

    Test-SPContentDatabase -Name "Your database name" -webapplication "Your web app's url"


    Thanks, Soumya | MCITP, SharePoint 2010

    Thursday, March 15, 2012 3:26 PM

  • You probably will need to use the correct account with access to the content database on the SQL server that is the problem

    Monday, July 28, 2014 8:40 PM