locked
Word add-in not able to load during startup RRS feed

  • Question

  • I am trying to create a APP-V sequence for Word add-in on windows 10 anniversary edition with Office 365 installed. This add-in has VSTO 2010 dependency and it is a COM add-in. When tested on APP-V client machine the add-in tries to load but failing to show up in Word. When i checked in the Word->File->Options->Addins my add-in is under "Inactive Application Add-ins". I am using RunVirtual and ClickToRun registries also. Does anyone know how to make this add-in work?

    Below are my software versions:

    -------------------------------------------

    Sequencer: 5.1

    Client: 5.2

    OS: Win 10 1607 (anniversary edition)

    Office: Office 365 Pro Plus

    Sunday, April 9, 2017 3:37 PM

All replies

  • Have you enabled COM?Is the path to the inactive addin correct? if not can you try symlink to correct appv location.

    This should also help you:

    http://www.applepie.se/tag/allowjitvinappvvirtualizedprocess

    http://app2pack.blogspot.com/2016/03/sequence-excel-addin-for-adobe.html


    (Please click on Vote as Helpful and/or Mark as Answer, if it has helped you.)

    MVP - Windows and Devices for IT

    app2pack.blogspot.com: app2pack.blogspot.com

    Monday, April 10, 2017 9:32 AM
  • First check for the allowjitvinappvvirtualizedprocess regkey in case of O365. If you're using O365 32-bit... also export the hive: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY, and import it into HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Office\ClickToRun\REGISTRY.

    After you apply the allowjitvinappvvirtualizedprocess and apply the reg export/import all you virtualized add-ins should work with a local install of O365 C2R.

    After that it's possible your addin needs integrated COM settings.


    Roy Essers

    Monday, April 10, 2017 12:46 PM