locked
Skype Room System v2 over o365 - Calendar not displaying RRS feed

  • Question

  • Does anyone know what is the trick to enable the calendar information display on the screen of SRS v2 unit?

    We currently have few non-domain joined skype room system v2 units with Logitech Smart dock. Everything else is working except the calendar information is not displayed on the screen. 

    Has anyone experienced this issue before?

    Tuesday, August 22, 2017 2:31 AM

All replies

  • Hi Niuhang,

     

    When you can’t get the calendar information, are there some error messages?

    The Skype Room Systems v2 needs to be assigned a "User account" in Active Directory, Exchange online, and Skype for Business online.

    You can change another account to make a test.

     

    Followed guidelines to check the setting of exchange online account .

    https://technet.microsoft.com/en-us/library/mt790554.aspx

     

    If you have some doubts about the Deploy Skype Room Systems v2 with Office 365,the following link is for your reference.

    https://technet.microsoft.com/en-us/library/mt790557.aspx?f=255&MSPPError=-2147217396


    Best Regards,

    Leon-Lu
    TechNet Community Support


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, August 23, 2017 7:34 AM
  • Are there any update for this issue, if the reply is helpful to you, please try to mark it as an answer, it will help others who has similar issue.

    Best Regards,

    Leon-Lu
    TechNet Community Support


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, August 28, 2017 8:35 AM
  • Hi Leon-Lu

    i have the same issue my surface says "calendar cannot be shown"


    • Edited by iPaidFairly Wednesday, January 10, 2018 2:06 PM
    Wednesday, January 10, 2018 2:06 PM
  • Having the same issue with a Logitech SmartDock SRS v3.1 - displays "Cannot fetch calendar" on the SRS screen and no calendaring/meetings display.

    I have ran and configured all steps successfully from "Deploy Skype Room Systems v2 with Office 365" - https://technet.microsoft.com/en-us/library/mt790557.aspx - Logitech support reported I should double-check the steps and I have 3-4 times.   

    I also tested the account functionality/calendaring on O365 online and also installed Outlook 2016 & Skype for Business on a desktop. On both O365 online AND the desktop via Outlook the requests auto-accept, auto-respond correctly, doesn't allow double-booking, etc.. And,  Skype online & Skype for Business client on a desktop functions correctly Skype shows "upcoming events".. everything on a desktop runs correctly without error with the O365 account.

    The account in Exchange Online Admin is setup as a "Room Resource".. I'm wondering if that is the issue.  Should the account be setup as a regular user mailbox, not a Room Resource? (Then, apply the powershell commands to the user account?)

    This SRS system is being setup with Office 365 only - no on-premisses services.  





    • Edited by tbtechg Sunday, March 25, 2018 10:50 PM
    Sunday, March 25, 2018 10:44 PM
  • I've run into your issue a few times and 365 support was useless.  "Cannot fetch calendar" is resolved for me by adding an entry - autodiscover.yourdomain.com    MicrosoftIP (this you can get from 365 support, just ask for the IP your autodiscover should resolve to) - to the SRS device hosts file.

    Definitely should be a resource and not a user account; otherwise, autoattendant and booking options will not work.  After you've created the resource account, you need to run the following commands in three different PowerShell modules:

    In Exchange Online PS

    Set-Mailbox -Identity ROOMADDRESS -EnableRoomMailboxAccount $true -RoomMailboxPassword (ConvertTo-SecureString -String ROOMPASSWORD -AsPlainText -Force)

    Set-CalendarProcessing -Identity ROOMADDRESS -AutomateProcessing AutoAccept -AddOrganizerToSubject $false -AllowConflicts $false -DeleteComments $false -DeleteSubject $false -RemovePrivateProperty $false

    ----------------------

    IN AZURE PS

    Connect-MsolService -Credential $cred

    Set-MsolUser -UserPrincipalName ROOMADDRESS -PasswordNeverExpires $true


    -------------------------

    IN REGULAR POWERSHELL (after downloading SfB Online PS module)

    Import-Module LyncOnlineConnector 
    $cssess=New-CsOnlineSession -Credential $cred 
    Import-PSSession $cssess -AllowClobber


    Run this to confirm registrar pool is still the same:
    Get-CsOnlineUser -Identity 'YOURACCOUNT'| fl *registrarpool*

    Then this:
    Enable-CsMeetingRoom -Identity ROOMADDRESS -RegistrarPool "REGISTRARPOOLRETURNEDABOVE" -SipAddressType EmailAddress

    Hope that saves you some pain....

    Tuesday, April 3, 2018 1:11 PM
  • Room Mailbox in ExhcangeOnline are disabled for logon. You will need to first set-up a password, and then enable the room mailbox for logon

    See: https://docs.microsoft.com/en-us/powershell/module/exchange/mailboxes/Set-Mailbox?view=exchange-ps

    -EnableRoomMailboxAccount

    The EnableRoomMailboxAccount parameter specifies whether to enable the disabled user account that's associated with this room mailbox. Valid values are:

    • $true: The disabled account that's associated with the room mailbox is enabled. You also need to use the RoomMailboxPassword with this value. This allows the account to log on to the room mailbox.
    • $false: The account that's associated with the room mailbox is disabled. You can't use the account to logon to the room mailbox. This is the default value.

    You need to use this parameter with the Room switch.

    Typically, the account that's associated with a room mailbox is disabled. However, you need to enable the account for features like the Lync Room System or the Skype for Business Room System.

    -RoomMailboxPassword

    Use the RoomMailboxPassword parameter to changethe password for a room mailbox that has an enabled account (the EnableRoomMailboxAccount parameter is set to the value $true.)

    If the RoomMailBox isn’t enabled, please run the following to assign a password and also to enable the AD account for logon

    $SecureStringPassword = ConvertTo-SecureString -String “Insert Password Here” -AsPlainText -Force

    Set-Mailbox -Identity “ROOMMAILBOX Name” -EnableRoomMailboxAccount $true -RoomMailboxPassword $ SecureStringPassword

    Wednesday, April 11, 2018 4:59 AM
  • Hi tbtechg,

    Did Dav-O 's recommendation of adding the Auto-discover record and running the three power-shell commands, resolve your issue?

    Tuesday, January 15, 2019 12:25 AM