locked
Management Server Error RRS feed

  • Question

  • Event Type:  Error

    Event Source: Application Virtualization Server

    Event Category:     Devices

    Event ID:    44955

    User:        N/A

    Computer:    APPVMANAGEMENT

    Description:

    Certificate could not be loaded. Error code [-2146893043]. Make sure that the Network Service account has proper access to the certificate and its corresponding private key file.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp

    I have  a Windows Server 2008 CA. Made a Web template Duplicate and Add the access permission check box.
    Did the Installation , Added the cert. Now when I restarted the Server and Open the console This Error Comes.
    When A clients Initiates a Session the Server Rejects it. Any CLUES?

    Thursday, December 31, 2009 1:03 PM

Answers

  • Thank You Both for your Replies.
    DOnt know what the problem was. I just Deleted and Requested for the Certificate Again and it worked Like a Charm :)
    Thank You Znack for your Help and because of your help I managed to do a Successfull Proof Of Concept for one of my Cutomers here and the customer is also ready for a roll out starting at the end of this month:)
    Tuesday, January 5, 2010 6:26 AM

All replies

  • Thursday, December 31, 2009 2:59 PM
  • No Luck ....
    Can You Please tell that what Access Besides the above is given for the network Service to access the cert  correctly ?
    Thursday, December 31, 2009 6:49 PM
  • The Certificate needs to specifically have the Network Service added as having access to the it.

    The whiteppaer App-V Security Operations Guide should have it in step by step for both windows Server 2003 or 2008.

    it is available along with other whitepapers on App-V at:

    http://go.microsoft.com/fwlink/?LinkId=127120

    mattmcdermott
    • Proposed as answer by znack Tuesday, January 5, 2010 5:18 AM
    Tuesday, January 5, 2010 2:50 AM
    Moderator
  • Thank You Both for your Replies.
    DOnt know what the problem was. I just Deleted and Requested for the Certificate Again and it worked Like a Charm :)
    Thank You Znack for your Help and because of your help I managed to do a Successfull Proof Of Concept for one of my Cutomers here and the customer is also ready for a roll out starting at the end of this month:)
    Tuesday, January 5, 2010 6:26 AM