locked
System Slow / Hang When Creating a Mirrored Volume RRS feed

  • Question

  • I am running Windows Server 2008 R2 Standard in a Dell PowerEdge 2970 server.

    To give some background, the system initially had three hard drives:

    * Disk 0 - a Samsung HD103SJ 1TB hard drive
    * Disk 1 - a second Samsung HD103SJ 1TB hard drive
    * Disk 2 - a WD 1.5TB hard drive

    The OS was initially set up on Disk 0.  Disks 1 and 2 were added after initial setup, the idea being to do a volume mirror to Disk 1 and use Disk 2 dedicated for backups.  When mirroring to Disk 1 was set up via Disk Management, the system suddenly ground to a halt.  IIS stopped responding immediately, and the MMC stopped responding as well.  The system responded via Ping for about an hour, and then that stopped as well.  I pulled the drive and within about 5 seconds the system started responding.  The drive was added again, mirroring attempted again, with the same results.  I checked the error log and found an LSI_SAS error:  "The driver detected a controller error on \Device\RaidPort0".  I tried the drive in several of the available drive bays on the server with the same results.

    I then tried mirroring to Disk 2 (the 1.5TB) instead.  The system and MMC stopped responding for about 5 minutes, then resumed and mirroring started successfully. 

    Assuming the issue to be a problem with the physical drive, I had Drive 1 replaced by Samsung under warranty.  The new drive arrived, and I tried establishing a mirror to it with the same results as before - system slow down to a virtual halt, MMC stopped responding, with no response after as long as 30 minutes, with system functionality resuming after pulling the drive.  The system showed the same LSI_SAS error, but only at the time the drive was physically pulled.

    Considering that it might be an issue with having two of the same Samsung HD103SJ drives, I purchased a new WD 1TB drive, added it in as Drive 1, and started mirroring to this drive.  Same result - system hang/slow down - IIS stopped responding, MMC stopped responding, but the system returned pings.  After 30m with no change, the drive was pulled and the system resumed.  This time there was no LSI_SAS error.

    Giving up for now, I re-established the mirror to Drive 2, the 1.5TB drive.  Like before, it appeared to hang for about 5m, and then started mirroring normally with no noticeable system impact.

    So, to recap, mirroring appears to slow down the system to the point of hanging when attempting with three separate 1TB hard drives over two separate brands, but works (after a short hang) when mirroring to a 1.5TB drive.

    ACK!

    I'm really at a loss as to what to do from here.  It seems very odd that mirroring would cause the system to slow to a halt on THREE separate drives, over TWO different brands, and that even on the 1.5 that it mirrors to it hangs for a short time while mirroring starts.

    The server is new this January, I have verified the hardware firmware on the server is current, and am running what looks like the latest drivers.

    Any ideas on what I should try from here?
    Friday, February 19, 2010 5:45 AM

All replies

  • Based on the lack of response, it looks like this issue has everyone else as perplexed as me!
    Tuesday, February 23, 2010 5:26 AM
  • I have spent a week to study such issues. I changed different hardware(SATA cards). Tried hardware mirror and software mirror. I got the same result. As long as you copy coplue big files, it will trigger the problem. Then I went back to 2008 R1, same thing happened.

    As long as the system gets into SLOW MODE, you have to wait long long time and it will get back to normal.

    I believed that is bug in low level file I/O. It will be triggered when file I/O is busy. The problem may exist in Vista, Windows 7, 2008 32/64 bit.

    For you second situation, you will get big trouble if you use it in production.

    Friday, June 25, 2010 5:29 PM