locked
Service Request set to complete without firing activites RRS feed

  • Question

  • Background:
    I am using orchestrator to create Service Requests by scanning our ticket system and passing some values into the Service Request from the ticket.  I have a template that applies based on a workflow rule that uses the title of the service request.  This works very well.  The problem is the Service Requests randomly get set to completed without moving to the first activity.  Sometimes it works great; sometimes it completely fails. All the activities are pending when I look. I believe there is a built in workflow that controls this.  I set the requests to New status when I create them.  This problem is making SM useless as we can't rely on it.

    Anyone have an idea what might be going on. I see no failures anywhere.

    Friday, August 15, 2014 5:56 PM

All replies

  • This is a known issue in older versions of Service Manager. It was silently fixed back in one of the updates prior to the R2 release. 

    Patch the workflow server with the current cumulative update, and the problem should go away. 

    Friday, August 15, 2014 8:03 PM
  • I am on 2012 R2 7.5.3079.0 and the issue exists.  Any more suggestions?
    Tuesday, August 19, 2014 5:38 PM
  • By any chance, when Orchestrator creates your service request record, does it contain activities? Or are you adding all the activities with the template that you apply?
    Tuesday, August 19, 2014 6:01 PM
  • I'm adding the activities via the template. None are added by SCORCH.

    Tuesday, August 19, 2014 8:53 PM
  • This used to happen a lot in 2010.

    One workaround I found was to export the management pack that contains your template.  Then edit the XML to hardcode each template into a Pending state initially.  That seems to stop the problem.

    Tuesday, August 26, 2014 6:29 PM
  • OK. I'll give that a shot. If it works, I'll mark this as answer. Thanks for the reply.
    Wednesday, August 27, 2014 2:29 PM