none
Workflow approvals in Outlook 2013 - 404 error RRS feed

  • Question

  • Hi,

    We are using Exchange 2013, Outlook 2013, FIM 2010 R2 SP1, client workstation with FIM add-ins and extensions.

    Whenever we trigger an approval workflow, we see it in the Portal and can 'approve' or 'reject' it.

    However, when opening the approval emails 'Action Item' in Outlook, it shows a 404 error message. We deployed the FIM add-ins and extension using the NetBIOS name of the FIM server, which works via either http or https from a browser...but not from within Outlook.

    Also, inside the 'Action Item' 404 message window, there is a "Refresh Page" link. When this is clicked, the actual FIM Portal loads inside the 'Action Item'.

    Is this a bug?

    thanks,

    SK


    • Edited by Shim Kwan Thursday, March 27, 2014 10:07 PM
    Thursday, March 27, 2014 10:06 PM

All replies

  • Hello Shim!

    Do I understand you correctly if I say that you are receiving the approval notification email to the owner of the group but you cannot click the approve button?

    The only important configuration when installing Add-ins for this to work is to get the SMTP-address of the FIM service service account (which sends the approvals) right.

     /Robert Kielén

    Friday, March 28, 2014 2:20 PM
  • That's correct Robert,

    Firstly the Request is visible in the Portal and can be approved or rejected in the Portal by manager.

    Secondly, the approval email request arrives in the inbox of the manager, but the 'action items' gives us a 404 error.

    We have rechecked that the SMTP address of FIM Service is correct in the FIM client. We are using other notification emails that users receive from the FIM Service account - which means Exchange is working and FIM Service account is setup correctly.

    We have applied the latest FIM  build on server and client: 4.1.3508.0

    Unfortunately there is no more information in Event Viewer either.

    thanks

    Friday, March 28, 2014 8:19 PM
  • Ok, The only thing I can think of is that sending email's to FIM Service Service account fails and returns 404.

    Take a look at this, I dont think it's a FIM problem. http://support.microsoft.com/kb/2812355/sv

    Can you verify that you can send email from the same user to that mailbox?

    Saturday, March 29, 2014 8:30 AM
  • Hi,

    Can confirm that we can send email to and from the FIMService account using OWA.

    What should we see in the "Action Items" box? Should it be the 'Accept' or 'Reject' buttons?

    thanks

    Saturday, March 29, 2014 9:11 PM
  • Yes there should be 2 buttons in Outlook "Approve" and "Reject"when you have the plugin installed correctly.

    Sunday, March 30, 2014 3:28 PM
  • Hi,

    This is what the Manager sees in Outlook 2013:

    Then, we press the Refresh button in 'Action Items' and it reloads like this:

    Could this be a bug?


    • Edited by Shim Kwan Monday, March 31, 2014 8:44 PM
    Monday, March 31, 2014 8:43 PM
  • Shim,

    I think Robert may be on to something. When the Outlook client starts, I believe there is a log of the plug-ins that are loaded as this happens. I don't remember if this happens or somehow needs to be configured but I would definitely look at the plug-ins being loaded. Also, in Outlook option, you can view what other plug-ins are enabled, perhaps there is a particular module that interferes with the FIM one.................

    Tuesday, April 1, 2014 3:37 AM
  • I believe that the "Action Items" is some sort of module where outlook is trying to find what you would like do to based on the content of the email. This has nothing to do with FIM plugin. If you don't have the FIM outlook add-ins features try to remove the software and reinstall it using this guide.

    http://technet.microsoft.com/en-us/library/hh322877(v=ws.10).aspx

    Tuesday, April 1, 2014 6:32 AM
  • Hi,

    Have completely removed and reinstalled the FIM add-ins, including the latest hotfix which is meant to work with Outlook 2013 (build 4.1.3508.0).

    We are still seeing the same problem - no 'approve' or 'reject' buttons appear in Outlook.

    Have confirmed that the FIM Add-in is listed under 'Active Application Add-ins' within Outlook. Also have disabled all other add-ins...but still no joy.


    • Edited by Shim Kwan Wednesday, April 2, 2014 3:43 AM
    Tuesday, April 1, 2014 10:31 PM
  • Ok, Can you please supply a screendump of an approval email from outlook?
    Wednesday, April 2, 2014 8:53 AM
  • As you can see, the email arrives, but the "Approve" or "Reject" buttons do not appear.

    I can log on as the user in the FIM Portal and approve or reject the request there.

    So there must be an issue with Outlook 2013 and the FIM add-in? I am also getting the same behavior on another machine running Outlook 2013.


    • Edited by Shim Kwan Thursday, April 3, 2014 8:27 PM
    Thursday, April 3, 2014 8:25 PM
  • I can only agree with you, and it's quite clear that it's a client problem. Is this problem on one or multiple client computers? If only one I would suggest to try installing Outlook, FIM add-ins + FIM update on another newly installed client to verify if the problem still exist.

    /Robert

    Friday, April 4, 2014 6:52 AM
  • Hi,

    Have tried this on 2 different workstations running Outlook 2013; with different operating systems: Windows 2008 R2 and Windows 2012.

    Thanks.

    Friday, April 4, 2014 11:59 PM