none
Problem Upgrading from FIM r2 Release Candidate to FIM r2 (Service and Portal) RRS feed

  • Question

  • Hey everyone, I am trying to upgrade our system from FIM r2 release candidate to FIM r2. We already upgraded the sync service and we had no problems there. However, we are having problems upgrading the portal and service. We install it and everything seems to install correctly. When we go to the website though, it doesn't work. When we go to turn on the FIM service under services, there is nothing there. I'm not sure exactly what is wrong.

    If anyone has an idea of what could be wrong, that would be a great help. If you have any questions about the details of our system, I'd be happy to answer them.

    Thanks,

    Ramiz

    Tuesday, June 12, 2012 6:28 PM

All replies

  • I don't get what you mean by "When we go to turn on the FIM service under services, there is nothing there." - FIMService is not on the list?

    Try running powershell command "get-service FIM*" just to check if FIMService is listed.

    I would try running "Repair" option from Control Panel \ Add/Remove Programs.


    Wednesday, June 13, 2012 9:54 AM
  • Hi ramizandoni,

    When you upgrade FIM to R2, the major upgrade process happens in 2 steps:

    • Uninstall your existing product
    • Install R2

    This process happens automatically and transparently and you can observe it by looking at the setup logs. If you tried to upgrade to R2 and something failed during the second step of major upgrade, then at that point setup uninstalled your product. My guess is that this explains why you don't see the FIM Service in services.

    Did setup terminate prematurely during upgrade?



    • Edited by SaFanek Thursday, June 14, 2012 7:24 PM
    Thursday, June 14, 2012 7:23 PM