locked
Can't open docx and xlsx from my Sharepoint Library RRS feed

  • Question

  • Hello,

    All of a sudden I can't open docx and xlsx in Edit mode from my SharePoint Library anymore. They are all openend in Read Only. The only solution is to open the SharePoint document explorer and open the file or save it as an office 2003 file. Is there someone who had this problem before or knows a solution for this?

    Also the images of Excel and Word 2007 are blank in de Library.

    Thanks in advance.

    Paul
    Monday, December 21, 2009 12:42 PM

Answers

All replies

  • What Office Products (exactly) do you have on your client PC ?
    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Monday, December 21, 2009 1:24 PM
  • We all use Office 2007 SP1 Excel, Word, Outlook, Powerpoint installed.
    Tuesday, December 22, 2009 8:24 AM
  • Hi Paul

    It's a known issue. Follow these steps in your system to resolve this issue.

    Go To Start > Run > Type webfldrs.msi
    Click on Select Reinstall Mode button (not Reinstall button)
    Select all options
    Click on OK
    Now click on the Reinstall button
    Click on OK
    Click on Yes to restart the machine or manually restart the machine.

    Basically this operation will re-install Web Folder component of your system to resolve it.

    Secondly you can try Detect and Repair option in your Word under Help Menu.

    Regards
    Balu
    Sunday, December 27, 2009 3:58 AM
  • The file extension and icon in SharePoint is associated with client application in the DOCICON.XML file, please check that file on your SharePoint server. For detail about that file, please refer to http://msdn.microsoft.com/en-us/library/ms463701.aspx

    • Proposed as answer by Ahmed Madany Tuesday, December 29, 2009 10:16 AM
    • Marked as answer by Paul Barnes Tuesday, December 29, 2009 10:17 AM
    Tuesday, December 29, 2009 8:25 AM
  • You are my hero! Thanks
    Tuesday, December 29, 2009 9:49 AM