locked
Plain Documents folder icon 2 x issues RRS feed

  • Question

  • Problem

    The "Documents" folder appears as a plain icon when accessed via two different locations from the Vista Desktop UI and doesn't work as expected.  However, the redirected "Pictures", "Music" and "Videos" folders which all follow the "Documents" folder, have their correct icons displayed under both issue scenarios and behave as expected.  Any help, greatly appreciated.

    These two issue scenarios are summarized below (see configuration below for summary of environment):

    1. Blank (White File Icon) for "Documents" in Favorite Links or Save As...
    When Windows Explorer is started, the Favorite Links pane (top left pane by default) is showing a blank (white file) Icon for the "Documents" folder/link.  I would expect to see a "special folder" icon (green, open folder with documents inside) for the "Documents" folder/link instead of a blank (white file) icon.  When the blank "Documents" icon/link is

    clicked, nothing happens.  When the blank "Documents" folder/link is right-clicked, no options to open or explore are shown. I would expect the "Documents" folder/link to redirect to the correct folder as opposed to nothing happening.

    The same issue exists when "Documents" is shown through the Save As... dialog box of builtin OS applications, like Notepad etc.

    2. When browsing to "Documents" via the Start Menu or Save As...
    When the resulting Windows Explorer window is loaded after clicking "Documents" from the start menu, the "Documents" folder appears as a plain yellow folder icon. I would expect to see a "special folder" icon (green, open folder with documents inside) for the "Documents" link instead of a blank (yellow) icon.  The folder is showing as having correctly

    redirected, when viewing the "Documents" folder properties and indeed all documents and sub-folders are correctly located and accessible on the network DFS folder.

    The same issue exists when "Documents" is shown through the Save As... dialog box of MS Office 2003 applications.


    Steps followed to Resolve so far (still not resolved)
    Have started with new build, new user, new profile etc. on several occasions but still have the same issue.
    Have checked the .lnk file inside C:\Users\%username%\Links by opening with Notepad, this is encoded for the best part, though it does have 3 references to the redirected folder within the encoding. Not sure how .lnk files can be correctly edited?

    Have checked the desktop.ini file in both C:\Users\%username%\Links and \\domain\users\%username%\Documents, these are provided below:
    (desktop.ini from C:\Users\%username%\Links)
    [LocalizedFileNames]
    Documents.lnk=@shell32.dll,-21770

    (desktop.ini from \\domain\users\%username%\Documents)
    [DeleteOnCopy]
    Owner=%username%
    Personalized=5
    PersonalizedName=My Documents

    [.ShellClassInfo]
    LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
    IconResource=%SystemRoot%\system32\imageres.dll,-112
    IconFile=%SystemRoot%\system32\shell32.dll
    IconIndex=-235

     

    Configuration
    Windows Vista Enterprise (Build 6001: Service Pack 1), with all latest hotfixes.

    Windows Server 2003 R2 x64 Native AD Forest/Domain, using DFS for redirected folders.
     
    Documents folder, redirected via Group Policy & DFS to
    \\domain\users\%username%\Documents
    Pictures, Music & Videos folders follow Documents.
    Desktop folder, redirected via Group Policy & DFS to
    \\domain\users\%username%\Desktop
    Profile.v2 folder, redirected via Group Policy & DFS to \\domain\users\%username%\profile

    • Edited by belpad Tuesday, January 6, 2009 2:20 AM Removed quotes in subject line for this post, a few moments ago.
    Monday, December 8, 2008 11:40 PM

All replies

  • OK, it seems that an issue with DFSUTIL, as described here https://blogs.technet.com/filecab/archive/2008/09/23/storage-tips-how-to-create-namespace-links-in-uppercase.aspx was the root cause of these issues.

     

    DFSUTIL was used to create the "Desktop", "Documents", "Profile" and "Profile.v2" on a W2K3 R2 64-bit Domain based DFS but it creates these folders all in lowercase, despite capitalising the first letter of each of these folders when using DFSUTIL link add.

     

    When all these DFS folders were first deleted from the users DFS namepace (non data destructive) and then recreated using dfscmd /map, the affected users were logged of their Vista machines and logged in again to find both the above issues resolved.

     

    P.S. This also fixes how the "Documents" folder is displayed on the start menu or through explorer, in that, the first letter is also displayed in capitals and not lowercase anymore.

    • Unmarked as answer by belpad Thursday, January 8, 2009 2:56 AM
    Thursday, December 11, 2008 3:56 AM
  • It seems the 2 x plain Documents folder issues above have returned (although the capital D for the Documents folder is not affected and remains in place).

    We have made a change since using the DFSCMD command mentioned above.  Storage quota's have now been applied to the physical user(s) data folder hosting Documents.  Disk quotas were applied using the following command on W2K3 R2 Server:
    dirquota quota add /path:<pathtodatafolder> /sourcetemplate:"<templatename>"

    What's really wierd is that for one of the users, while ensuring the quota management functionality is working correctly, through hitting their quota hard limit, then resetting the peak usage in FSRM (File Server Resource Manager), the issues temporarily disappeared.  After that user then locked/unlocked their Vista machine the issues returned. Subsequent logoff/logons and reboots made no difference.

    We still have users that have not had storage quota's applied to their data folder, so will check if they are getting the same issue and report back.
    belpad
    Thursday, January 8, 2009 3:18 AM
  • Have checked with users who haven't had storage quota's applied and they are also getting the same issues.  However, following a visit to a user with the issue today, then guiding them through offline files and the Sync Center, I noticed the plain icon in explorer (Favorite Links pane) changed from the white file icon (non functioning link) to a yellow folder icon (functioning link). 

    Here the only thing we really did, was to have Explorer open and browse to the users "Documents" folder via their %username% special folder. Then we made a change to one of their Excel spreadsheets and saved the change. We the disconnected and reconnected network connectivity whilst the Explorer window was still open.  Then opened a new Explorer window and this is when we noticed the icon had changed to the yellow icon.

    NOTE: Before the storage quota's were applied, the FSRM component was enabled on the file/DFS server hosting the affected users data and this required a reboot.  I'm now thinking if the FSRM service is causing these issues?


    belpad
    Friday, January 9, 2009 10:20 AM
  • Today, I also tried this test on another user with the plain documents issue but it made no difference and the folder icon stayed plain white (non-functioning).
    belpad
    Sunday, January 11, 2009 10:49 PM
  • Have also tried...
    Stopping the FSRM service on the file server - Plain Documents issues still there;
    Restarted the FSRM service on the file server - Plain Documents issues still there;
    Removed quota from affected users - Plain Documents issues still there;


    belpad
    • Edited by belpad Sunday, January 11, 2009 11:28 PM typo
    Sunday, January 11, 2009 11:02 PM
  • As a long shot, I've also removed a users DFS folders ("Desktop", "Documents", "Profile" and "Profile.v2") and re-established these using DFSCMD, as per my second reply in this post above but the plain folder issues haven't gone away this time.  Storage Quotas are still in place on the users data structure, since previously turning this off made no difference.
    belpad
    Thursday, January 15, 2009 3:44 AM
  •  

    Here's an update of where these issue are at.  The issues seem to have been resolved for now.

    So what’s changed?
    A few days ago, I changed NTFS permissions on the DFSRoots/users/%username% folder.  They were previously set in accordance with guidelines at MS KB907458, since we’ve enabled ABE on the file servers.  However, a few days ago I completely removed NTFS permissions on DFSRoots/users/%username% where the access control list had %username% as an entry (or ACE).

    Immediately following the above change, the issues were still there.  Then about 4 hours later, the Documents folder icon changed from plain white (non-functioning) file icon to a yellow (functioning) icon within the Favorite Links pane of Windows Explorer.  The Documents link would also work when accessed via an Open or Save As… dialog box, when previously this did not.  This is a good step forward but I’d still expect to see a "special folder" icon (green, open folder with documents inside) for the Documents folder link.

    I also tried deleting the local/roaming user profile and recreating a brand new roaming profile, but the Documents icon, still remained yellow and functioning

    This behaviour remained until my Vista PC was rebuilt today and starting with a brand new roaming Profile again.  Now the Documents link icon is correct, showing a "special folder" icon (green, open folder with documents inside) and is fully functional.

    Although not convinced that changing the NTFS permissions on the DFSRoots/users/%username% folder was the thing that resolved this issue, we do think this could be related to the way the “Default User” profile is created in our Vista image.  Thus affecting subsequent logins to Vista once fully built.  We have revisited our Vista image and have ensured all the “special folders” such as Documents, Pictures etc… are set exactly the same as they would be in an “out of the box” Vista configuration.

    Although we have not found or posted the definitive answer here, hopefully the information above helps others with similar issues?  I will mark this post as the answer and monitor for repeats/returns of these issues and report back as appropriate.

    Any comments from MS?


    belpad
    • Marked as answer by belpad Thursday, January 22, 2009 12:03 AM
    • Unmarked as answer by belpad Monday, November 23, 2009 10:26 AM
    Thursday, January 22, 2009 12:02 AM
  • We seem to be re-experiencing the same issue here.  At one stage the Documents folder returned to the custom green folder and was operating as expected but now it has returned to its former plain folder and will not open upon clicking.  Further to this I have found that if you right click and select Explore or Open the folder will open as a new window.  From this I take that it is not a permission issue but rather an issue with the link.

    I have noticed that the Pictures link in the links folder has the correct path to the redirected folder. If I create a link outside of the links folder with the correct path to the redirected Documents folder (which works when I double click) once I place the link into the links folder it changes and I can no longer see the redirect target in the link.  Double clicking the Documents link in the links folder still works but clicking the Documents link in the top left setion of explorer does not.

    No answers sorry just some observations that I hope may lead someone to say "Oh yeah I know what that's all about..."
    Monday, November 23, 2009 2:53 AM
  • OK I've unmarked my previous comment above as an answer, since Kel has replied, highlighting the issue is back again.

    Hopefully someone out there might be able to shed some light on this?
    belpad
    Monday, November 23, 2009 10:30 AM