locked
Very High Cpu usage associated with RAID drive RRS feed

  • Question

  • I've been having a major problem with my system.  The observed effect is that all actions taken either slow down massively (as in 3-5 MINUTES to respond to right click on the desktop) or outright hang.  When I am able to get the task manager to turn on I see very high cpu utilization (40-80%) but no process in the process tab is using more than 2% except the system idle process.  This all occurs even when no applications at all are running (as shown in the applications tab).  Have experienced complete system hangs where even the task manager wont show up and under forced shut down (when I can get that to occur) appears listed as 'not responding'. 

    There are a number of interesting additional features to this problem.  First of all it occured on a brand new system (well, new mobo, cpu, and new boot drives).  Second, since first seeing this problem some 4 weeks ago, I have gone through 3 motherboards, and 2 cpus.  I now have the exact same problem with a different motherboard (and different brand, first brand Asus P8p67, current brand Gigabyte GA-Z68XP-UD4), and different cpu type (first type E5000, 2nd type i5 core 2500K).  Third to be clear this is a brand new install of OS, drivers, etc.  In fact its a brand new OS source as well -- was using win7pro -x64 upgrade, now win7 pro x64 (not upgrade).  I've installed a few apps (adobe cs3, photoshop cs5, msOffice 2007 ultimate, but nothing else no fancy widgets of any kind).  The problem recurs within 24 hours of new install. 

    My system (as of now): Gigabyte GA-Z68XP-UD4, Intel i5-2500K, 16GB Corsair DDR3 1600 MHz (also had this problem with different RAM set), nVidia 8400GS (last remnant of old system, quite old graphics card 4 years?, shouldn't be a problem), 650 Watt Corsair power supply (also old), and various hard drive configurations:  base: 1 pair of matched seagate drives 500 GB configured as RAID1.  additional: 2 pairs of drives configured as RAID1 (new hitachi 1.4TB replacing recent but seemingly problematic Seagate 1 TB pair), and RAID0 (old: WD 250GB each).  All of these are attached to the Intel RAID controller on the mobo.  With this mobo that is apparently integrated into an Intel Z68, with the previous mobo (ASUS P8P67) they were also connected to an intel RAID controller, but it was a different chip (looks like the Z68 integrates that other chip plus some other bus functionality).

    The good news:  I can turn the problem on and off -- when I only have the boot drive (pair, RAID1) connected, there is no problem.  That's why I'm currently able to post to this forum.  When I connect the RAID0 pair (WD pair, old), the problem arises within about 20-30 minutes of boot regardless of what else is happening (seemingly).  I have yet to test booting with the two RAID1's and no RAID0, that's next up.  So it could be the RAID0 drives themselves, but I'm starting to doubt it.  Why? see next

    Some other info: immegiately upon installing the OS, after vendor supplied driver install, I ran windows update.  This time I only installed 'urgent updates' including IE9.  In researching this problem I have seen a few references to a windows update that can apparently manifest in a way very similar to what I'm experiencing, although none of the refs I've seen have narrowed it down to a link to the RAID system.  Most seem to be chasing software issues in Office, networking apps, or overclocking, none of which I'm doing. 

    I did suspect some kind of virus or malware (and wondered if it was sticking to my system by virtue of staying with the same hard drives since the start of the problem), except... 1) brand new install of Kaspersky 2011 with updates reports no problems (as of this morning), second its not quite true that I've had the same hard drives.  First of all the boot drives have been reformatted (a couple of times), and wipe deleted (all zeros write).  Even the WDs have been reformatted, and the other pair of drives is brand new but I've only plugged them in physically and logically, haven't used them or even initialized them. Windows Disk Mgmt reports them as uninitialized when they are connected and I still have the problem.  Actually it says the same thing about the RAID0 set too and too, haven't used the RAID0 set as in reading/writing to them, and nonetheless problem arises.

    My guess is an interaction between the Intel RAID controller driver (I'm using the vendor supplied one, not clear if there is an update), and the Windows update.

    I see one problem in this forum that sounds very similiar, but its dated 2007, and is refering to the IHC7 Intel Raid Controller and the ASUS P5B mobo -- which was my last working configuration, and worked fine with a pair of raid drives, 1 RAID1 pair, and 1 RAID0 pair (consisting of the same WD 250 GB drives I've still got).  The Intel site is not very responsive but I've yet to find any indication of a problem they've seen with the RAID controller.  In fact, I'm quite surprised at how few references there are to this problem on the net in general given how massive a shutdown of my system I have, and how 'not latest greatest' my system is.

    So.... thoughts?

    Thanks in advance,

    Mike

     

    Thursday, July 7, 2011 3:02 PM

All replies

  • I'm going to add information as I find it. 

    First of all I found this thread: http://social.technet.microsoft.com/Forums/en-US/w7itproperf/thread/534a7384-4009-44db-900e-cdff92a92741 which sounds very much like its the same problem, or at least some of the problems reported may be the same.  In that thread there is an idea that the problem might be the nVidia graphics card.  That can't be it.  The ONLY thing that remains the same from my computer the worked for two years is the nVidia graphics card.  That working computer also had two raid arrays, 1 RAID1, and 1 RAID0, and was running Win7x64 upgraded (but fresh and clean) from WinXPpro x64.  It was a P5QC mobo, with 8GB ram (corsair DDR2, but I had this problem on the new system with a completely different RAM vendor, type and speed, which persists with the new DDR3 Corsair 1600MHz (again different speed)).  More importantly on that thread we see that this problem goes back to 2007, as does my graphics card, yet my graphics card worked fine in the old system, with old drivers.  The new system fails with the OLD card, and old drivers, as well as with the old card and the latest drivers.

     

    What has changed between the old working system and the new?  I never did Windows update on the old one, just got out of the habit when I upgraded.  Conversely in building this new one, I thought 'well, I should get the latest just to be sure...'.  I'm going to test this Win Update problem shortly, if the restore point is viable.

     

    Unlike most of the others posting, I have very minimal software installs.  I never go in for gaming, or fancy internet stuff, and never use a different browser.  I don't overclock, and I don't run quirky software with unverifiable provenance. 

     

    Mike

     

    Thursday, July 7, 2011 6:46 PM
  • Looks like Windows update as the cause has been eliminated.  I rolled back to just after the OS install, only additional components being mobo supplied drivers.  Then I plugged in the RAID0 pair, and browsed online (wikipedia) for a while.  30-40 minutes later the system became all but unuseable -- massive cpu activity, extremely delayed response to mouse button presses.  Was able to shut down using ctrl-alt-del.
    Thursday, July 7, 2011 7:55 PM
  • LatencyMon might help, it'll show up which driver has problems and is forcing the kernel, and CPU, to work hard to compensate.
    Thursday, July 7, 2011 10:29 PM
  • Hi,
    
    According the issue, I recommend that you may try to run Windows 7 in safe mode. Since Kaspersky detected no virus. You can also narrow down whether this problem is caused by drivers.
    
    If the issue disappears in safe mode, I suggest that you may upgrade your BIOS and motherboard driver.
    
    In case the problem occurs again, you may use Process Explorer to collect the some information about dll files, then we can analyze the log to find some clue:
    
    1.	Download the Process Explorer form the following :
    http://technet.microsoft.com/en-us/sysinternals/bb896653
    2.	Run Process Explorer, click Agree to open it.
    3.	Click View on the Tool menu, and select “Show Lower Pane”.
    4.	Click View on the Tool menu, click “Lowe Pane View”, and select “DLLs”.
    5.	Just run Windows 7 without any other software.
    6.	Find the process which occupied a great quantity resource.
    7.	Then highlight the process in the left pane.
    8.	Click File in the Toole menu, and then select “Save As…”.
    9.	Save and upload it via SkyDrive, then post a link here.
    http://explore.live.com/windows-live-skydrive?wa=wsignin1.0
    
    
    Hope that helps
    


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”


    • Edited by zhen tan Friday, July 15, 2011 2:28 AM
    Tuesday, July 12, 2011 3:16 AM
  • Hi,

    I've been having the exact same problems. Also running Win7x64, System includes among others a RAID setup that I've never really looked into to be honest, and a relatively new nVidia graphics card. Since yesterday, the whole system seems rather slow, with CPU usage constantly around 40-50%. Additionally, since the graphics card was installed, I've had some random crashes, especially when browsing websites that use Flash in some way (youtube, for example). This sounds like it may be the same issue.

    Keep me posted.

     

    Kai

     

    edit: tried LatencyMon, got the following output:

     

    One or more DPC routines that execute on behalf of drivers running in your system appear to be causing serious problems making your system unsuitable for processing real time audio. You are likely to experience audio dropouts, clicks and pops.
    
    
    
    Highest DPC routine execution time (µs): 5892
    
    Responsible driver:            nvlddmkm.sys (NVIDIA Windows Kernel Mode Driver, Version 267.59 , NVIDIA Corporation)
    
    DPC count (execution time <500 µs):    10466052
    
    DPC count (execution time 500-999 µs):  64792
    
    DPC count (execution time 1000-1999 µs): 2039252
    
    DPC count (execution time 2000-3999 µs): 45479
    
    DPC count (execution time >=4000 µs):   11
    Going to update my drivers first, then see what happens.

    Tuesday, July 12, 2011 4:16 PM
  • Hi All

     

      To Zhen Tan: Yes I have admin priviliges on my machine.  No I have not installed any third party browsers. 

     

      Why would I want to install content advisor?  I have no need of a microsoft nanny, thanks anyway.  More importantly as I think I made awfully darn clear, the problem is in no way associated with browsing web sites, rather it is associated with the presence or absence of more than one raid drive.  To explain why I say this: When I first had this problem (3 mobo's ago = 1 month) the first occurence of it, I leapt at the idea that it might be caused by a virus or other problem acquired over the internet.  So in all future motherboards I 1) waited to attach a network, 2) ensured the presence of an additional firewall/virus protector beyond that present in windows 3) browsed only the safest of sites, and kept that to a minimum.  Try to understand, I had a computer that would not remain stable for more than 45 minutes after OS install, and this problem had been going on for a month, with all kinds of hardware work happening constantly (there were other mistakes made because I got so frustrated).  Under these conditions hopefully it is fairly obvious that I wasn't out willy-nilly browsing all over the internet.  It could be that it is associated with adobe flash player -- its hard to avoid sites that want to install it these days.  At one point in this process I refused that at all attempts, and still ended up with a problem (though I can't swear it was the same problem), and it is true that it is installed in the current setup which can exhibit the problem (when I connect an additiona raid pair).  But... If there's a problem with adobe flash player and win7pro x64 I sort of think it would be pretty wide spread problem, in fact it would be a massive problem, and it would have been addressed heretofore.  Furthermore that would not explain why having only a boot drive raid pair (on which flash is installed) does not show the problem, but plugging in a second raid pair (but not even initializing it disk mgmt, much less using it), immediately causes a problem.  It's not the flash player.

       There does seem to be a persistent association with nVidia graphics cards, but I really don't think this is the issue.  Why?  because I had exactly the same card that is in my current system in my last working computer and it worked for a good two years.  It had the same graphics driver, the same OS, the same raid configuration (as I want to have in this one: 1 small boot raid1 pair, 1 large storage raid1 pair, and 1 fast raid0 pair).  It had the same power supply and the same case.  What was different?  The motherboard, and hence the associated rev of the intel raid storage controller, also different ram DDR2 800 in the old vs. DDR3 1600 in the new.  Same amount of RAM in the current configuration.  So... it really doesn't seem likely that its the nVidia card.   Of course it could be an interaction between the nVidia driver, and the raid controller driver or hardware (like competing for bus bandwidth, except that the graphics card and raid controller have different connectivity into the cpu), and others have reported a similar problem dating back a few years, so this could be older rev graphics card (like mine) and older rev intel controller (like my old computer).  But no one on those threads has tied the problem in with the raid system at all, so its hard to say.  Most are busy chasing down issues with all kinds of crazy software they've installed.  And again, if its the graphics card, why does the problem go away when only one raid pair is installed, and immediately return when a 2nd pair is added (without initializing or using)?  Answer... it has nothing to do with the graphics card.

     

        To both the flash player idea, and the graphics card idea, one has to ask: why doesn't this show up else where if that's the problem?  My old working system had both of these, as do millions of other computers.  My old working system also of course had three raid pairs, and it worked.  So what's different?  Intel controller, intel controller driver.  I am posting this to intel as well, by the way.

     

       Now for my question: did you read the post?

     

    To Satrow:  in general I like this idea, however there is a problem: right now I have found a configuration that does not exhibit the problem, which I desperately needed, because I have other work that needs to get done.  So running this program under this configuration will not show any problem.  Conversely, I know precisely how to get the problem to manifest -- plug in a raid drive pair.  And, re-iterating the above, this occurs with a completely clean OS install, no other drivers installed, not even the nVidia graphics card driver (only the default windows drivers).  So there aren't a lot of candidates for what the problem might be -- it has something to do with the raid system, could be drivers, could be hardware.  I'm happy to change that opinion if someone else comes along whose actually experienced this problem and knows what causes it.  Conversely, its pretty clear from browsing this site that there are some pretty serious (from the point of view of the user) issues lurking around, related to 'massive cpu activity' that have not been solved, and have been around for a number of years.  That makes me pretty concerned that there is a rare but nasty bug in the OS that it is more convenient to ignore.

    In any event, when I get the work done that has to get done, which has nothing to do with fixing my computer, I will most likely follow up on your suggestion, assuming I haven't heard something more authoritative about my problem before then. 

    So thanks for helping.

     

    Tuesday, July 12, 2011 7:30 PM
  • Hi,

     

    Oh, I'm awfully sorry for my mistake, I have edited my reply. Please refer and try to collect some detail information about this problem.

    I would keep on focusing this thread. And do my best to assist you for this problem.

     

    Thanks for understanding


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, July 15, 2011 2:27 AM
  • Thanks Zhen Tan -- your edited post sounds very helpful.  I'm not sure that I'm going to be able to follow up on it in a short time frame -- basically I have some real work that needs to get done and my current setup doesn't prevent me doing that, so that's the priority.  I do want to get this problem solved, and get back to the kind of computer I want to have, so I will follow up on what you wrote.  I'm just not sure when right now.  Maybe this weekend.

     

    Thanks again though, that sounds very constructive.

    Mike

     

    Friday, July 15, 2011 5:21 PM
  • To Kai -- please let us know what you find out.  It sounds like LatencyMon has so far only confirmed what you basically knew.  But I'd be quite curious to know if there is a specific driver that caused the problem.

     

    Mike

     

    Friday, July 15, 2011 5:25 PM