none
RCDC UocIdentityPicker, Search scope not displaying RRS feed

  • Question

  • Reading this,  http://social.technet.microsoft.com/Forums/en-US/ilm2/thread/c57e10e6-9eb6-4acc-8a51-2b2dc86aa7e4 , what I am trying to do should be straight forward.

    Basicly I've got a custom resource, with a custom RCDC with a UocIdentityPicker which I want to use with a searchscope for another custom resource.

    <my:Control my:Name="CustomResourceOne" my:TypeName="UocIdentityPicker" my:Caption="{Binding Source=schema, Path=CustomResourceOne.DisplayName}" my:Description="{Binding Source=schema, Path=CustomResourceOne.Description}" my:RightsLevel="{Binding Source=rights, Path=CustomResourceOne}">
    	<my:Properties>
    		<my:Property my:Name="ReadOnly" my:Value="false" />
    		<my:Property my:Name="Required" my:Value="{Binding Source=schema, Path=CustomResourceOne.Required}" />
    		<my:Property my:Name="ColumnsToDisplay" my:Value="DisplayName, ObjectType" />
    		<my:Property my:Name="AttributesToSearch" my:Value="DisplayName" />
    		<my:Property my:Name="Value" my:Value="{Binding Source=object, Path=CustomResourceOne, Mode=TwoWay}" />
    		<my:Property my:Name="Mode" my:Value="MultipleResult" />
    		<my:Property my:Name="UsageKeywords" my:Value="AllCustomResourceOneUI" />
    		<my:Property my:Name="ListViewTitle" my:Value="{Binding Source=schema, Path=CustomResourceOne.Description}" />
    		<my:Property my:Name="ObjectTypes" my:Value="CustomResourceOne" />
    		<my:Property my:Name="Hint" my:Value="{Binding Source=schema, Path=CustomResourceOne.Hint}" />
    	</my:Properties>
    </my:Control>

    Usage Keyword: AllCustomResourceOneUI

    It shows up looking like this:

    But it should look more like this (obviously not the same since i borrowed the screenshot):

    There are two sets:

    One set which holds all the resources to be searched

    One set which holds the searchscope who's UsageKeyword is "AllCustomResourceOneUI"

    There are two MPR's which grant permission to All Users to Read both sets, which include reading all attributes.

    Copying the direct link to the resources in the sets and trying them out with my test user, I can read all the values. Yet the searchscope does not show up on the RCDC.

    I'm completely stuck on this, from what I can tell it should be working.

    Any help is greatly appreciated.

    Best Regards

    /Daniel

    Tuesday, February 12, 2013 2:14 PM

All replies

  • Hi Daniel

    try to use the following instead

              <my:Property my:Name="Filter" my:Value="/CustomResourceOne"/>
    

    and remove the following

    		<my:Property my:Name="UsageKeywords" my:Value="AllCustomResourceOneUI" />


    This should bring up the expected screenshot.

    You can then tweak the search scope to be shown on the top.

    The following link is the best out there for RCDC Reference

    http://technet.microsoft.com/en-us/library/ee534918(v=ws.10).aspx


    Regards Furqan Asghar

    Tuesday, February 12, 2013 8:51 PM
  • Thanks, that sortof works. It looks like this: http://i.technet.microsoft.com/dynimg/IC394743.gif which is to be expected. And I see my results. So atleast that part of the permissions are ok.

    But I really need to be able to search through these using searchscopes.

    The RCDC page mentions this: You must also create search scopes with the UsageKeyword property set to Person and Group.

    Why Person, and why Group? Obviously to search through them, but how does: Creating a searchscope with a string attribute (UsageKeyword), completely change the behavior of the RCDC (also setting the search scope there) Obviously "Person" and "Group" must already be defined somewhere else for permissions.

    Wednesday, February 13, 2013 2:13 PM
  • You will have to give users access to the Search Scope, I think that is your problem

    Create a Set with the filter /SearchScope[UsageKeywords = 'usagekeyword'] and an MPR to grant access to it.

    btw: I have noticed that if you use Search Scopes referred through keywords (like you do), and you have a filter with e.g. a certain employee type on Person, you can fool the system by typing in something and resolving it. I those cases the Search Scope has no effect, only the ObjectTypes, ResultObjectTypes and AttributesToSearch is used.

    Setting the filter on the RCDC instead of a UsageKeyword to a Search Scope resolves that.

    Wednesday, February 13, 2013 2:55 PM
  • Hi, best I can do is:
    A set, which I already have.

    /SearchScopeConfiguration[UsageKeyword = 'keyword']  (I have checked that my searchscope appears in the results)

    And I have this MPR:
    Security: Users can read CustomResource Search Scope
     Grants Permission: True
     Read Resource: True
     Requestors:
      All Users And Groups
     Target Resource:
      The above mentioned set
     Resource Attributes:
      All Attributes

    But it still dosn't show up properly, this is confusing the heck out of me.

    Friday, February 15, 2013 12:23 PM
  • Instead of All Users and Groups in the requestors, use All People

    I know it shouldn't make any difference but might as well try it.

     

    Also if there is a need for something for all the people in the portal to see, there is no need to create all this for the Usage Keyword. just use the 'BasicUI' as the Usage Keyword and it should be working for all the people.

    Have you run 'iisreset' and checked again?


    Regards Furqan Asghar

    Saturday, February 16, 2013 11:01 AM
  • Tried changing the MPR requestor set to All People, ran iisreset. Sadly, it did not make a difference.

    All people will eventually be able to see, but I'm using the keywords to hide things from users while they are not yet fully implemented.

    Monday, February 18, 2013 7:53 AM