locked
Outlook 2016 mailbox issue RRS feed

  • Question

  • I added a user's mailbox so that it would open the additional mailbox along with my own mailbox, but now I want to take it out, and it is impossible.  If I right-click it, and select Close "<user mailbox>", it tell me this:

    So then, I go to the account settings like it says, and the only mail account there is mine.  If I remove it, I will not be doing myself any favors.  So the only other thing that made any sense was to go to the account settings and then "more settings", and then select the advanced tab, and remove the other mailbox from the "Open these additional mailboxes" field.  The only problem is, there is nothing there!  (as in the image below):

    So I even tried creating a new profile in Outlook - I removed my existing profile, and then created a new one, and it STILL opens the other mailbox.  Eventually the other mailbox will be removed from Exchange entirely, and then I am not sure what will happen...  But there must be something in the registry, or in one of the c:\users\<username>\appdata\*.* subfolders, that is preventing the other mailbox from being removed even when creating a new profile.  Is this a bug, or is there something I am missing? 

    Many thanks,

    Sam S.

    Tuesday, May 10, 2016 2:18 PM

Answers

  • The other mailbox is being automatically added to your Outlook because you have full access permissions to that mailbox. To retain the full access permission, but not have the mailbox automatically added to your Outlook, go into Active Directory and the account to which you have full access, click the Attribute Editor tab, and go to the attribute named msExchDelegateListLink. You'll see your address listed there and you should remove it.

    Or you can just remove yourself from having Full Access to that other mailbox.

    -Peter

    Tuesday, May 10, 2016 6:44 PM
  • Hi Sam,

    As Peter says, it is an mailbox AutoMapping feature which would add shared mailbox automatically in Outlook if you have full access mailbox permission on it.

    The AutoMapping feature is controlled by the msExchDelegateListLink attribute in AD. You can remove this attribute for this shared mailbox to disable AutoMapping. Please notice that remove this attribute would bot remove the full access permission in Mailbox level.

    Alternatively, we can just run the following command in Exchange server to remove both Full access permission and AutoMapping feature for shared mailbox:

    Remove-MailboxPermission -Identity SharedMailbox1 -User YourName -AccessRights FullAccess


    Regards,

    Winnie Liang
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, May 11, 2016 9:52 AM

All replies

  • The other mailbox is being automatically added to your Outlook because you have full access permissions to that mailbox. To retain the full access permission, but not have the mailbox automatically added to your Outlook, go into Active Directory and the account to which you have full access, click the Attribute Editor tab, and go to the attribute named msExchDelegateListLink. You'll see your address listed there and you should remove it.

    Or you can just remove yourself from having Full Access to that other mailbox.

    -Peter

    Tuesday, May 10, 2016 6:44 PM
  • Hi Sam,

    As Peter says, it is an mailbox AutoMapping feature which would add shared mailbox automatically in Outlook if you have full access mailbox permission on it.

    The AutoMapping feature is controlled by the msExchDelegateListLink attribute in AD. You can remove this attribute for this shared mailbox to disable AutoMapping. Please notice that remove this attribute would bot remove the full access permission in Mailbox level.

    Alternatively, we can just run the following command in Exchange server to remove both Full access permission and AutoMapping feature for shared mailbox:

    Remove-MailboxPermission -Identity SharedMailbox1 -User YourName -AccessRights FullAccess


    Regards,

    Winnie Liang
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, May 11, 2016 9:52 AM