Windows 7 SP1 (x64) Fails to Download (Error Code: 0x800F081F)


  • Hello,

    I have been having trouble downloading Service Pack 1 for Windows 7 Ultimate (x64). The download stops at 24% before failing completely, resulting with the errorcode 0x800F081F. I have tried getting it through Windows Update as well as the standalone installer. I downloaded the System Update Readiness Tool, but it didn't show up with any problems I don't think (it's supposed to run automatically, but no new error messages came up or anything after I installed the Readiness Tool and tried to download the SP1 again). I have run the "SFC /scannow" command prompt, which gave no error messages. I have also download the Microsoft Fix It tool, which did detetct problems with the Windows Update components, but it doesn't seem to be applying the fixes. I go through the wizard, and it says that the fix is successfully applied each time, but when I run the tool again, it keeps detecting those same problems.

    Any help would be greatly appreciated, as every other update is fine - it's only SP1 that is causing me issues.

    Tuesday, February 14, 2012 11:25 PM