none
Internal and exteral message size

    Question

  • I have 4 Exchange severs 2013  (DAG) I need  to setup internal message size between users 5MB in same domain , External message size 20 MB when users send or receive message from internet or external domains   


    hass

    Friday, March 3, 2017 1:22 PM

Answers

  • I have 4 Exchange severs 2013  (DAG) I need  to setup internal message size between users 5MB in same domain , External message size 20 MB when users send or receive message from internet or external domains   


    hass

    https://technet.microsoft.com/en-us/library/bb124345(v=exchg.150).aspx

    Set the transport config and all connectors to 20MB ( receive and send)

    Then create a transport rule that drops messages greater than 5MB when sent from an internal sender to an internal recipient.

    P.S. If you internet messages to be truly 20MB, then set the transport config and connectors to 25/26MB to account for content encoding padding on those messages.

    Friday, March 3, 2017 1:41 PM

All replies

  • Hi,

    This example uses the Get-User command to find all users in the Customer Service department, and then uses the Set-Mailbox command to change the maximum message size for sending messages to 2 MB.

    Get-User -Filter "Department -eq 'Customer Service'" | Set-Mailbox -MaxSendSize 2MB
    

    Set the limit on Recieve and send connector via below commands:-

    1. set-recieveconnector -identity"" -MaxMessageSize 20MB

    The valid input range for this parameter is from 65536 through 2147483647 bytes.

    2. Set-SendConnector "Contoso.com Send Connector" -MaxMessageSize 20MB 



    MCSA Office 365 | MCSA Exchange server 2010 | Red Hat Certified Engineer | https://www.linkedin.com/in/abrar-kaberi-46a483102/




    • Edited by Akabe Friday, March 3, 2017 1:46 PM
    Friday, March 3, 2017 1:33 PM
  • I have 4 Exchange severs 2013  (DAG) I need  to setup internal message size between users 5MB in same domain , External message size 20 MB when users send or receive message from internet or external domains   


    hass

    https://technet.microsoft.com/en-us/library/bb124345(v=exchg.150).aspx

    Set the transport config and all connectors to 20MB ( receive and send)

    Then create a transport rule that drops messages greater than 5MB when sent from an internal sender to an internal recipient.

    P.S. If you internet messages to be truly 20MB, then set the transport config and connectors to 25/26MB to account for content encoding padding on those messages.

    Friday, March 3, 2017 1:41 PM
  • If you limit internal message size to 5MB, you can't have larger than that for inbound external messages.  Outbound settings (on the Send connectors) can be 20 MB, but with a 5 MB send size limit on the internal sender, you'll never get a 20 MB message outbound.  Size limit settings are in the following areas:

    • Global Transport Settings - set with the "Set-TransportConfig -MaxReceiveSize <size> -MaxSendSize <size> -MaxRecipientEnvelopeLimit <count>" command
    • Send Connectors - set with the "Set-SendConnector <connector name> -MaxMessageSize <size>" command
    • Receive Connectors - set with the "Set-ReceiveConnector <connector name> -MaxMessageSize <size>" command
    • Per Mailbox - set with the "Set-Mailbox <mailbox alias> -MaxSendSize <size> -MaxReceiveSize <size>" command

    How these work:  Global settings trump everything - you can't have any of the other settings higher than the global setting and expect to receive the larger message. Then come the connector settings - if you have smaller settings on your connectors, inbound and outbound messages will be limited in size (though internal mail can be larger, through the global setting).  And finally, the mailbox settings come into play.

    As I note, you can make the lower precedent settings a lower value, but setting them to a higher value will get messages blocked due to the higher precedent settings.  So you can't have in and outbound email settings (connector level settings) set to a higher setting than the global setting (for your Internal setting).  What you are asking for can't be achieved.


    Will Martin ...
    -join ('77696c6c406d617274696e2d66616d696c6965732e6f7267' -split '(?<=\G.{2})' | ? { $_ } | % { [char][int]"0x$_" })


    Friday, March 3, 2017 1:53 PM
  • If you limit internal message size to 5MB, you can't have larger than that for inbound external messages.  Outbound settings (on the Send connectors) can be 20 MB, but with a 5 MB send size limit on the internal sender, you'll never get a 20 MB message outbound.  Size limit settings are in the following areas:

    • Global Transport Settings - set with the "Set-TransportConfig -MaxReceiveSize <size> -MaxSendSize <size> -MaxRecipientEnvelopeLimit <count>" command
    • Send Connectors - set with the "Set-SendConnector <connector name> -MaxMessageSize <size>" command
    • Receive Connectors - set with the "Set-ReceiveConnector <connector name> -MaxMessageSize <size>" command
    • Per Mailbox - set with the "Set-Mailbox <mailbox alias> -MaxSendSize <size> -MaxReceiveSize <size>" command

    How these work:  Global settings trump everything - you can't have any of the other settings higher than the global setting and expect to receive the larger message. Then come the connector settings - if you have smaller settings on your connectors, inbound and outbound messages will be limited in size (though internal mail can be larger, through the global setting).  And finally, the mailbox settings come into play.

    As I note, you can make the lower precedent settings a lower value, but setting them to a higher value will get messages blocked due to the higher precedent settings.  So you can't have in and outbound email settings (connector level settings) set to a higher setting than the global setting (for your Internal setting).  What you are asking for can't be achieved.


    Will Martin ...
    -join ('77696c6c406d617274696e2d66616d696c6965732e6f7267' -split '(?<=\G.{2})' | ? { $_ } | % { [char][int]"0x$_" })


    unless you create a transport rule for the internal messages  :)

    Friday, March 3, 2017 1:56 PM