Disk Cleanup won't run (doesn't start) RRS feed

  • Question

  • ultimately i'm trying to cleanup the Windows Installer and SxS folders, but i can't seem to get the cleanup utility to start.


    Panasonic ToughPad G1

    Windows 7 x86 (latest updates)

    i have 3 of these toughpads and the disk cleanup only works on 1 of them. the other two, i've tried running it from the disk properties panel (on the general tab), i've tried searching "disk cleanup" and running it as admin, and then i just browsed to the cleanmgr.exe in sys32 and ran that as admin.  in every case, i get a half-second of hourglass and then nothing.

    on the computer that does work, i can just hit the button in disk properties (as a normal local user) and it starts scanning the disk.

    i have no idea what i'm missing.  any thoughts??

    ~if this were /. this sig would be funny

    Friday, October 17, 2014 3:35 PM

All replies

  • Click Start > type cmd right click and select Run as Administrator

    Command Prompt will open with administrator privilege.

    type sfc /scannow and hit Enter

    If not working, refer this link.


    Mark as Answer if it's worked. Thanks. Balamurugan_Subramaniyan

    Friday, October 17, 2014 11:39 PM
  • Hi,

    Have you tried the suggestion mentioned by Balamurugan? Any result?

    Meanwhile, according to this blog


    disk cleanup plugins for Disk Cleanup are listed under the registry entry:


    I suggest you check whether there're some corruptions or permission issue for the registry entry in the problematic pcs, you can compare it with another one (which is functioning fine).

    or some third party tool you installed conflict with the built-in disk cleanup tool.

    Yolanda Zhu
    TechNet Community Support

    • Edited by Yolanda Zhu Monday, October 20, 2014 6:20 AM
    Monday, October 20, 2014 6:20 AM
  • yep, that was one of the first things i did - everything came up clean

    ~if this were /. this sig would be funny

    Wednesday, October 22, 2014 1:33 PM
  • i've logged in as a new domain admin (meaning it created a new profile) and i still couldn't get it.

    it's also a very clean machine - only office, autocad, and sql management tools. we don't have any third party utilities or other clutter. and all the machines are based on the same image.

    it's not a huge deal, but i appreciate your suggestions. :)

    ~if this were /. this sig would be funny

    Wednesday, October 22, 2014 1:37 PM
  • Did the computers-in-question come with Win7 32-bit preinstalled?

    ~Robear Dyer (PA Bear) MS MVP-Windows Client since 2002 Disclaimer: MS MVPs neither represent nor work for Microsoft

    Thursday, October 23, 2014 11:13 PM
  • when your reply works, how do you get the program to run on base, in my opinion reg edit only open from cmd, and I am curious about sfc too now.
    Sunday, May 22, 2016 10:28 AM