locked
Remove KMS server and delete _VLMCS recvord permanently from the DNS. RRS feed

  • Question

  • Dear Experts,

    In our environment, we are facing the issue with Windows Server 2008 R2 OS. The _VLMCS records are getting registered in DNS automatically. everytime we delete it, we will find the same key is registered in DNS after some days.

    I followed the following steps

    1. run 'slmgr -dli' from an elevated comand prompt on the server and found that the server against which the _VLMCS DNS key is registered and found the below.

    • Key management service is enable on this machine
    • current count : 0
    • listening in port :1688

    From this, i understand that KMS service is enabled on this machine but this server is not activating any client (OS) in our domain as the current count is 0.

    hence I took the decision to activate windws on that server using the product key, then uninstall KMS server and delete the _VLMCS DNS record manually.

    Now, after few days, again we noticed that the _VLMCS DNS record is appearing against another (newly rebuilt) server. It seems, when the OS was installed for that server, the engineer has has entered the KMS key instead of VLK and so, the _VLMCS DNS record is getting created again automatically.

    To get rid of the above issue permanently (even if a new OS is installed using the KMS key, it should not create any _VLMCS DNS record in the domain) we have to follow the steps mentioned (change teh DWORD registry key to disable ) in the thread below.

    http://social.technet.microsoft.com/Forums/en-US/winservermanager/thread/dfaffe75-2e18-4746-b60e-023f6463c7eb/

    but unfortunately, i am unable to locate the below key in Win 2008 R2 server. The below key exists in Win 2008 server. Please specify the corresponding registry for Win 2008 R2 server.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SL. 

    I have planned to do the registry changes only to fix it permanently and believe it will do. Please provide any other suggestion that will help fix this issue permanently 

     Thanks!


    Thanks

    Tuesday, February 7, 2012 10:18 AM

Answers

  • I got IT.

     

    Using the Slmgr.vbs script to disable automatic DNS publishing is preferred, but you can also perform this task by creating a new DWORD value called DisableDnsPublishing in the registry, and set its value to 1. This value is at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform in the registry. To re-enable the default behavior for publishing of KMS SRV records to DNS, set the value to 0.

    Thanks!


    Thanks

    • Marked as answer by MSSQL-DB Tuesday, February 21, 2012 10:44 PM
    Tuesday, February 21, 2012 10:44 PM