none
ConnectComputer: error occured when configuring networking settings. See your network administrator

    Question

  • I am trying to join a new win7 64bit client Dell laptop to my SBS2003r2 domain that is already running 7, Win7 and 3 XP computers with no problems. I start the "connect computer" wizard In IE9 and run through all the screens including running NSHelp from the server.All seems successful till after the wizard finishes and I get:"An error occured when configuring networking settings. See your network administrator."Then when I restart the PC, it shows the "_sbs_netsetup_" account as a user account option, password and all.

    The server shows the new computer name in the AD in the proper place and listed in DHCP and DNS also properly with the IP address of 192.168.1.30 . I can ping the server OK and I can remote thru terminal service to the client but when I try to sign in to my user admin  account with the administrator credentials it says the password is incorrect and will not connect. I can also see the network shared folders thru my computer. The computer Network is still listed as WORKGROUP not MYDOMAIN.local after the wizard and reboot.

    I have tried several things to no avail I just end up back where I started with the same error.

    Here are some of the things I tried,

    Disable windows defender/firewall and no other antivirus installed.

    Open TCP ports 4125,139,445.

    Disable simple file sharing ,and enable it,

    Remove the client from server and try again=same result.

    As a note: On my first attempt to connectcomputer I got an error of “Make sure that only one net adaptor is enabled and that it is connected to SBS. I found this error was related to a Bluetooth adaptor running in device manager and when I disabled it I was able to go thru the wizard steps but then got the above error which I cannot get past.

    I have learned to use the wizards provided in SBS as this usually gives best results and I tried to join the network by changing to domain on the client manually but that too failed.

    I have joined several win7 machines to this server and always had one problem or another but found ways “ to get er done” but this time I am stumped and do not know where to go next.

    Saturday, May 04, 2013 1:40 AM

Answers

All replies

  • I still need to resolve this issue so I am posting the NetSetup log from the client in hopes that will help someone help me.

    Thanks

    05/03/2013 11:45:18:316 -----------------------------------------------------------------
    05/03/2013 11:45:18:316 NetpDoDomainJoin
    05/03/2013 11:45:18:316 NetpMachineValidToJoin: 'ASSOCPASTOR'
    05/03/2013 11:45:18:316  OS Version: 6.1
    05/03/2013 11:45:18:316  Build number: 7601 (7601.win7sp1_gdr.130104-1431)
    05/03/2013 11:45:18:316  ServicePack: Service Pack 1
    05/03/2013 11:45:18:316  SKU: Windows 7 Professional
    05/03/2013 11:45:18:316 NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
    05/03/2013 11:45:18:316 NetpGetLsaPrimaryDomain: status: 0x0
    05/03/2013 11:45:18:316 NetpMachineValidToJoin: status: 0x0
    05/03/2013 11:45:18:316 NetpJoinDomain
    05/03/2013 11:45:18:316  Machine: ASSOCPASTOR
    05/03/2013 11:45:18:316  Domain: WillowHills.local
    05/03/2013 11:45:18:316  MachineAccountOU: ou=sbscomputers,ou=computers,ou=mybusiness,dc=willowhills,dc=local
    05/03/2013 11:45:18:316  Account: WillowHills.local\John Sterner
    05/03/2013 11:45:18:316  Options: 0x167
    05/03/2013 11:45:18:316 NetpLoadParameters: loading registry parameters...
    05/03/2013 11:45:18:316 NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1' 0x2
    05/03/2013 11:45:18:316 NetpLoadParameters: DomainCompatibilityMode not found, defaulting to '0' 0x2
    05/03/2013 11:45:18:316 NetpLoadParameters: status: 0x2
    05/03/2013 11:45:18:316 NetpJoinDomain: Unsecure join requested.
    05/03/2013 11:45:18:316 NetpValidateName: checking to see if 'WillowHills.local' is valid as type 3 name
    05/03/2013 11:45:18:316 NetpValidateName: 'WillowHills.local' is not a valid NetBIOS domain name: 0x7b
    05/03/2013 11:45:18:316 NetpCheckDomainNameIsValid for WillowHills.local returned 0x54b, last error is 0x0
    05/03/2013 11:45:18:316 NetpCheckDomainNameIsValid [ Exists ] for 'WillowHills.local' returned 0x54b
    05/03/2013 11:45:18:316 NetpJoinDomainOnDs: Domain name is invalid, NetpValidateName returned: 0x54b
    05/03/2013 11:45:18:316 NetpJoinDomainOnDs: Function exits with status of: 0x54b
    05/03/2013 11:45:18:316 NetpDoDomainJoin: status: 0x54b
    05/03/2013 11:46:45:409 -----------------------------------------------------------------
    05/03/2013 11:46:45:409 NetpDoDomainJoin
    05/03/2013 11:46:45:409 NetpMachineValidToJoin: 'ASSOCPASTOR'
    05/03/2013 11:46:45:409  OS Version: 6.1
    05/03/2013 11:46:45:409  Build number: 7601 (7601.win7sp1_gdr.130104-1431)
    05/03/2013 11:46:45:409  ServicePack: Service Pack 1
    05/03/2013 11:46:45:409  SKU: Windows 7 Professional
    05/03/2013 11:46:45:409 NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
    05/03/2013 11:46:45:425 NetpGetLsaPrimaryDomain: status: 0x0
    05/03/2013 11:46:45:425 NetpMachineValidToJoin: status: 0x0
    05/03/2013 11:46:45:425 NetpJoinDomain
    05/03/2013 11:46:45:425  Machine: ASSOCPASTOR
    05/03/2013 11:46:45:425  Domain: WillowHills.local
    05/03/2013 11:46:45:425  MachineAccountOU: ou=sbscomputers,ou=computers,ou=mybusiness,dc=willowhills,dc=local
    05/03/2013 11:46:45:425  Account: WillowHills.local\John Sterner
    05/03/2013 11:46:45:425  Options: 0x167
    05/03/2013 11:46:45:425 NetpLoadParameters: loading registry parameters...
    05/03/2013 11:46:45:425 NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1' 0x2
    05/03/2013 11:46:45:425 NetpLoadParameters: DomainCompatibilityMode not found, defaulting to '0' 0x2
    05/03/2013 11:46:45:425 NetpLoadParameters: status: 0x2
    05/03/2013 11:46:45:425 NetpJoinDomain: Unsecure join requested.
    05/03/2013 11:46:45:425 NetpValidateName: checking to see if 'WillowHills.local' is valid as type 3 name
    05/03/2013 11:46:45:425 NetpValidateName: 'WillowHills.local' is not a valid NetBIOS domain name: 0x7b
    05/03/2013 11:46:45:425 NetpCheckDomainNameIsValid for WillowHills.local returned 0x54b, last error is 0x0
    05/03/2013 11:46:45:425 NetpCheckDomainNameIsValid [ Exists ] for 'WillowHills.local' returned 0x54b
    05/03/2013 11:46:45:425 NetpJoinDomainOnDs: Domain name is invalid, NetpValidateName returned: 0x54b
    05/03/2013 11:46:45:425 NetpJoinDomainOnDs: Function exits with status of: 0x54b
    05/03/2013 11:46:45:425 NetpDoDomainJoin: status: 0x54b


    John Sterner

    Saturday, May 04, 2013 3:55 PM
  • Hi John:

    First hiccup seems to be DNS.  Can you verify that the client is set to dynamic DHCP and it has the correct DNS pointer, that is, DNS for the nic in the client points only to the IP of the SBS?

    Then the log says it hiccuped on .local.  This may be just backwash from the first error, but have you tried it without the .local as the domain in the screen where it asks for permission?  Is there a dash in the domain name?


    Larry Struckmeyer[SBS-MVP]

    Saturday, May 04, 2013 5:14 PM
    Moderator
  • Please post the results of an   ipconfig /all   for both the SBS 2003 server and for a workstation.
     
    Do you have ISA 2004 installed on the SBS server?
     
    Can we assume that you have KB926505 installed on the SBS server?
     
    Windows Small Business Server 2003: Windows 7, Windows Vista and Outlook 2007 compatibility update
     
    Download, install and run a scan with the SBS 2003 BPA and fix any issues it finds...
     
    SBS 2003 Best Practices Analyzer
     

    --
    Merv  Porter
    ============================
    Saturday, May 04, 2013 11:44 PM
    Moderator
  • Thanks for your response.

    I live about 25 miles from where this server is located so again today I drove there and tried some more things prior to getting your reply.

    First let me address your questions. About DNS hiccup. When I check the client nic settings they are all set to obtain automatic. When I check the connection Status details in the local connection they show:

    Ipv4 address   192.168.1.30 (This is correctly assigned by DHCP in server and listed  in server)

    Ipv4Default gateway  192.168.1.1  (This is the router)

    Ipv4 DHCP server    192.168.1.10  (This is the server DHCP)

    Ipv4 DNS server      192.168.1.10   (This is the DNS server in the server and the Host A record is correct along with the forward and reverse lookup records which are correct.)

    Ipv4 WINS Server  192.168.1.10  This also is correct)

    I can ping the server from client by IP address and name from client ok. I can ping the client from server by IP and name too.

    Hope this clarifies your first question.

    As to the second question; When any login asks for the domain name I think I have always used the Domain name as WillowHills.local and there is no dash in the name. I have not tried it without the .local but will do so when I go back tomorrow.


    John Sterner

    Today also I tried to use the My Computer Network ID wizard to join the domain from the client and got the following error:

    An active directory domain controller (AD DC) for the domain WillowHills.local could not be contacted.

    Details: The following error occurred when DNS was queried for the service location (SRV) resource record used to locate an Active Directory Domain Controller (AD DC) for domain "WILLOWHILLS.LOCAL":

    The error was: "DNS name does not exist."

    (error code 0x0000232B RCODE_NAME_ERROR)

    The query was for the SRV record for _ldap._tcp.dc._msdcs.WILLOWHILLS.LOCAL

    Common causes of this error include the following:

    - The DNS SRV records required to locate a AD DC for the domain are not registered in DNS. These records are registered with a DNS server automatically when a AD DC is added to a domain. They are updated by the AD DC at set intervals. This computer is configured to use DNS servers with the following IP addresses:

    192.168.1.10

    - One or more of the following zones do not include delegation to its child zone:

    WILLOWHILLS.LOCAL

    LOCAL

    . (the root zone)

    I do not fully understand this error but it seems your pointing to the DNS server may be valid. I just don’t know.

    Since the above did not work I deleted the net setup from the client and then deleted the client from the server including the DNS and DHCP records and restarted the client not connected to the server Ethernet or wireless.

    I then changed the name of the client to Assocpastor1 and restarted twice. Then I plugged in the Ethernet cable and turned off windows firewall and tried again using the ConnectComputer wizard in IE9.

    As before the process went ok to the end where I got the same error as the first attempts. Here is the NetSetup log for that attempt.

    05/04/2013 09:53:35:976 -----------------------------------------------------------------

    05/04/2013 09:53:35:976 NetpValidateName: checking to see if 'WILLOWHILLS.LOCAL' is valid as type 3 name

    05/04/2013 09:53:35:976 NetpValidateName: 'WILLOWHILLS.LOCAL' is not a valid NetBIOS domain name: 0x7b

    05/04/2013 09:53:35:991 NetpCheckDomainNameIsValid for WILLOWHILLS.LOCAL returned 0x54b, last error is 0x0

    05/04/2013 09:53:35:991 NetpCheckDomainNameIsValid [ Exists ] for 'WILLOWHILLS.LOCAL' returned 0x54b

    05/04/2013 10:09:29:531 -----------------------------------------------------------------

    05/04/2013 10:09:29:531 NetpValidateName: checking to see if 'WILLOWHILLS.LOCAL' is valid as type 3 name

    05/04/2013 10:09:29:531 NetpValidateName: 'WILLOWHILLS.LOCAL' is not a valid NetBIOS domain name: 0x7b

    05/04/2013 10:09:29:562 NetpCheckDomainNameIsValid for WILLOWHILLS.LOCAL returned 0x54b, last error is 0x0

    05/04/2013 10:09:29:562 NetpCheckDomainNameIsValid [ Exists ] for 'WILLOWHILLS.LOCAL' returned 0x54b

    05/04/2013 10:11:20:151 -----------------------------------------------------------------

    05/04/2013 10:11:20:151 NetpValidateName: checking to see if 'ASSOCPASTOR' is valid as type 1 name

    05/04/2013 10:11:20:478 NetpCheckNetBiosNameNotInUse for 'ASSOCPASTOR' [MACHINE] returned 0x0

    05/04/2013 10:11:20:478 NetpValidateName: name 'ASSOCPASTOR' is valid for type 1

    05/04/2013 10:11:20:478 -----------------------------------------------------------------

    05/04/2013 10:11:20:478 NetpValidateName: checking to see if 'AssocPastor' is valid as type 5 name

    05/04/2013 10:11:20:478 NetpValidateName: name 'AssocPastor' is valid for type 5

    05/04/2013 10:11:20:478 -----------------------------------------------------------------

    05/04/2013 10:11:20:478 NetpValidateName: checking to see if 'willowhills.local' is valid as type 3 name

    05/04/2013 10:11:20:478 NetpValidateName: 'willowhills.local' is not a valid NetBIOS domain name: 0x7b

    05/04/2013 10:11:20:478 NetpCheckDomainNameIsValid for willowhills.local returned 0x54b, last error is 0x0

    05/04/2013 10:11:20:478 NetpCheckDomainNameIsValid [ Exists ] for 'willowhills.local' returned 0x54b

    05/04/2013 10:32:56:938 -----------------------------------------------------------------

    05/04/2013 10:32:56:938 NetpValidateName: checking to see if 'ASSOCPASTOR' is valid as type 1 name

    05/04/2013 10:32:56:938 NetpCheckNetBiosNameNotInUse for 'ASSOCPASTOR' [MACHINE] returned 0x0

    05/04/2013 10:32:56:938 NetpValidateName: name 'ASSOCPASTOR' is valid for type 1

    05/04/2013 10:32:56:938 -----------------------------------------------------------------

    05/04/2013 10:32:56:938 NetpValidateName: checking to see if 'AssocPastor' is valid as type 5 name

    05/04/2013 10:32:56:938 NetpValidateName: name 'AssocPastor' is valid for type 5

    05/04/2013 10:32:56:954 -----------------------------------------------------------------

    05/04/2013 10:32:56:954 NetpValidateName: checking to see if 'willowhills.local' is valid as type 3 name

    05/04/2013 10:32:56:954 NetpValidateName: 'willowhills.local' is not a valid NetBIOS domain name: 0x7b

    05/04/2013 10:32:56:954 NetpCheckDomainNameIsValid for willowhills.local returned 0x54b, last error is 0x0

    05/04/2013 10:32:56:954 NetpCheckDomainNameIsValid [ Exists ] for 'willowhills.local' returned 0x54b

    05/04/2013 11:29:54:183 -----------------------------------------------------------------

    05/04/2013 11:29:54:198 NetpValidateName: checking to see if 'ASSOCPASTOR1' is valid as type 1 name

    05/04/2013 11:29:54:245 NetpCheckNetBiosNameNotInUse for 'ASSOCPASTOR1' [MACHINE] returned 0x0

    05/04/2013 11:29:54:245 NetpValidateName: name 'ASSOCPASTOR1' is valid for type 1

    05/04/2013 11:29:54:261 -----------------------------------------------------------------

    05/04/2013 11:29:54:261 NetpValidateName: checking to see if 'Assocpastor1' is valid as type 5 name

    05/04/2013 11:29:54:261 NetpValidateName: name 'Assocpastor1' is valid for type 5

    05/04/2013 11:42:31:026 -----------------------------------------------------------------

    05/04/2013 11:42:31:042 NetpDoDomainJoin

    05/04/2013 11:42:31:042 NetpMachineValidToJoin: 'ASSOCPASTOR1'

    05/04/2013 11:42:31:042       OS Version: 6.1

    05/04/2013 11:42:31:042       Build number: 7601 (7601.win7sp1_gdr.130318-1533)

    05/04/2013 11:42:31:042       ServicePack: Service Pack 1

    05/04/2013 11:42:31:042       SKU: Windows 7 Professional

    05/04/2013 11:42:31:042 NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0

    05/04/2013 11:42:31:042 NetpGetLsaPrimaryDomain: status: 0x0

    05/04/2013 11:42:31:042 NetpMachineValidToJoin: status: 0x0

    05/04/2013 11:42:31:042 NetpJoinDomain

    05/04/2013 11:42:31:042       Machine: ASSOCPASTOR1

    05/04/2013 11:42:31:042       Domain: WillowHills.local

    05/04/2013 11:42:31:042       MachineAccountOU: ou=sbscomputers,ou=computers,ou=mybusiness,dc=willowhills,dc=local

    05/04/2013 11:42:31:042       Account: WillowHills.local\John Sterner

    05/04/2013 11:42:31:042       Options: 0x167

    05/04/2013 11:42:31:042 NetpLoadParameters: loading registry parameters...

    05/04/2013 11:42:31:042 NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1' 0x2

    05/04/2013 11:42:31:042 NetpLoadParameters: DomainCompatibilityMode not found, defaulting to '0' 0x2

    05/04/2013 11:42:31:042 NetpLoadParameters: status: 0x2

    05/04/2013 11:42:31:042 NetpJoinDomain: Unsecure join requested.

    05/04/2013 11:42:31:042 NetpValidateName: checking to see if 'WillowHills.local' is valid as type 3 name

    05/04/2013 11:42:31:042 NetpValidateName: 'WillowHills.local' is not a valid NetBIOS domain name: 0x7b

    05/04/2013 11:42:31:042 NetpCheckDomainNameIsValid for WillowHills.local returned 0x54b, last error is 0x0

    05/04/2013 11:42:31:042 NetpCheckDomainNameIsValid [ Exists ] for 'WillowHills.local' returned 0x54b

    05/04/2013 11:42:31:042 NetpJoinDomainOnDs: Domain name is invalid, NetpValidateName returned: 0x54b

    05/04/2013 11:42:31:042 NetpJoinDomainOnDs: Function exits with status of: 0x54b

    05/04/2013 11:42:31:042 NetpDoDomainJoin: status: 0x54b

    05/04/2013 11:43:49:227 -----------------------------------------------------------------

    05/04/2013 11:43:49:227 NetpDoDomainJoin

    05/04/2013 11:43:49:227 NetpMachineValidToJoin: 'ASSOCPASTOR1'

    05/04/2013 11:43:49:227       OS Version: 6.1

    05/04/2013 11:43:49:227       Build number: 7601 (7601.win7sp1_gdr.130318-1533)

    05/04/2013 11:43:49:227       ServicePack: Service Pack 1

    05/04/2013 11:43:49:227       SKU: Windows 7 Professional

    05/04/2013 11:43:49:227 NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0

    05/04/2013 11:43:49:227 NetpGetLsaPrimaryDomain: status: 0x0

    05/04/2013 11:43:49:227 NetpMachineValidToJoin: status: 0x0

    05/04/2013 11:43:49:227 NetpJoinDomain

    05/04/2013 11:43:49:227       Machine: ASSOCPASTOR1

    05/04/2013 11:43:49:227       Domain: WillowHills.local

    05/04/2013 11:43:49:227       MachineAccountOU: ou=sbscomputers,ou=computers,ou=mybusiness,dc=willowhills,dc=local

    05/04/2013 11:43:49:227       Account: WillowHills.local\John Sterner

    05/04/2013 11:43:49:227       Options: 0x167

    05/04/2013 11:43:49:227 NetpLoadParameters: loading registry parameters...

    05/04/2013 11:43:49:227 NetpLoadParameters: DNSNameResolutionRequired not found, defaulting to '1' 0x2

    05/04/2013 11:43:49:227 NetpLoadParameters: DomainCompatibilityMode not found, defaulting to '0' 0x2

    05/04/2013 11:43:49:227 NetpLoadParameters: status: 0x2

    05/04/2013 11:43:49:227 NetpJoinDomain: Unsecure join requested.

    05/04/2013 11:43:49:227 NetpValidateName: checking to see if 'WillowHills.local' is valid as type 3 name

    05/04/2013 11:43:49:227 NetpValidateName: 'WillowHills.local' is not a valid NetBIOS domain name: 0x7b

    05/04/2013 11:43:49:227 NetpCheckDomainNameIsValid for WillowHills.local returned 0x54b, last error is 0x0

    05/04/2013 11:43:49:227 NetpCheckDomainNameIsValid [ Exists ] for 'WillowHills.local' returned 0x54b

    05/04/2013 11:43:49:227 NetpJoinDomainOnDs: Domain name is invalid, NetpValidateName returned: 0x54b

    05/04/2013 11:43:49:227 NetpJoinDomainOnDs: Function exits with status of: 0x54b

    05/04/2013 11:43:49:227 NetpDoDomainJoin: status: 0x54b

     Again thanks again for helping me , I do this as a volunteer for this church and it is easy to get in over my head.


    • Edited by JohnBoyJR Sunday, May 05, 2013 12:58 AM Add more information
    Sunday, May 05, 2013 12:55 AM