none
shutdown client pc via gpo

    Question

  • Hi ,

        I want to shutdown my client computer using group policy...currently we have windows server 2012 ...I have search google regarding this issue but that solution not working...kindly help me this issue... for your reference i mentioned that solution below..

    1. Created new GPO
    2. Computer configuration > Preferences > > Control Panel settings > Shedule Tasks
    3. Run > c:\windows\system32\shutdown.exe
    4. Arguments > -f -s
    5. Schedule time for shutdown 
    6. Run as administrator
    7. gpupdate /force on both server and PC, rebooted PC

    

    Tuesday, February 21, 2017 7:15 AM

All replies

  • Thanks for your reply .. I tried to your suggestion but its not working..

    

    Tuesday, February 21, 2017 8:21 AM
  • Hi Murali,

    Are you scheduling the script with administrative privileges. When you have finished scheduling the script in task scheduler, manually run it and see if it is working or not.

    / Karim

    Tuesday, February 21, 2017 9:55 AM
  • Hi Karim,

                 yes i scheduling the script in administrator privileges..

    if you don't mind can you tell me how to run manually ?..

    Tuesday, February 21, 2017 11:53 AM
  • Hi Murali,

    Go to task scheduler library and right-click you task and then click Run.

    Please mark it as answer if this help.

    / Karim

    Tuesday, February 21, 2017 12:02 PM
  • Hi,
    First of all, before we go further, please verify that the GPO is applied to clients successfully, you could run gpresult /r command to check that.
    If the GPO is not applied, please follow the article as below to troubleshoot it:
    10 Common Problems Causing Group Policy To Not Apply
    http://social.technet.microsoft.com/wiki/contents/articles/22457.10-common-problems-causing-group-policy-to-not-apply.aspx
    If the GPO is applied, but the scheduled task is not working, then please check If you set the preference item under Computer Configuration, by default the task is run in the security context of the System account. You need the change run the schedule task as "NT AUTHORITY\SYSTEM" account
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, February 22, 2017 5:53 AM
    Moderator
  • Hi Wendy,

                  gpresult /r showing only default policies .... i couldnt find the NT Authority/system in users tab

    Wednesday, February 22, 2017 9:48 AM
  • Hi all!

    I configured as above but then Server System ( Domain Controler, SQL, ....) was shutdown the same client. I only want to shutdown Clients. Can you help me? Thanks all!!!!

    Friday, February 24, 2017 3:18 AM
  • Hi,
    Thank you for posting questions in this thread, however, in order to offer better assistance on your problem, I would suggest you open a new thread with your questions and group policy settings in this forum, once we get your thread, feedback and suggestions will be replied to you.
    Appreciate for your understanding.
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, February 27, 2017 3:15 AM
    Moderator
  • Hi Murali,

    I am checking how the issue going, if you still have any questions, please feel free to contact us.

    And if the replies as above are helpful, we would appreciate you to mark them as answers, and if you resolve it using your own solution, please share your experience and solution here. It will be greatly helpful to others who have the same question.

    Appreciate for your feedback.

    Best regards,

    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, February 27, 2017 3:17 AM
    Moderator