none
Default User and Sysprep

    Question

  • I have been online searching for an answer for this for days with no help. I am trying to image a Windows XP SP3 machine that consists of 2 different profiles. 1 is the default administrator profile and one is a custom one I created for non-admin users that I want to copy as the Default User. In the past, I've done this successfully literally hundreds of times with our Windows XP SP2 machines. Now that we have XP SP3 it is not working. What happens is the custom desktop shortcuts I've created get deleted. I've researched and always come across the answer that in SP3, you have to add in this:

    [Unattended]

    UpdateServerProfileDirectory=1

     

    in your sysprep.inf file to have sysprep copy the administrator profile to the Default User profile. This is NOT what I want to do. I want to have a different profile be copied to the Default User profile.  So I tested changing the value to 0 or not having the line at all. Same results.

    I did this all the time in my previous images so it's confusing me as to why this is the behavior now. I also noticed that sysprep deletes any custom desktop shortcuts I've created in the existing profiles I have as well, not just for the Default User one. Is this how it is supposed to behave now? Any assistance will be appreciated.

    Wednesday, February 10, 2010 11:28 PM

Answers

  • AH! I figured it out. If anyone runs into this problem, I hope this helps.

    So apparently sysprep by default will clear out your desktop icons and only leave some system ones (IE, Windows Media Player, etc). You have to do a registry change to prevent that from happening:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion

    then
    DWORD Value , and then add the following registry value:
    Value name: OemDesktopCleanupDisable
    Value data: 1 (decimal)

    You can also add an entry into the same key called DoDesktopCleanup, and make it's value 1 or 0 for yes/no.  

    They sound like they do the same thing, so to be sure I put in both. It worked. I checked my old XP SP2 images and they indeed had an entry for the "DoDesktopCleanup=0". I never added that so it must have come preloaded like that on the Dell I was working on originally.  On this new XP SP3 machine (HP, not Dell) that I'm working on, it was set to "DoDesktopCleanup=1".


    * now a side note, after putting these entries in, I noticed Windows Media Player would get a shortcut created on the desktop despite my having a GPO and a registry entry saying to not create desktop shortcuts for it. So I found this helpful site with a registry hack to fix that as well:

    http://windowsdevcenter.com/pub/a/windows/2004/11/16/JIT.html


    I hope that helps someone.
    • Marked as answer by Jon CK S Thursday, February 11, 2010 2:46 AM
    Thursday, February 11, 2010 2:46 AM