none
Portal Page cannot be displayed after upgrade to 2010 R2 RRS feed

  • Question

  • Hi,

    I just upgraded our FIM 2010 installation (Sync Service and Service) to FIM 2010 R2.  The installation completed successfully but I am no longer able to access the FIM portal, which now displays "IE cannot display the webpage".  The error I see in Event Viewer is

    "The portal was unable to complete a request and showed a user the default error page. An unhandled exception was caught."

    I have turned on advanced error logging ( "http://setspn.blogspot.ca/2010/06/fim-2010-enable-advanced-error-logging.html")  and was seeing the error 

    "error CS0433: The type 'Microsoft.IdentityManagement.WebUI.Controls.BrandBar' exists in both 'c:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\807f2e44\90b6c8\assembly\dl3\cfd406a6\000110a7_22decc01\Microsoft.IdentityManagement.WebUI.Controls.DLL' and 'c:\Windows\assembly\GAC_MSIL\Microsoft.IdentityManagement.WebUI.Controls\4.1.2273.0__31bf3856ad364e35\Microsoft.IdentityManagement.WebUI.Controls.dll' "

    I tried deleting the dll that was in the Temporary ASP.NET files folder but the file was recreated when I went to access the portal. I then tried to reinstall the portal.  However, after doing the issue continued but I no longer saw the detailed errors in the event log even though advanced logging was turned on.  

    When I went through the upgrade in my test environment I did not come across this issue some am a bit stumped as to what has gone sideways.  Any suggestions on what to try would be greatly appreciated.

    Sunday, April 28, 2013 10:16 PM

Answers

  • There is a lot of log and tracing enhancements to the R2 release. Take a look at these: http://social.technet.microsoft.com/wiki/contents/articles/how-to-configure-fim-portal-tracing.aspx http://technet.microsoft.com/en-us/library/jj150427(v=ws.10).aspx I'll get back to you tomorrow. :)

    Regards, Remi www.iamblogg.com

    • Marked as answer by Woggi Monday, April 29, 2013 10:50 PM
    Monday, April 29, 2013 8:52 PM

All replies

  • Is the FIM Service running ?

    Did you look here: http://social.technet.microsoft.com/wiki/contents/articles/3610.fim-2010-wiki-articles.aspx#FIM_Troubleshooting_Article for something similar to your problem ?


    Regards, Remi www.iamblogg.com

    Monday, April 29, 2013 8:21 AM
  • Hi Remi,

    Thanks for the reply.  Yes, the FIM Service is running.  I took a look at the link you suggested but did not find any article that covered the particular issue I am facing.  I can get to the root of the sharepoint site (https://fim.my.domain/).  The problem is only with accessing the MS Identity Management site (https://fim.mydomain/IdentityManagement/).  Using "localhost" instead of "fim.my.domain" makes no difference.  


    • Edited by Woggi Monday, April 29, 2013 6:11 PM
    Monday, April 29, 2013 6:11 PM
  • Hello ocannada,

    I had a similar problem one time. Trying to remember what I did to fix it.

    Could you take a look in the Microsoft.ResourceManagement.Service.exe.config file, you are probably using localhost as the base address for Microsoft.ResourceManagement.WebServices.ResourceManagementService and Microsoft.ResourceManagement.WebServices.SecurityTokenService.

    Try changing it to http://youdomain:5725 for the ResourceManagementService, and http://youdomain:5726 for the SecurityTokenService.
    Remember to restart the fimservice after you made the change. Here`s my config:

        <services>
          <service name="Microsoft.ResourceManagement.WebServices.ResourceManagementService">
            <host>
              <baseAddresses>
                <add baseAddress="http://fimservice.mydomain.local:5725" />
              </baseAddresses>
            </host>
          </service>
          <service name="Microsoft.ResourceManagement.WebServices.SecurityTokenService">
            <host>
              <baseAddresses>
                <add baseAddress="http://fimservice.mydomain.local:5726" />
              </baseAddresses>
            </host>
          </service>
        </services>
      </system.serviceModel>
      <resourceManagementClient resourceManagementServiceBaseAddress="fimservice.mydomain.local" />
      <resourceManagementService externalHostName="fimservice.mydomain.local" />



    Regards, Remi www.iamblogg.com

    Monday, April 29, 2013 6:25 PM
  • Thanks for the suggestion.  I gave it a try but the results were the same.  I also tried updating the base address to use "https" instead of "http" but that preventing the FIMService from starting.
    Monday, April 29, 2013 7:52 PM
  • hmm.. And there is nothing in your event viewer ?

    Regards, Remi www.iamblogg.com

    Monday, April 29, 2013 8:05 PM
  • Unfortunately, the only error I get is the following, which slows up in the log dozens of times each time I try to access the portal:

    "The portal was unable to complete a request and showed a user the default error page.
    An unhandled exception was caught.
    Check the product diagnostic log file and then check the SharePoint log file."

    Note that I have set up advanced logging as described here ( "http://setspn.blogspot.ca/2010/06/fim-2010-enable-advanced-error-logging.html") but am not getting more details appearing the event log.

    Monday, April 29, 2013 8:26 PM
  • There is a lot of log and tracing enhancements to the R2 release. Take a look at these: http://social.technet.microsoft.com/wiki/contents/articles/how-to-configure-fim-portal-tracing.aspx http://technet.microsoft.com/en-us/library/jj150427(v=ws.10).aspx I'll get back to you tomorrow. :)

    Regards, Remi www.iamblogg.com

    • Marked as answer by Woggi Monday, April 29, 2013 10:50 PM
    Monday, April 29, 2013 8:52 PM
  • That helped.  Implementing the FIM logging I was seeing the error that I noted in my original post again.  On investigating this error further I discovered that  there was a copy of the Microsoft.IdentityManagement.WebUI.Controls.DLL in the GAC and in the virtual folder of the sharepoint site.  The version of the GAC DLL was higher then that of the DLL in the virtual folder.  Replacing the DLL in the virtual folder with the one from the GAC solved the issue.



    • Edited by Woggi Monday, April 29, 2013 10:50 PM
    • Proposed as answer by Ross Currie Wednesday, May 8, 2013 4:32 PM
    Monday, April 29, 2013 10:50 PM