none
Group Policy not applying proxy when there's exceptions involved RRS feed

  • Question

  • Hi,

    I'm trying to apply proxy settings to a domain with IE11. I'm currently using Windows 10 to do this as you need to be >8 to be able to set policies for IE10/11.

    When I'm configuring Internet Explorer in the 'Internet Settings' section of the GPO, I can set everything up correctly including the proxy information. However, as soon as I set an exception on the advanced section and save it, the proxy will be blank on all of my clients.

    It's only when there's an exception, without the exception it works flawlessly.

    It seems to be a pretty known bug but no one seems to have any sort of fix.

    Does anybody know of another way I can set the exceptions?

    Kind Regards,

    Gary

    Monday, November 9, 2015 4:48 PM

Answers

  • Hi,

    Since you want to applied proxy settings through the domain, you need to edit the domain policy in the domain server, not the Windows 10 client to do this. Therefore, could you please tell us the Windows server operating system edition so that we can help you better? 

    In addition to that, if you want to set Internet Explorer proxy for the domain, you need to use Group Policy Preference but not the Group Policy Objects.

    If you use Windows Server 2008, the Group Policy Preference do not support Internet Explorer 10 and Internet Explorer 11. For these condition, you need to use IEAK to deploy the proxy settings.

    If you use Windows Server 2012, you can try to edit the policy by right click the domain policy name > "Edit". Then you need to go "User Configuration" > "Preference" > "Control Panel Settings" > "Internet Setting". After that, right click the right blank area > "New" > select a Internet Explorer version, then set the proxy settings.

    Hope that can help you.

    Best Regards

    Simon


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, November 11, 2015 7:02 AM
    Moderator
  • Apparently a common cause of this issue, is an invalid syntax in the exceptions string/values

    http://blogs.msdn.com/b/asiatech/archive/2013/03/11/failed-to-apply-proxy-setting-through-gpo.aspx


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Wednesday, November 11, 2015 7:39 AM

All replies

  • Hi,

    Since you want to applied proxy settings through the domain, you need to edit the domain policy in the domain server, not the Windows 10 client to do this. Therefore, could you please tell us the Windows server operating system edition so that we can help you better? 

    In addition to that, if you want to set Internet Explorer proxy for the domain, you need to use Group Policy Preference but not the Group Policy Objects.

    If you use Windows Server 2008, the Group Policy Preference do not support Internet Explorer 10 and Internet Explorer 11. For these condition, you need to use IEAK to deploy the proxy settings.

    If you use Windows Server 2012, you can try to edit the policy by right click the domain policy name > "Edit". Then you need to go "User Configuration" > "Preference" > "Control Panel Settings" > "Internet Setting". After that, right click the right blank area > "New" > select a Internet Explorer version, then set the proxy settings.

    Hope that can help you.

    Best Regards

    Simon


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, November 11, 2015 7:02 AM
    Moderator
  • Apparently a common cause of this issue, is an invalid syntax in the exceptions string/values

    http://blogs.msdn.com/b/asiatech/archive/2013/03/11/failed-to-apply-proxy-setting-through-gpo.aspx


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Wednesday, November 11, 2015 7:39 AM