locked
Why is MS Sharepoint 2013 so complicated to setup? RRS feed

  • Question

  • Hi.

    I have tried to get Microsoft SharePoint 2013 running for a couple of weeks now without success.

    First I installed it on an already existing Windiow Server 2012 computer, there was alot of problems to even run the install, The Preparation Tool setup gave some errors and when restarting it will just start over again. After ALOT of work it got running but the SharePoint itself did not work as expected, it gave exceptions when creating new website. If You are interested, look at this thread : http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/9553f51b-2947-43c0-8370-009f6ffc2ab3/

    I never got it to work even after days of work. So now I have got a new/fresh Windows Server 2012 computer, I have installed all the updates but I still have problems to install SharePoint 2013!? It demands me to run Microsoft SharePoint2013 Product Preparation Tool setup but when I do it ends with : 

    There was an error during installation : Aplication Server Role. Web Server(IIS) Role: configuration error

    I have googled and found some possible problems but none worked. So what is wrong with MS Sharepoint 2013? Why so much problems just to set it up?

    I have worked with other simular programs before and even if there might have been problems thay have been easy to solve for the most part but SharePoint 2013 just demands ALOT of time and even then it does not run as it should?

    Tuesday, April 1, 2014 12:59 PM

All replies

  • I understand the problem you are facing.

    There is a bug in pre-requisits install for sharepoint 2013 which is causing issue. APPfabric cause the loop of installing pre-requisits again and again. You can install appfabric manaully

    http://www.sharepointdoug.com/2013/01/manually-install-microsoft-app-fabric.html

    or

    Try below article:

    http://blogs.technet.com/b/praveenh/archive/2013/02/22/sharepoint-2013-prerequisites-fails-with-msi-installer-error-code-1603-while-installing-appfabric-1-1.aspx


    Tuesday, April 1, 2014 1:10 PM
  • But right now the problem is not app fabric, its : 

    There was an error during installation : Aplication Server Role. Web Server(IIS) Role: configuration error

    I dont get why Microsoft dont fix this? To be able to install the software should be priority 1, right?

    Tuesday, April 1, 2014 1:38 PM
  • Hi Snowjim,

    May this helps to fix your problem : http://support.microsoft.com/kb/2765260/en-us

    Best Regards,

    Senthil

    Tuesday, April 1, 2014 2:03 PM
  • Hi,

    I downloaded the 64 bits for Windows 2012 but the file was called Windows 8 RT!? When execute the file I get "The update is not applicable to your computer". Why should it be easy ;)

    Wednesday, April 2, 2014 7:03 AM
  • I hope you are not using Windows server 2012 R2. 

    SP 2013 has issues with Windows server 2012 R2


    If this helped you resolve your issue, please mark it Answered

    Monday, July 14, 2014 11:58 AM
  • The unpatched media yes, that won't work with 2012 R2. Disk images that include SP1 should be fine with Server 2012 R2.

    SharePoint is one of the largest and most complex systems Microsoft sells. It is annoyingly easy to get wrong during installation but you probably haven't even noticed those mistakes yet ;)

    What is your high level process? Generally i'd get a VM from the infrastructure team, ensure it's fully patched, get the user accounts created and only then start on the install.

    Also are you following a guide for installation, if so which one?


    Monday, July 14, 2014 12:13 PM
  • Thanks,

    It worked great with the SP1 version of SharePoint!

    Monday, September 1, 2014 1:35 PM
  • HI,Please find the below Links that detailed explanation of Pre-requisites,Installation and the issues facing while Installation of Sharepoint 2013.

    http://expertsharepoint.blogspot.de/2013/11/detailed-sharepoint2013-installation-i.html

    http://expertsharepoint.blogspot.de/2013/10/installation-of-sharepoint-2013-on.html

    In the same blog,you can find all the resolutions for the issues occurred in SP2013.


    Anil Avula[MCP,MCSE,MCSA,MCTS,MCITP,MCSM] See Me At: http://expertsharepoint.blogspot.de/

    Tuesday, September 2, 2014 4:20 AM
  • It is incredible why it takes so much effort installing such a sofware! I have over 25 years experience implementing all sorts of software and this one amazes me all the time. I finally got it installed with the SP1 download (why isn't there any mention that the original download would not work with Server 2012 R2? and why the prerequesite installation does not detect that?). But take note that if you had installed the AppFabric manually, you have to uninstall it first and let it install from the SP1 download. Hope this will save the long hours I've spent on this for others.
    Wednesday, August 12, 2015 8:01 PM