locked
Performance Point: Code blocks are not allowed in this file. RRS feed

  • Question

  • Hi All,

    I'm trying to use Performance Point 2010 in Sharepoint 2010...

    I have start the application in centrel admin
    I have created a site collection based on the Bisuness Intelligence Center template

    I can surf the new Site Collection but when I try to open the "Start using PerformancePoint Services" link I get the following error:

    "An error occurred during the processing of /PerformancePoint/Pages/ppssample.aspx. Code blocks are not allowed in this file."

    is there any way to fix it???

    is there any good source to understand and deploy Performance Point 2010??

    thanks All

    Vit
    Thursday, January 21, 2010 8:23 AM

Answers

  • This worked for me.  Placed this in the web.config file of the web application within the <PageParserPath> header.

    <PageParserPath VirtualPath="/BI/Pages/ppssample.aspx" CompilationMode="Always" AllowServerSideScript="true" />

    IISReset /noforce

    Notice the BI in the path.  When you hover over the link that is giving you trouble you should be able to see the path to put in your web.config.



    • Proposed as answer by Netshrinks Tuesday, January 10, 2012 7:22 PM
    • Edited by Netshrinks Tuesday, January 10, 2012 7:24 PM
    • Marked as answer by Margriet Bruggeman Monday, April 9, 2012 8:58 AM
    Tuesday, January 10, 2012 7:22 PM

All replies

  • I followed the soup-to-nuts install instructions. I have the same problem. Does anyone have an actual solution?
    Thursday, July 29, 2010 7:41 PM
  • I have the same issue, did any of you find an answer to this?
    Monday, September 6, 2010 2:33 PM
  • Hi,

    you need to add the below entry in the <pageparserpaths> element. I assume this should not be necessary since this page is created by sharepoint itself.... Hope it helps

    <PageParserPath VirtualPath="/PerformancePoint/Pages /ppssample.aspx" CompilationMode="Always" AllowServerSideScript="true" />
    Wednesday, September 22, 2010 3:37 PM
  • Hi i too am facing the same issue and adding the page paser element as you suggested in the web.config file did not work is there any other solution?

     

     

    Wednesday, October 6, 2010 2:02 PM
  • Hi All,

    I am facing the same issue and tried to add the page parser element entry also. But no success.

    Could anyone please help its very urgent.

    Wednesday, January 12, 2011 10:54 AM
  • Anyone found the solution?

    Thank you.

    Friday, March 11, 2011 2:48 PM
  • This (slightly changed) worked for me:

    <PageParserPath VirtualPath="/Pages/ppssample.aspx" CompilationMode="Always" AllowServerSideScript="true" />

    Best regards,

    Jens Fokdal

    Tuesday, April 12, 2011 9:35 AM
  • I have tried the above PageParserPath settings, however none seem to fix this problem for me.  Does anyone have another solution to this issue?

     

    I've tried...

     

    <PageParserPath VirtualPath="/Pages/ppssample.aspx" CompilationMode="Always" AllowServerSideScript="true" />

    <PageParserPath VirtualPath="/PerformancePoint/ppssample.aspx" CompilationMode="Always" AllowServerSideScript="true" />

    <PageParserPath VirtualPath="/mysitecollection/ppssample.aspx" CompilationMode="Always" AllowServerSideScript="true" />

     

    Help Please!!!

    Monday, November 28, 2011 5:46 PM
  • This worked for me.  Placed this in the web.config file of the web application within the <PageParserPath> header.

    <PageParserPath VirtualPath="/BI/Pages/ppssample.aspx" CompilationMode="Always" AllowServerSideScript="true" />

    IISReset /noforce

    Notice the BI in the path.  When you hover over the link that is giving you trouble you should be able to see the path to put in your web.config.



    • Proposed as answer by Netshrinks Tuesday, January 10, 2012 7:22 PM
    • Edited by Netshrinks Tuesday, January 10, 2012 7:24 PM
    • Marked as answer by Margriet Bruggeman Monday, April 9, 2012 8:58 AM
    Tuesday, January 10, 2012 7:22 PM
  • This worked for me.  Placed this in the web.config file of the web application within the <PageParserPath> header.

    <PageParserPath VirtualPath="/BI/Pages/ppssample.aspx" CompilationMode="Always" AllowServerSideScript="true" />

    IISReset /noforce

    Notice the BI in the path.  When you hover over the link that is giving you trouble you should be able to see the path to put in your web.config.



    Might be a bit of a security problem. In our case it was because our master pages are custom, reverting them to the default ones solved the problem (You can change them back after this issue occurs only when trying to launch designer). We didn't deploy our master pages as features so performance point isn't able to load in "safe mode" to avoid code execution at the farm level.
    • Proposed as answer by gomjh Tuesday, October 9, 2012 5:31 PM
    Monday, June 25, 2012 2:16 AM
  • In our case it was because our master pages are custom, reverting them to the default ones solved the problem (You can change them back after this issue occurs only when trying to launch designer).
    That's exactly what it was for me. I had modified the v4.master when messing around with some navigation menu tweaks. As soon as I reset to site definition the problem disappeared.
    Tuesday, October 9, 2012 5:31 PM
  • I followed this BUT I forgot the extra S in ppSsample.aspx and so it OBVIOUSLY Would not work, then I tried to follow again as others have found it to work, I also had to change the path for my subsites that I was in and NOW it works.  I am including this as a helpful hint after "not" following exactly the resolution that was clear and plain! :)  Nice Netshrinks!
    Friday, October 26, 2012 12:12 PM
  • worked for me.  odd to me that a "sample" page in sharepoint doesn't work out of the box.

    par for the course on sharepoint though.


    ~george

    Thursday, January 17, 2013 6:58 PM
  • Thank you, changing the web.config and changing the MASTER page back to default solved the problem BUT I still need the changes I have applied to the Master page. What would be the issue that it will not work if the Master page is slightly altered? In my case, the breadcrumb was changed.

    I would appreciate some insight.

    Thank you

    Wednesday, February 13, 2013 5:54 PM
  • I got through. I fixed it by changing the Master Page for the site to the default.master in Sharepoint Designer. 
    Friday, January 17, 2014 2:34 PM