none
Password Reset Registration not working

    Question

  • Hi,

    While i am trying to register for password reset on vista machine , registration page is not comming up while it is comming with windows 2003 server once unregistered user logs in to the server.

    i wanna check is there any compatibilty issuewith vista workstations?
    Mohit Goyal
    Thursday, July 9, 2009 1:22 PM

Answers

  • OK, that's better.  So let me get this straight.  Using the same AD user account, you can hit the registration page on one system and not on another?  Well, that's a new one for me.  Do this:

    On the system in question, using an elevated command prompt, type the following:

    notepad "%ProgramFiles%\microsoft identity management\password client\pwdmgmtproxy.exe.config"


    In the resultant window, look for the element:

    <source name="Microsoft.ResourceManagement" switchValue="Warning">


    And change "Warning" to "Verbose"

    Ensure NT AUTHORITY\Network Service has Write permission to "%ProgramFiles%\microsoft identity management\password client" and restart the service.

    Try registering again.  Then open the PwdMgmtProxy.svclog file on the client.  Look for the errors and come back to us.

    Note.  You probably won't be able to open it on the client so access that folder remotely from your ILM server, assuming you have Visual Studio. 
    • Marked as answer by workingmind Tuesday, July 21, 2009 6:16 AM
    Friday, July 10, 2009 8:31 PM

All replies

  • Are you getting an error?  Have you installed the necessary bits onto the Vista box?  Are you trying it through the portal?  If so, have you added the portal to your trusted sites and set "Initialize and script ActiveX controls not marked as safe for scripting" to either disabled or prompt?  What happens if you type mspwdregistration -all from the run command?

    I think we need some additional info. from you.
    Friday, July 10, 2009 8:02 AM
  • Hi Paul,

    I had installed necessary bits on the client computer. i think there are only two bits rewuired
    1-ILM2 certificate
    2-ilm-client installer

    also i added portal URL to trusted site and set "Initialize and script ActiveX controls not marked as safe for scripting" to prompt.

    while i typed mspwdregistration -all  on command prompt it says " you are not authorized to register for self-service Password Reset" where as same user get window for password register automatically once he logs in to the computer.


    Please let me know if you require any more infromation, i will be more then happy to let you konow evey bit of info to resolve this issue.

    Also i am trying it through protal.

    Thanks!!! :)
    Mohit Goyal
    • Edited by workingmind Friday, July 10, 2009 1:15 PM more info
    Friday, July 10, 2009 10:20 AM
  • OK, that's better.  So let me get this straight.  Using the same AD user account, you can hit the registration page on one system and not on another?  Well, that's a new one for me.  Do this:

    On the system in question, using an elevated command prompt, type the following:

    notepad "%ProgramFiles%\microsoft identity management\password client\pwdmgmtproxy.exe.config"


    In the resultant window, look for the element:

    <source name="Microsoft.ResourceManagement" switchValue="Warning">


    And change "Warning" to "Verbose"

    Ensure NT AUTHORITY\Network Service has Write permission to "%ProgramFiles%\microsoft identity management\password client" and restart the service.

    Try registering again.  Then open the PwdMgmtProxy.svclog file on the client.  Look for the errors and come back to us.

    Note.  You probably won't be able to open it on the client so access that folder remotely from your ILM server, assuming you have Visual Studio. 
    • Marked as answer by workingmind Tuesday, July 21, 2009 6:16 AM
    Friday, July 10, 2009 8:31 PM