locked
Error when creating PerformancePoint Data Connection -- No Databases Available RRS feed

  • Question

  • Trying to create a data connection in PerformancePoint Dashboard Designer.

    2 box depolyment.  1) SharePoint 2010 on Windows Server 2008 R2 and 2) SQL Server 2008 on Windows Server 2008 R2.   The current WCF hot fix has been applied to the SharePoint box.

    PerformancePoint Service is up and running fine.  Can create data connections and indicators, dashboards, etc., and they save with no problem.

    However when I go to connect to SQL or SSAS to create my data connection, I cannot get a list of databases.

    The unattended service account is "domain_name\perfpoint" and that account has been granted access to a series of cubes and databases.

    In event viewer, when I try to connect to a data source I am seeing:

    ***
    The data source provider for data sources of type 'ADOMD.NET' is not registered. Please contact an administrator.

    PerformancePoint Services error code 10115.

    ***

    I am guessing I have a problem with ADOMD.NET, but what should I try?

    Alan
    My Ramblings @ http://alanwhitehouse.wordpress.com
    • Moved by Mike Walsh FIN Thursday, December 3, 2009 5:39 AM Moving to Admin until such time as there is a 2010 forum for Perf. Pt. questions (From:SharePoint 2010 - General Questions and Answers)
    Wednesday, December 2, 2009 8:25 PM

Answers

  • Did an uninstall and reinstall and now all works.   Hmmmmmm.....
    My Ramblings @ http://alanwhitehouse.wordpress.com
    Friday, December 4, 2009 2:05 PM

All replies

  • Hi Alan,


    Yes, please install the ADOMD.Net the Dashboard Designer is not changed in V2.  Current release of Dashboard Designer  ADOMD.NET is required.  Make sure following is been taken care


    1. Add the Unattended Service Account to PerformancePoint Service Application | Administrator make sure to mark Full Control. 
     
    2. Verify the Manage Service Application | Secure Store Application | PPS Unattended Service Account entry is present

    Thank you,
    Sundar - MSFT


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, December 2, 2009 9:53 PM
  • Sundar,

    1.  Confirmed ADOMD.Net is installed -- version 8.0

    2.  Setup Unattended Service Account (domain\perfpoint) is setup as full control under administrators.  Central Admin -> Manage Service Applications -> PerformancePoint Service Application (highlight) -> Administrators (from ribbon bar) and added "domain\perfpoint" and gave full control.

    3.  Can you expand a little on this point?  When I go into that area I see what looks like a guid and then the words "PPSUnattendedAccount".  Should I be checking the area under "Set Credentials" or under "Set Permissions" or something else?


    Alan
    My Ramblings @ http://alanwhitehouse.wordpress.com
    Thursday, December 3, 2009 1:25 AM
  • Hi Alan,

    Yes, you are right Secure Store Application will display GUID+PPSUnattendedAccount.

    From Manage Service Applicaton | PerformancePoint Services | Manage | PerformancePoint Services Settings when the Unattended Service Account is updated the secure store is updated with credentials.  There is no separate requirement to Set the credentials in Secure Store Service Application | Set Credentials area.     Check the Event Viewer | Application Log for error which may provide clue.

    Please log into the Server as Service Account see whether you are able to access the Data Source from Dashboard Designer as well as SSMS.

    Can you please check again on the ADOMD.NET version, I believe it should be 9.0?

    Thank you,
    Sundar - MSFT


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, December 3, 2009 2:03 AM
  • Did an uninstall and reinstall and now all works.   Hmmmmmm.....
    My Ramblings @ http://alanwhitehouse.wordpress.com
    Friday, December 4, 2009 2:05 PM
  • I configured PerformancePoint on SharePoint 2013. I tried several
    versions of ADO.NET. But only oldest version fixed this issue... :)

    Feature Pack for Microsoft SQL Server 2005 - November 2005

    https://www.microsoft.com/en-us/download/details.aspx?id=15748

    SQLServer2005_ADOMD_x64.msi




    Tuesday, February 12, 2013 2:25 PM
  • uninstall and reinstall of what?
    Friday, March 10, 2017 9:20 PM