none
No puedo unir Windows 10Pro a dominio Server 2008R2 RRS feed

  • Pregunta

  • Hola tengo el siguiente problema, no puedo unir Windows 10Pro a un dominio Server 2008R2 debido a un error. Al intentar hacer la unión da el mensaje de bienvenida al dominio y luego lanza el siguiente error "NO SE PUDO CAMBIAR EL NOMBRE DNS DE DOMINIO PRINCIPAL DE ESTE EQUIPO A "". SE MANTENDRA EL NOMBRE "XXXXXX".

    Cabe aclarar que Windows 7Pro conecta perfectamente al domino pero no así con el cliente Windows 10Pro. Quiero saber si hace falta alguna configuración adicional a los pasos comunes para la unión a dominios, o alguna actualización.

    Luego del error solicita el reinicio del equipo e inicia como un equipo de dominio pero no permite agregar usuarios porque "El equipo tiene problemas para comunicarse con el dominio".

    Ya revise todos los pasos, IP, DNS, etc etc

    Agradezco si alguien conoce la solución a este problema.

    Gracias!

    Saludos!

    martes, 3 de mayo de 2016 15:15

Todas las respuestas

  • Hola IngDar, por que te dice "Que no se podrá modificar el nombre", en el DNS puedes verificar en las zonas: Forward y Reverse, que no exista el nombre

    Saludos,


    Peter Chirinos | IT Consultant, MCP, MCSA, Microsoft Office Master, Software Developer, Microsoft Certified Professional, MAP , Microsoft Small Business Specialist, Veeam Technical Sales Professional (VMTSP), Veeam Sales Professional (VMSP), VMware Technical Solutions Professional (VTSP) | @peter_chirinos

    martes, 3 de mayo de 2016 16:33
  • Hola Peter gracias por tu respuesta, me podrías ampliar la solución? porque la configuración actual funciona perfectamente con cliente Windows 7, hay algo que trabaja distinto en Windows 10?

    Saludos.


    Damián A. Romani

    martes, 3 de mayo de 2016 16:41
  • Hola, lo que llama la atención es que te dice que no puede cambiar el nombre del equipo, es como si ya existiera, puede ser que se haya quedado guardado el registro del equipo, por eso te comentaba que veas en las zonas si existe ese nombre, además te consulto cuantos servidores DNS tienes? 

    Saludos,


    Peter Chirinos | IT Consultant, MCP, MCSA, Microsoft Office Master, Software Developer, Microsoft Certified Professional, MAP , Microsoft Small Business Specialist, Veeam Technical Sales Professional (VMTSP), Veeam Sales Professional (VMSP), VMware Technical Solutions Professional (VTSP) | @peter_chirinos

    martes, 3 de mayo de 2016 16:47
  • Si es muy raro, en Active Directory el equipo se crea pero sin los datos del SO, leí que podía ser problema del sufijo DNS pero no logro solucionarlo. Tengo un único DNS.

    Saludos.


    Damián A. Romani

    martes, 3 de mayo de 2016 17:04
  • Por otra parte solo le pasa a un w10? o tienes otros con el mismo problema?

    Puedes hacer lo siguiente, para probar:

    1. Sacarlo del dominio

    2.- Eliminar los objetos del equipo (DNS)

    3.- cambiar de nombre al equipo

    4.- Asignale una IP (fijo) - (no te pregunte si tienes el ROL del DHCP), una vez que se agregue se lo habilitas

    Me cuentas,


    Peter Chirinos | IT Consultant, MCP, MCSA, Microsoft Office Master, Software Developer, Microsoft Certified Professional, MAP , Microsoft Small Business Specialist, Veeam Technical Sales Professional (VMTSP), Veeam Sales Professional (VMSP), VMware Technical Solutions Professional (VTSP) | @peter_chirinos

    martes, 3 de mayo de 2016 18:53
  • Me paso anteriormente con Windows 8.1 y ahora con Windows 10 (ambos versiones Pro), pero con Windows 7 no tengo ningún tipo de problemas al unir a dominio, por eso no se si es algo del DC o de la pc.

    Respecto a tu sugerencia, ya cambié el nombre del equipo, elimine el objeto del AD, puse IP fija (tengo DHCP), pero sigue igual.

    Saludos.


    Damián A. Romani

    miércoles, 4 de mayo de 2016 10:49
  • Hola,

    Colaborando con el equipo, tenemos para ti la siguiente respuesta:

    "

    Estimado

     

    Este error puede ser provocado por la configuración en los DNS, puedes verificar que en las propiedades de TCP/IP del adaptador esté configurado la dirección IP de tu Active Directory como DNS primario, puedes verificarlo haciendo un ping a tu dominio: ejemplo: ping dominio.com.mx

     

    También es conveniente vaciar la cache de tu equipo lo cual podría solucionar el problema, esto es con el comando:  ipconfig /flushdns   esto deberá ejecutarse en una ventana con

    símbolo del sistema con privilegios elevados y posteriormente reiniciar el equipo.

    <u5:p> </u5:p>

    Como referencia te dejo el siguiente link el cual puede apoyar con algunas preguntas de DNS.

     

     

    http://windows.microsoft.com/es-mx/windows/domain-name-system-faq#1TC=windows-7

     

    Esperando que esta información le haya sido de utilidad, quedamos en espera de sus resultados.

     

    Saludos cordiales

    "

    Gracias por usar los foros de TechNet.

    Marco

    _____


    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    viernes, 13 de mayo de 2016 21:25
  • Gracias por la respuesta...

    Ya hice todas las verificaciones que tienen que ver con IP y DNS, todo esta correcto, haciendo ping al dominio obtengo respuesta del Controlador de dominio sin problemas.

    También probé conectar el equipo por medio de IP fija y por DHCP. En la información de red, muestra la leyenda "Red privada" en vez de indicar "Red de dominio".

    Alguien probó unir Windows 10 a dominio Server 2008R2?

    No encuentro donde esta el problema, ya que Windows 7 se une perfectamente.

    Saludos. 


    Damián A. Romani

    lunes, 16 de mayo de 2016 11:31
  • Hola IngDar, te sugiero algunas otras soluciones, a ver si lo puedes solucionar

    1.- Saca la máquina del Dominio, y borra todos los datos de esta máquina tanto en el Dominio y en DNS

    2.- En el cliente, en Sistema, en la ficha donde puedes cambiar el nombre de máquina, ingresa por el botón "Más". Revisa que no tenga ningún nombre puesto en sufijo primario de Dominio, y que esté marcada la opción de Cambiar el sufijo cuando se une a un Dominio

    3.- Revisa en las propiedades avanzadas de TCP/IP, que tenga configurado para usar como DNS únicamente al Controlador de Dominio, ninguno externo, ni Router, etc.

    4.- Reinicia la máquina y prueba unirla al Dominio

    Si lo anterior no funciona revisa el siguiente enlace a ver si se cumplen algunas de las condiciones que nombra

    Windows 7 or Windows Server 2008 R2 domain join displays error "Changing the Primary Domain DNS name of this computer to "" failed...."
    https://support.microsoft.com/en-us/kb/2018583 

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    • Propuesto como respuesta Moderador M lunes, 16 de mayo de 2016 21:53
    • Marcado como respuesta Moderador M viernes, 20 de mayo de 2016 15:28
    • Desmarcado como respuesta Moderador M viernes, 20 de mayo de 2016 18:10
    • Votado como útil Moderador M jueves, 4 de mayo de 2017 14:29
    lunes, 16 de mayo de 2016 11:49
  • Guillermo te comento que esas sugerencias ya las había aplicado, mas arriba alguien lo propuso.

    Respecto al sufijo primario de dominio, al unir un equipo, automáticamente ese valor se completa con el nombre del dominio, es normal, de todos modos se lo borre pero no hay ningún cambio.

    Todas las sugerencias son para Windows 7, sistema operativo con el cual no tengo ningún problema en el dominio, es por eso que me gustaría saber si alguien pudo unir correctamente un Windows 10 a un dominio Server 2008R2 y si tuvo algún problema con eso.

    Gracias.


    Damián A. Romani

    viernes, 20 de mayo de 2016 17:15
  • Hola Damián, sí, W10Pro se puede unir a Dominio sin ningún problema. Ya se ha hecho muchas veces

    Debe haber otra cosa que no está bien configurada por ahí :)

    Supongo que no haz clonado las máquinas ¿o si?

    Y que tienen configurado para usar como DNS únicamente a el o los Controladores de Dominio, y ningú otro ¿si?

    Porque no hay demasiada ciencia :D

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    viernes, 20 de mayo de 2016 19:11
  • Gracias por tu respuesta Guillermo, es como vos decís, no hay demasiada ciencia es por eso que me tiene desconcertado, da de pensar que algo cambió internamente en W10 en lo referido a la vinculación con un dominio. Recuerdo que apenas apareció W7 y a pesar de tener las mismas opciones que WXP, no se podía unir a dominio a no ser que se realice en linea de comandos, cosa que fue solucionada con el lanzamiento del SP1. Es algo muy parecido a lo que me sucede ahora con W10.

    El equipo que intento unir esta formateado e instalado desde cero y con un único DNS, el del controlador del dominio. Tengo un dominio de 60 equipos (W7 y algunos WXP) y esta (W10) es la única que me da problemas.

    En resumen, tengo un equipo unido al dominio a medias, ya que me da la bienvenida al mismo pero luego y antes de pedirme el reinicio muestra el error mencionado, por lo cual no me permite agregar usuarios del dominio al equipo y cuando intento acceder a los recursos de red debo escribir las credenciales cada vez, es decir que no se autentica en el inicio de sesión.

    Saludos.


    Damián A. Romani

    lunes, 23 de mayo de 2016 11:33
  • Algunas ideas que se me ocurren y quizás alguna ayude

    - Desde PowerShell ejecutado como administrador prueba: "Test-ComputerSecureChannel"
    Si responde con "true" no habría problemas con la autenticación de la cuenta de máquina
    Si responde con "false", vuelve a ejecutar el comando agregando el modificador "-Repair"

    - Si el problema se produce antes de actualizar el sistema, probaría luego de actualizarlo a la fecha
    Y si fuera actualizado, probaría con uno sin actualizar
    El objetivo es ver si hay alguna actualización que esté produciendo el problema

    - Y si con nada de lo anterior se soluciona, descargar nuevamente el sistema y crear un nuevo medio de instalación
    Para ver si el problema está en los archivos de instalación

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 23 de mayo de 2016 11:43
  • Guillermo por lo pronto al ejecutar "Test-ComputerSecureChannel" el resultado que obtengo es "False".

    Voy a seguir con el tema de las actualizaciones.

    Saludos. 


    Damián A. Romani

    lunes, 23 de mayo de 2016 13:56
  • Hola Damián, si el resulta fue "FALSE", entonces está rota la relación de confianza de la máquina con el Dominio. No tienen la misma versión de la contraseña de cuenta de máquina

    Se debería solucionar con "Test-ComputerSecureChannel -Repair"

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 23 de mayo de 2016 15:54
  • Al ejecutar el comando "Test-ComputerSecureChannel -Repair" me muestra el siguiente error: 

    "No se puede restablecer la contraseña del canal seguro para la cuenta de equipo en el 
    dominio. Error en la operación con la siguiente excepción: Ha ocurrido un error local."

    Alguna idea de esto? muchas gracias!


    Damián A. Romani

    lunes, 23 de mayo de 2016 17:11
  • La palabra *local* ya da una pista

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 23 de mayo de 2016 20:55
  • Hola se me presento el mismo caso, en Win7 sin problemas pero en Win10 me marca el mismo error.

    En mi caso se resolvió dejando en las propiedades de Protocolo de Internet Versión 4 (TCP/IPv4) el DNS de mi servidor de dominio.


    Con eso se firmo al dominio sin ningún problema.

    Saludos!!

    miércoles, 4 de octubre de 2017 22:29
  • Hola TorresMX, es lo que pones justamente la configuración necesaria

    Todas las máquinas que forman parte de un Dominio Active Directory tienen que tener configurado para usar como DNS únicamente a el o los Controladores de Dominio del propio Dominio con el servicio DNS. Nunca ni como alternativos a DNSs externos, Routers, o DNS públicos

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    jueves, 5 de octubre de 2017 11:21