none
Mi propio servidor Mail RRS feed

  • Pregunta

  • Buenas a todos, en principio lo que quiero es tener un servidor mail, propio, para mi uso personal, es decir, tener configurado un mail con mi dominio y algunas cuentas de correo.

    Os cuento como tengo configurado el mail y todo, sin exchange.

    En primer lugar instale el servicio de correo de windows server 2003.

    Cree varios buzones, y comprobe que entre la ed interna se envian email perfectamente.

    El problema que tengo es a la hora de recibir-enviar email al exterior, que no consigo que termine de funcionar, lo que tengo en el router, es ip dinamica con dyndns, ip estatica, de esta forma he redirigido mi puerto 110 (POP3) y 25 SMTP a mi servidor 192.168.1.100

    Hasta ahi todo bien, el problema no se si puede estar en mi DNS que tengo, que puede ser... dado a que la tablas que tengo son las siguientes:

    mail      HOST A 192.168.1.100
    mail     MX         mail.nombredominio.com
    ftp       CNAME   nombredominio.com
    www    CNAME   nombrededominio.com


    Y bueno, creo que todo lo tengo mas o menos bien configurado, no se si puede estar el error en los reenviadores de MX, o alguna cosa más.

    Si necesitaís agún dato más comentarmelo, solo sea por ayudarme... muchas gracias!


    lunes, 27 de julio de 2009 1:39

Todas las respuestas

  • Buenos Dias

    En tu explicacion no comentas nada sobre tu ISP y la Ip Publica proporcionada por el mismo.

    lo que deberias hacer es pedirle a tu ISP que el registro MX para tu dominio va ser tu IP Publica, desde entonces todo el trafico SMTP y POP3 que se dirija desde la internet hacia el dominio @tudominio.com llegara hacia tu Ip Publica.

    Luego es simplemente trabajar con tu enrutador para que este enrute los paquetes hacia el Servidor de correo.

    Saludos;


    lunes, 27 de julio de 2009 14:26
  • Hola buenas tardes,

    Mi ISP es jazztel, pero supongo que no tendrá nada que ver en este tema, en mi dominio el registro MX es decir @midominio.com esta apuntando a mi dirección IP que es la dirección del dyndns, que se actualiza igual que mi dirección, por lo tanto el registro del dominio midominio.com esta apuntando nombredeusuario.dyndns.org, de esa forma estaría correcto.

    Muchas Gracias, pero no se que puedo estar haciendo mal.

    Gracias!
    martes, 28 de julio de 2009 15:49
  • bueno, si eso es correcto entonces al realizar lo siguiente fuera de tu red te deberia dar la ip publica:

    Inicio
    Ejecutar
    cmd
    nslookup
    set type=mx
    tudominio.com


    El motivo por el cual me estoy yendo por este lado:

    cuando tu envias un correo lo que hace el equipo cliente es preguntarle al DNS quien es el MX de midominio.com. luego establece la comunicacion de la siguiente manera:

    telnet midominio 25
    helo localhost
    mail from: <cuenta@midominio.com>
    rcpt to: <tucuenta@midominio.com>
    data

    Esto es una prueba de correo

    ...
    ..
    .
    y el correo se envia

    Te podria colaborar mas sobre el tema si me proporcionas el FQDN de tu dominio.

    A espera de respuesta;

    Saludos;


    martes, 28 de julio de 2009 18:27
  • Bien, de acuerdo, vamos a ver si conseguimos que esto funcione, por favor, por que no se donde puede estar el problema, te comento:

    Cuando hago el nslookup me contesta esto:


    > set type=mx
    > moisesvazquez.com
    Servidor:  33.Red-80-58-0.staticIP.rima-tde.net
    Address:  80.58.0.33

    moisesvazquez.com
            primary name server = dns1.name-services.com
            responsible mail addr = info.name-services.com
            serial  = 2002050701
            refresh = 10001 (2 hours 46 mins 41 secs)
            retry   = 1801 (30 mins 1 sec)
            expire  = 604801 (7 days 1 sec)
            default TTL = 181 (3 mins 1 sec)


    Bien parece ser que esa contestando bien... no es asi?

    Bien de esa forma, las guias de investigación pueden estar por otro lado, puede ser que el servidor virtual de SMTP, no este creado bien... o no este corriendo del todo bien.

    Haber que me puedes decir, si me permites, puedo pedirte el mail, para poder o bien mirarlo por mail, mas tranquilamente, o hacerte alguna consulta.

    Muchas Gracias, por si quieres mi email es: moisesvs arroba gmail.com
    viernes, 31 de julio de 2009 2:34
  • Buenas Noches Moises

    Al parecer aun no tienes los DNS bien configurados con el registro MX.

    El resultado correcto a esta resolucion deberia ser el siguiente:


    nslookup

    Servidor predeterminado:  UnKnown
    Address:  10.1.1.1

    > set type=mx
    > hotmail.com
    Servidor:  UnKnown
    Address:  10.1.1.1

    DNS request timed out.
        timeout was 2 seconds.
    Respuesta no autoritativa:
    hotmail.com     MX preference = 5, mail exchanger = mx4.hotmail.com
    hotmail.com     MX preference = 5, mail exchanger = mx1.hotmail.com
    hotmail.com     MX preference = 5, mail exchanger = mx2.hotmail.com
    hotmail.com     MX preference = 5, mail exchanger = mx3.hotmail.com

    hotmail.com     nameserver = ns1.msft.net
    hotmail.com     nameserver = ns5.msft.net
    hotmail.com     nameserver = ns4.msft.net
    hotmail.com     nameserver = ns2.msft.net
    hotmail.com     nameserver = ns3.msft.net
    mx1.hotmail.com internet address = 65.55.37.104
    mx1.hotmail.com internet address = 65.55.37.120
    mx1.hotmail.com internet address = 65.55.92.136
    mx1.hotmail.com internet address = 65.55.92.184
    mx1.hotmail.com internet address = 65.55.37.72
    mx1.hotmail.com internet address = 65.55.37.88
    mx2.hotmail.com internet address = 65.55.37.72
    mx2.hotmail.com internet address = 65.55.37.88
    mx2.hotmail.com internet address = 65.55.37.104
    mx2.hotmail.com internet address = 65.55.37.120
    mx2.hotmail.com internet address = 65.55.92.136
    mx2.hotmail.com internet address = 65.55.92.152
    mx3.hotmail.com internet address = 65.55.92.168
    mx3.hotmail.com internet address = 65.55.37.72
    mx3.hotmail.com internet address = 65.55.37.88
    mx3.hotmail.com internet address = 65.55.37.104
    mx3.hotmail.com internet address = 65.55.37.120
    mx3.hotmail.com internet address = 65.55.92.152

    Nota:   El anterior fue un ejecmplo con los servidores MX de Hotmail.com


    De acuerdo a el resultado que me enviaste, lo que te recomiendo es lo siguiente:

    El DNS de tu proovedor de servicios es dns1.name-services.com , debes decirle a tu ISP que el MX del dominio moisesvazquez.com va a ser tu direccion Ip Publica.

    Al parecer Name-Services.com es la empresa a la que le compraste el dominio y por lo tanto debe de ser a esta a la que le solicitaras el cambio de registro MX.

    Observaciones:


    El Servidor de Correo se encuentra bien ya que puedes enviar y recibir localmente. Esto se debe ya que el DNS local posee el registro MX apuntando al host 192.168.1.100, es decir, los computadores de la red local ya saben cual es el equipo encargado del trafico SMTP y POP3. Por Otro lado la internet aun no tiene conocimiento que el MX de moisesvazquez.com es tu direccion Ip Publica.

    A espera de comentarios ...


    viernes, 31 de julio de 2009 4:33
  • Adicionalmente te dejo un enlace para que verifiques tu dominio cuando hayas hecho el cambio:

    http://www.mxtoolbox.com/

    Saludos;

    viernes, 31 de julio de 2009 4:46
  • Te comento, el dominio el registro MX, lo tengo apuntando a mi dyndns de mi router, y no se si esta bien, mira el pantallazo que he realizado para que puedas comprobarlo tú.

    http://img268.imageshack.us/i/dnsq.jpg/

    De esta forma, lo que es el registro MX y el www lo tengo redirigido a mi dirección de dyndns, lo que es la web me funciona correctamente, pero el MX me esta dando problemas.

    Si quieres, te puedo hacer un pantallazo de como tengo configurado lo que es el DNS propio.

    No se que puede pasar, ni donde puede estar el error, pero todos los mails que mando, me los rechaza.

    Muchas Gracias, haber si llegamos a solucionarlo.
    viernes, 31 de julio de 2009 13:27
  • Buenos Dias Moises

    Perdon por la demora. He realizado una consulta DNS y efectivamente la redireccion hacia el www.moisesvazquez.com se esta efectuando.


    Servidor predeterminado:  UnKnown
    Address:  10.1.1.1

    > www.moisesvazquez.com
    Servidor:  UnKnown
    Address:  10.1.1.1

    Respuesta no autoritativa:
    Nombre:  moisesvs.dyndns.org
    Address:  87.217.14.84
    Aliases:  www.moisesvazquez.com


    Tambien ha este le he realizado un telnet por el puerto 80 y ha respondido como debe ser. Luego hice un telnet al puerto 25 (SMTP) a la misma direccion Ip Publica y este no me ha repondido.

    Efectivamente tenemos problemas de publicacion del Servidor SMTP.

    Prueba con esto

    - Verifica que el Servidor SMTP se encuentre Publicado. En teoria asi yo no le haya configurado un resgistro MX al servidor de correo si le doy el siguiente comando:

         telnet moisesvs.dyndns.org 25

    Me deberia de responder el Servidor de la siguiente manera:

    220-thor.sslcatacombnetworking.com ESMTP Exim 4.69 #1 Sat, 01 Aug 2009 08:10:31
    -0500


    Pero cuando ejecuto el comando telnet moisesvs.dyndns.org 25 me rechaza la conexion

    Conclusion:
    Al parecer en estos momentos no se encuentra publicado el servidor de correo en el enrutador. Esto seria decir al enrutador que todo el trafico que venga desde internet por el puerto 25 me lo redireccione a la direccion IP 192.168.1.100.

    Luego, si no estoy mal, deberias cambiarle la configuracion que tienes en estos momentos por la siguiente:

    Actual: @.moisesvazquez.com
    Despues: *@moisesvazquez.com


    Espero te haya servido de ayuda

    A espera de comentarios;

    Saludos;
    sábado, 1 de agosto de 2009 13:29
  • Hola Jacinto, volvemos a la carga, a ver si podemos solucionar,

    Te comento en el router si que esta haciendo NAT hacia esa dirección, a no ser que el router, no me refirija bien esos puertos, la verdad es que no se como hacer, o que programa me puede decir que el puerto 25 esta bien redirigido o no me lo esta cortando el router.

    En este caso te pongo un ejemplo de mi router Asus WL700GE, en la siguiente imagen, tengo toda la tabla de NAT:

    http://img13.imageshack.us/i/natc.jpg/

    Bien de esa forma la tabla de NAT creo que esta bien mapeada, tanto el 110(POP) como el 25 de SMTP, puede ser que tenga algún problema en el servidor.

    Ya no se me ocurre nada más por hacer, existe alguna posibilidad de poder hacer o ver si el router está mapeando bien, por que con el puerto 80 me dio algún problema de hecho me lo sige dando por que la administración del router va por el 80... y me fastidia a la hora de colocar el servidor web.

    Muchas Gracias, espero tu respuesta.
    Saludos!
    sábado, 1 de agosto de 2009 15:29
  • Acabo de arrancar el servidor, y al hacer telnet al 25, me sale esto:

    220 SERVIDOR.moisesvazquez.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.3
    959 ready at  Sat, 1 Aug 2009 17:29:13 +0200

    Parece que algo más funciona, no??

    O algo quiere hacer, a ver que me puedes decir con esto.

    Saludos y gracias!
    sábado, 1 de agosto de 2009 15:31
  • Asi es como tengo configurado el SMTP virtual del servidor:

    http://img104.imageshack.us/i/smtp.jpg/

    Saludos y gracias!

    EDITO: He estado viendo, y aunque me hace Telnet en el puerto 25 en el MXTOOLBOX que me pasastes, no me funciona...
    sábado, 1 de agosto de 2009 15:34
  • Perfecto bien hecho

    Ahora ya puedo ver tu servidor SMTP en la Red.

    Exitosamente ya lo tienes publicado ahora solo es tema de definir el MX del DNS


    Para realizar pruebas de envio y recepcion me podrias dar una cuenta de correo existente ?

    Otra pregunta, Ya probaste cambiando @.moisesvazquez.com por *@moisesvazquez.com

    A espera de respuesta


    Ya pronto solucionaremos este problema

    Saludos;


    sábado, 1 de agosto de 2009 15:40

  • haz aplicado algu cambio, porque ya no lo puedo ver ??


    sábado, 1 de agosto de 2009 15:47
  • Hola Jacinto, bien...

    Pues de momento se ve, es que apague el servidor, un momento, perdon...

    Si para las pruebas te puedo dar un nombre de usuario por ejemplo: moisesvs@moisesvazquez.com es una correo, aunque puedo crearte uno como jacinto@moisesvazquez.com para hacer las pruebas.

    Muchas gracias, me estas ayudando mucho.

    El cambio que me comentas no se donde tengo que hacerlo en el DNS??

    Mira asi tengo configurado el DNS:

    http://img22.imageshack.us/i/dnsq.jpg/

    Comentame lo que tengo que hacer para haber si podemos solucionarlo lo antes posible, muchas gracias!
    sábado, 1 de agosto de 2009 16:00
  • Acabo de enviarte una prueba de correo electronico de la siguiente manera:

    220 SERVIDOR.moisesvazquez.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.3
    959 ready at  Sat, 1 Aug 2009 18:14:35 +0200
    helo localhost
    250 SERVIDOR.moisesvazquez.com Hello [190.28.145.185]
    mail from: <moisesvs@moisesvazquez.com>
    250 2.1.0 moisesvs@moisesvazquez.com....Sender OK
    rcpt to: <moisesvs@moisesvazquez.com>
    250 2.1.5 moisesvs@moisesvazquez.com
    data
    354 Start mail input; end with <CRLF>.<CRLF>
    Esto es una Prueba desde la linea de comanods del Servidor de Correo, Contesta l
    a prueba hacia la direccion de correo j1111_0@hotmail.com.co
    ..
    .
    250 2.6.0 <SERVIDOROmzVtNPGdfS00000001@SERVIDOR.moisesvazquez.com> Queued mail f
    or delivery
    quit

    El DNS local tuyo esta bien ... ahi no hay ningun problema.

    El problema se encuentra en el DNS dns1.name-services.com , para que la configuracion de este Servidor pueda finalizar con exito el MX tambien debe estar configurado ahi.

    Es decir, en el servidor dns1.name-services.com debe de existir un registro MX que apunte a moisesvs.dyndns.org.


    Comunicate con el Administrador de este DNS y pidele que te lo adicione. Una vez adicionado todo depende del TTL del Servidor; me explico; si la TTL del servidor es de 1 hora, la replicacion en todos los servidores DNS del mundo se puede demorar 1 hora.

    A espera de Respuesta

    Saludos;

    sábado, 1 de agosto de 2009 16:27
  • Hola Jacinto muchas gracias!

    De que forma has realizado la prueba?

    Pero es que no puedo decirles que me creen un registro en su DNS... no conozco dns1.name-services.com, lo debo de administrar con el panel de control que me dan.

    Seguro que es fallo del DNS, por que he probado a mandar un mail de la siguiente forma: moisesvs@moisesvs.dyndns.org y de esa forma no funciona tampoco.

    De esa forma debería de funcionar, no es asi

    Muchas gracias por tu ayuda.

    Saludos y gracias!
    sábado, 1 de agosto de 2009 16:38
  • Hola Moises

    No de esa forma no te funciona ... y si es seguro, estoy seguro que es el DNS ya que me he comunicado con tu Servidor y desde ahi te puedo enviar correos. Mira la prueba la hice asi:

    Me comunique con el servidor de correo por medio del siguiente comando:

    telnet moisesvs.dyndns.org 25

    El me responde de la siguente manera:

    220 SERVIDOR.moisesvazquez.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.3
    959 ready at  Sat, 1 Aug 2009 18:14:35 +0200


    Luego me identifique con el Servidor de la siguiente manera:

    helo localhost

    el me respondio con un saludo:

    250 SERVIDOR.moisesvazquez.com Hello [Ip Publica ]

    y ya empece a enviar el mensaje de la siguiente manera:

    mail from: <moisesvs@moisesvazquez.com>

    250 2.1.0 moisesvs@moisesvazquez.com....Sender OK

    rcpt to: <moisesvs@moisesvazquez.com>

    250 2.1.5 moisesvs@moisesvazquez.com

    data

    354 Start mail input; end with <CRLF>.<CRLF>

    Esto es una Prueba desde la linea de comanods del Servidor de Correo, Contesta l
    a prueba hacia la direccion de correo j1111_0@hotmail.com.co
    ..
    .
    250 2.6.0 <SERVIDOROmzVtNPGdfS00000001@SERVIDOR.moisesvazquez.com> Queued mail f
    or delivery
    quit


    sábado, 1 de agosto de 2009 17:01
  • Te Explico

    cuando compras un dominio, lo que hacen es que te matriculan en el DNS de la siguiente manera:

    moisesvazquez.com HOST A moisesvs.dyndns.org

    y luego te dan un panel de control para que administres tu dominio. pero en la configuracion del DNS ellos te colaboran.

    Llama donde compraste el dominio ... dile que te comuniquen a alguien de soporte, pideles el favor que registren en el DNS el MX para que apunte a la direccion moisesvs.dyndns.org , Ellos no te cobran por eso.

    Nota: No sabria decirte si del panel de control te pueden hacer esto pero es la manera mas sencilla.

    Dale y veras que si no te ayudan al menos te dicen por medio del panel de control como hacerlo

    A espera de comentarios

    Saludos;
    sábado, 1 de agosto de 2009 17:10
  • Buenas Jacinto, si se a lo que te refieres y me quieres comentar, pero en los que venden dominios, lo que haces es que te proporcionan un panel de DNS, y lo que hacen es que en ese panel, puedes modificar lo punteros MX de tu dominio. Como te enseño a continuación:

    http://img7.imageshack.us/i/dnsdom.jpg/

    De esta forma, tienes el panel de control de dominio, y no te dejan nada más, no obstante lo consultaré para haber que puede pasar.

    De todas formas si se manda un email de la forma: moisesvs@moisesvs.dyndns.org si fuera culpa del dominio debería de funcionar, no?

    Saludos y gracias!
    sábado, 1 de agosto de 2009 18:13