none
sc query inetinfo me dice que no existe o que no esta instalado RRS feed

  • Pregunta

  • hola el caso es que necesito saber si un servicio determinado esta en estado "0", vamos que esta corriendo si o no, pero cuando consulto con SC me dice que no sabe de el, el servicio en cuestión es el el Servicio de administración del IIS, desde luego que el servicio desde la consola de services.msc me ofrece la posibilidad de hacer todo con este servicio, pero cuando quiero tener el estado usando SC, pues nada que no me dice nada, como veis me dice que no existe, esto me pasa con otros servicios, En este caso el de IIS, me pasa unsando el nombre exe y el displayname, pero en otros solo con el displayname, con el nombre del exe me funciona.

    Sabe alguien a que se debe esto? y sobre todo como puedo solucionarlo, porque el estado del servicio lo necesito para otra aplicación.

    C:\>sc query inetinfo.exe
    [SC] EnumQueryServicesStatus:OpenService ERROR 1060:

    El servicio especificado no existe como servicio instalado.

    C:\>sc query "Servicio de administracion IIS"
    [SC] EnumQueryServicesStatus:OpenService ERROR 1060:

    El servicio especificado no existe como servicio instalado.


    Carlos Del Prado

    martes, 11 de diciembre de 2012 9:03

Respuestas

  • Pues ya me lo he resuelto,

    el caso es que la mmc de los servicios da una informacion que no es cierta en todos los casos, aunque el sistema por dentro si maneje la correcta, por ello que nos deja reiniciar parar,etc servicios.

    ejecute esto "sc query type= all" y lo me ti en un fichero busque el IIS y el nombre del exe que el maneja es IISADMIN y no el inetinfo.exe por lo que al hacer el sc query del inetinfo, me decia que nanai de la china, ahora bien con sc query IISADMIN funcionam, lo que no sigue sin funcionar es el displayname, en ese caso la información es la misma y en ambos casos no sirve.

    Los otros servicios que no me funcionaban ya me van en uno que me mostraba la consola mmc que era serviciograbacionllamadas, realmente el tenia serviciograbacionllamadaswindowsservice, tocate los pies!!!

    EL caso es que con este otro "nombre" si me funciona todo, para obtener la informacion del estado del servicio para usar con Zabbix.

    Gracias a todos de todas formas


    Carlos Del Prado

    • Marcado como respuesta cdelprado martes, 11 de diciembre de 2012 9:32
    martes, 11 de diciembre de 2012 9:32