none
Sitio con acceso anónimo y subsitio con permisos exclusivos RRS feed

  • Pregunta

  • Hola a todos,

    Tengo un sitio web con al acceso anónimo habilitado y varios subsitios con permisos exclusivos a los que no tienen acceso los anónimos, estos subsitios no se muestran cuando entra un anónimo al sitio, pero hay uno de ellos que si sale en la barra de vínculos superior y si quieren entrar les pide la clave, como puedo hacer para que no se muestre al igual que los demás subsitios, los permisos están exactamente iguales.

    Gracias y saludos,

    Whilda

    martes, 7 de febrero de 2012 16:20

Todas las respuestas

  • Hola whilda

    ¿Podrías comprobar que dicho enlace no está pre-fijado en la configuración de la navegación?


    "En los momentos de crisis, sólo la imaginación es más importante que el conocimiento"

    martes, 7 de febrero de 2012 17:10
    Moderador
  • Gracias Santiago,

    Perdona, pero no comprendo bien a que te refieres.

    Saludos,

    Whilda

    martes, 7 de febrero de 2012 17:19
  • Hola! Gracias por contactar con los foros de Microsoft TechNet.

    Por favor, dirígete a Acciones del sitio y luego a Configuración del sitio. Luego has clic en el enlace Navegación, debajo de Aspecto.

    Si estás entregando ese enlace desde allí, deberás aplicar audiencia para evitar que los usuarios que no tienen acceso no puedan verlo.

    Me sigues o necesitas más detalle?


    Pablo Alejandro Fain
    MCP, MCSA, MCTS, MCITP
    To follow me on Twitter: @pabloafain
    To view my LinkedIn Profile: Click here
    This posting is provided AS IS, with no warranties.

    martes, 7 de febrero de 2012 18:11
  • Gracias Pablo,

    Ok ya lo ví, yo utilizo SharePoint Foundation y tengo en el menú directamente "Aspecto", el enlace al subsitio lo tengo en la barra de vínculos superior, aqui no tengo la opción de auditar, lo raro es que como comenté antes solo me da este problema con un subsitio los demás que no tienen acceso los anónimos no se muestran.

    Gracias y saludos,

    Whilda

    martes, 7 de febrero de 2012 19:06
  • Hola Whilda,

    las audiencias que comenta Pablo no están disponibles en SharePoint Foundation. Si los usuarios ven ese enlace, aunque no tengan permisos, sólo tienes que eliminarlo de la barra de vínculos superior y listo, los usuarios sin permisos dejaran de verlo.


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server

    martes, 7 de febrero de 2012 19:35
  • Gracias por seguir el hilo, Alberto. En efecto, SharePoint Foundation no contempla audiencias de usuarios.

    Lo que estaba pensando, Alberto, es que si Whilda elimina el enlace a ese sitio, todos sus usuarios dejarían de verlo y no se si es lo que el espera.


    Pablo Alejandro Fain
    MCP, MCSA, MCTS, MCITP
    To follow me on Twitter: @pabloafain
    To view my LinkedIn Profile: Click here
    This posting is provided AS IS, with no warranties.

    martes, 7 de febrero de 2012 19:41
  • Hola Pablo,

    por lo que puedo suponer, si los usuarios anónimos ven el enlace, puede pasar por dos motivos:

    1. Los permisos no están bien y los usuarios tienen acceso al sitio

    2. Se ha creado el enlace manualmente y por eso no respecta el comportamiento de seguridad de la plataforma que oculta aquello a lo que no tienes acceso o permiso.


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server

    martes, 7 de febrero de 2012 19:43
  • Coincido contigo, seguramente se haya añadido de manera manual ese enlace. Whilda, puedes confirmarlo?

    Pablo Alejandro Fain
    MCP, MCSA, MCTS, MCITP
    To follow me on Twitter: @pabloafain
    To view my LinkedIn Profile: Click here
    This posting is provided AS IS, with no warranties.

    martes, 7 de febrero de 2012 19:44
  • Gracias chicos por sus respuestas,

    Normalmente cuando creo un subsitio selecciono que quiero que esté en la barra de vínculos superior.

    Pero con este honestamente no me acuerdo si lo hice así o si copié y pegué el enlace agregandolo a la barra.

    Ya he revisado varias veces los permisos y todos los listados a ver si alguno permitía el acceso anónimo y están todos correctos.

    Estaba pensado guardar como plantilla todos los listados, eliminar el sitio y crearlo de nuevo, aunque tengo curiosidad de saber por que este comportamiento.

    Gracias y saludos,

    Whilda

    martes, 7 de febrero de 2012 21:10
  • Por qué no intentas primero decirle que herede los vínculos del nivel superior?

    Pablo Alejandro Fain
    MCP, MCSA, MCTS, MCITP
    To follow me on Twitter: @pabloafain
    To view my LinkedIn Profile: Click here
    This posting is provided AS IS, with no warranties.

    martes, 7 de febrero de 2012 23:58
  • Hola Pablo,

    Ya lo hice pero no me funciona, lo que si he podido comprobar es lo que comentaste antes, si agrego el enlace a la barra de vínculos superior manualmente es cuando se le muestra a los usuarios anónimos.

    Pero no se como arreglarlo.

    Saludos,

    Whilda

    miércoles, 8 de febrero de 2012 13:48
  • Hola whilda

    ¿has eliminado el vínculo que te sobra? Posiblemente se haya creado manualmente y por eso lo ven todos los usuarios.


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server

    miércoles, 8 de febrero de 2012 19:09
  • Hola Alberto,

    Si por la prueba que hice me he dado cuenta que lo agregué manualmente, no lo he quitado porque me hace falta para los usuarios autorizados.

    Saludos,

    Whilda

    miércoles, 8 de febrero de 2012 20:54
  • Vale, pero para los usuarios autorizados tienes una opción en la configuración del menú que muestra los subsitios automáticamente, sin necesidad de crear el enlace.


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server

    miércoles, 8 de febrero de 2012 20:59
  • Ah si?

    Si no selecciono, al momento de crear el subsitio que aparezca automáticamente en la barra vínculos superior, hay una forma de que lo haga solo?

    No he visto esa opción, donde está?

    Solo me salen las siguientes opciones: Nuevo vínculo, cambiar orden y utilizar vínculos del sitio primario.

    Gracias!

    miércoles, 8 de febrero de 2012 21:21