none
Value cannot be null. Parameter name: g RRS feed

  • Pregunta

  • Buenas tardes a todos.

    Espero que estén bien.

    Tengo un problema en el catalogo a través de una colección de sitios en la referencia http://sitio_layouts/15/AddCatalogSource.aspx. Al darle acceder al configuración del sitio ► Administrar conexiones al catálogo ► Conectar a un catalogo ► Escoger el catálogo requerido y clic en el botón Conectar. Arroja el siguiente error: Value cannot be null. Parameter name: g y ademas en la sección Página de categorías no muestra las páginas maestras.

    Cómo podría hacer para solucionar éste problema?

    Muchas gracias.


    ______________________ Jairo Baleta Ingeniero de Infraestructura


    • Editado Jairo Baleta jueves, 2 de marzo de 2017 16:05 Actualización
    jueves, 2 de marzo de 2017 16:01

Respuestas

  • Saludos, Jairo, te cuento que tuve exactamente el mismo error.  Luego de hacer varios laboratorios logré solucionarlo.

    Procedimiento

    1. Configuración del sitio --> Acciones del sitio --> Administrar las características del sitio --> Deshabilitar la característica Publicación de SharePoint Server.

    2. Configuración del sitio --> Administración de la colección de sitios --> Características de la colección de sitios --> deshabilitar Infraestructura de publicación de SharePoint Server.

    3. Abrir la consola de Administración de SharePoint 2013 - PowerShell - en modo administrativo y ejecutar 

    Enable-SPFeature -Identity F6924D36-2FA8-4f0b-B16D-06B7250180FA -Url http://sitecolection

    4. Configuración del sitio --> Acciones del sitio --> Administrar las características del sitio --> Habilitar la característica Publicación de SharePoint Server.

    5. Intente nuevamente Administrar conexiones al catálogo.

    Si tienes muchos sitios web, podría utilizar PowerShell

    Add-PSSnapin "Microsoft.SharePoint.PowerShell"
    #Get-SPWeb -site http://siteCollection -limit ALL | ForEach-Object {Disable-SPFeature Publishing -Url $_.Url -confirm:$false}
     
    #Get-SPWeb -site http://siteCollection -limit ALL | ForEach-Object {Disable-SPFeature PublishingWeb -Url $_.Url -confirm: $false}
     
    #Get-SPWeb -site http://siteCollection -limit ALL | ForEach-Object {Enable-SPFeature Publishing -Url $_.Url -confirm:$false}
     
    #Get-SPWeb -site http://siteCollection -limit ALL | ForEach-Object {Enable-SPFeature PublishingWeb -Url $_.Url -confirm: $false} 

    Carlos Andrés Pérez - Capa

    @Capatechsas

    • Propuesto como respuesta Moderador M jueves, 30 de marzo de 2017 15:48
    • Votado como útil Moderador M jueves, 6 de abril de 2017 14:26
    • Marcado como respuesta Moderador M martes, 6 de junio de 2017 20:50
    martes, 28 de marzo de 2017 20:19

Todas las respuestas

  • Hola Jairo, 

    Si revisas los logs de SharePoint, que error te muestra? podrías compartirlos? 


    Gabriel Edo. Sibaja | Comunidad SharePoint Costa Rica - http://www.sharepointcostarica.com | Twitter: @Gabs_Sibaja | Blog: http://gabsibaja.blogspot.com

    domingo, 12 de marzo de 2017 19:25
  • Saludos, Jairo, te cuento que tuve exactamente el mismo error.  Luego de hacer varios laboratorios logré solucionarlo.

    Procedimiento

    1. Configuración del sitio --> Acciones del sitio --> Administrar las características del sitio --> Deshabilitar la característica Publicación de SharePoint Server.

    2. Configuración del sitio --> Administración de la colección de sitios --> Características de la colección de sitios --> deshabilitar Infraestructura de publicación de SharePoint Server.

    3. Abrir la consola de Administración de SharePoint 2013 - PowerShell - en modo administrativo y ejecutar 

    Enable-SPFeature -Identity F6924D36-2FA8-4f0b-B16D-06B7250180FA -Url http://sitecolection

    4. Configuración del sitio --> Acciones del sitio --> Administrar las características del sitio --> Habilitar la característica Publicación de SharePoint Server.

    5. Intente nuevamente Administrar conexiones al catálogo.

    Si tienes muchos sitios web, podría utilizar PowerShell

    Add-PSSnapin "Microsoft.SharePoint.PowerShell"
    #Get-SPWeb -site http://siteCollection -limit ALL | ForEach-Object {Disable-SPFeature Publishing -Url $_.Url -confirm:$false}
     
    #Get-SPWeb -site http://siteCollection -limit ALL | ForEach-Object {Disable-SPFeature PublishingWeb -Url $_.Url -confirm: $false}
     
    #Get-SPWeb -site http://siteCollection -limit ALL | ForEach-Object {Enable-SPFeature Publishing -Url $_.Url -confirm:$false}
     
    #Get-SPWeb -site http://siteCollection -limit ALL | ForEach-Object {Enable-SPFeature PublishingWeb -Url $_.Url -confirm: $false} 

    Carlos Andrés Pérez - Capa

    @Capatechsas

    • Propuesto como respuesta Moderador M jueves, 30 de marzo de 2017 15:48
    • Votado como útil Moderador M jueves, 6 de abril de 2017 14:26
    • Marcado como respuesta Moderador M martes, 6 de junio de 2017 20:50
    martes, 28 de marzo de 2017 20:19