none
SUMA SEGUN CONDICION, CONSULTA POR RANGO , QUE DORMULA USAR RRS feed

  • Pregunta

  • Hola a Todos

    Tengo  una tabla  con las  siguientes columnas:

    PEDIDO, VENTAS, DIA, TURNO

    Ahora quiero  sumar  los valores de venta  por  Turno (hay tres MAÑANA, TARDE,NOCHE) y  que los  sume en  una celda  ,  sin usar  autofiltro  u  subtotales, con  formula

    Tambien  necesito  sumar las ventas  por dia (hay siete LUNES....) y que  tambien  la sume en  otra celda , sin usar  autofiltro  u subtotales, con formula,

    

    Gracias

    Alexia

    martes, 25 de septiembre de 2012 15:01

Todas las respuestas

  • Hola Alexia, es posible que necesitemos alguna precisión posterior.

    Tus campos estan en las columnas A, B, C y D en el mismo orden que tu has decidido. En la fila 1 tenemos los títulos y el rango de filas con los datos es de A2:D100.

    Fórmula para las ventas por turno, la celda F1 contiene el turno elegido:

    =SUMAR.SI.CONJUNTO(B2:B100;D2:D100;F1)

    yo utilizo el ";" como separador, comprueba que sea el tuyo o lo has de cambiar.

    Fórmula para las ventas por día de la semana, aquí se complica la cosa, he supuesto que en la columna C que tu titulas "Día" estan las fechas en formato Excel, en la celda G1 tienes el día de la semana en formato número, del 1 al 7.

    Para semana americana, Domingo=1 hasta el Sábado=7

    =SUMAPRODUCTO((DIASEM(C2:C100)=G1)*(B2:B100))

    Para semana europea, Lunes=1 hasta el Domingo=7

    =SUMAPRODUCTO((DIASEM(C2:C100;2)=G1)*(B2:B100))

    Veremos si he sabido deducir tus datos, de lo contrario habrás de concretarlos.

    Saludos,

    Xavier

    martes, 25 de septiembre de 2012 16:38
  • Muchas  Gracias Xavier, 

    Pude resolver mi  ejercicio,sera mucho  molestarte con  otra consulta respecto  a  filtros avanzados sucede que tengo una tabla  con los siguientes encabezados

      CODIGO,NOMBRE, REGION, CURSO, EXAMEN  PARCIAL,COSTO, DESCUENTO, NETO A PAGAR,EXAMEN FINAL, NOTA, OBS,

    Y me piden  hacer  filtros  avanzados,  

    1ro  con  Nombre y  region, pero  que comiencen  con  una letra determinada

    2do por Region y  curso

    y por ultimo  por Curso  , Examen final,  y  nota,

    Pero  la verdad no  comprendo como  utilizar los filtros avanzados,  estoy intentandolo  como  hace 2 horas, pero  no  me sale,  si pudieras ayudarme,  te agradecería

     

    
    
    
    martes, 25 de septiembre de 2012 21:35
  • Hola Alexia, tu pregunta es posible pero muy larga de explicar para propósito general.

    La ayuda de Excel es muy buena en estos casos, te la habrás de leer.

    Después para un caso muy concreto puedes repreguntar dando el máximo de información, porque el recrear una hoja de otro siempre es muy laboriosa y se ha de utilizar mucho tiempo.

    Saludos,

    Xavier

    miércoles, 26 de septiembre de 2012 8:39