locked
id 1002 application hang RRS feed

  • Pregunta

  • Hola,

    Tengo la siguiente situación:

    una aplicación desarrollada en Clarion, funciona correctamente bajo windows 98, pero cuando trabaja bajo windows xp se presenta la siguiente anomalía ocasional. 

    la aplicacion se bloquea (transparencia blanca) y crea el siguiente registro en el visor de eventos.

    Tipo de suceso: Error
    Origen del suceso: Application Hang
    Categoría del suceso: (101)
    Id. suceso: 1002
    Fecha: 08/03/2014
    Hora: 02:21:14 p.m.
    Usuario: No disponible
    Equipo: DOMICILIOS1
    Descripción:
    Aplicación que no responde: callcent.exe, versión 0.0.0.0, módulo que no responde hungapp, versión 0.0.0.0, dirección que no responde 0x00000000.

    Para obtener más información, vea el Centro de ayuda y soporte técnico en http://go.microsoft.com/fwlink/events.asp.
    Datos:
    0000: 41 70 70 6c 69 63 61 74   Applicat
    0008: 69 6f 6e 20 48 61 6e 67   ion Hang
    0010: 20 20 63 61 6c 6c 63 65     callce
    0018: 6e 74 2e 65 78 65 20 30   nt.exe 0
    0020: 2e 30 2e 30 2e 30 20 69   .0.0.0 i
    0028: 6e 20 68 75 6e 67 61 70   n hungap
    0030: 70 20 30 2e 30 2e 30 2e   p 0.0.0.
    0038: 30 20 61 74 20 6f 66 66   0 at off
    0040: 73 65 74 20 30 30 30 30   set 0000
    0048: 30 30 30 30               0000    

    es importante aclarar que la aplicacion funciona, solo que ocasionalmente se bloquea. y no hay ningún patrón detectable que ocacione la falla. simplemente sucede aleatoriamente.

    tambien es de tener en cuenta que la situación se presenta en 6 equipos, todos con windows xp y algunos los he reinstalado y siguen con el mismo comportamiento.

    lo unico raro que hace la aplicacion es que ejecuta algunas cosas por comandos de msdos.

    la unica configuracion que se me ha ocurrido realizar y no funciono fue ajustar el archivo config.nt incluyendole files=120 y buffers= 255.

    Culquier aporte muchas gracias.

    sábado, 22 de marzo de 2014 3:18

Todas las respuestas

  • Me sucede los mismo con otro aplicativo, me presenta el mismo error, podiste solucinarlo?
    martes, 19 de enero de 2016 21:25
  • Hola Andres,

    realmente no he podido solucionar este inconveniente. otras cosas que he probado y que me disminuyeron el problema, fue configurar el sistema para que solo usara un procesador en el msconfig. también le deshabilite la aceleración de hardware en la tarjeta de video.

    se presenta menos, pero el problema persiste.

    saludos


    FJBS

    miércoles, 20 de enero de 2016 14:07