locked
Win vista trata de grabar en CD siempre RRS feed

  • Pregunta

  • Hola a todos;

     

    Mi PC Lenovo ThinkCentre con Windows Vista Business no lee los CD o DVD, en su lugar siempre los detecta como discos en blanco y saca un mensaje que indica que los va a formatear.  Alguien sabe cómo se soluciona esto?  Gracias

     

     

    miércoles, 14 de noviembre de 2007 20:43

Respuestas

  •  dianaBSB2001 Escribió:

    vamos a ver què opciòn tomo y yo creo que tendrè que hacer uso de a garantía, aunque la verdad le tengo mucha pereza a lo de formatear e instalar todo.


    Pues aunque de pereza... es la manera de comprobarlo. Que conste que no es raro que nos vendan hardware deañado ya que la bajada de precios ultimamente ha implicado una bajada de controles de calidad increible... :-P

    Un saludo,
    domingo, 26 de octubre de 2008 8:40

Todas las respuestas

  • Esto sucede en dos casos (tanto en Vista, como en XP):

     

    1) El hardware está dañado. Es decir la grabadora está mal.

     

    2) O bien, has instalado algun software de grabacion no compatible elñ cual instala drivers o filtros. Para ver si es esto, primero creas un punto de restauracion y luego teclea en inicio -> buscar, teclea regedit (no pulses intro). Cuando te aparezca arriba, seleccionalo con el boton derecho y dale a "Ejecutar como Administrador". Dentro del el, localiza la clave:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

     

    Y en la zona de la derecha veras Upperfilters y Lowerfilters (puedes ver las dos o simplemente una de ellas). Eliminalas y reinicia. Si no se soluciona es el punto 1), o sea, está dañado la grabadora.

     

    Un saludo,
    miércoles, 14 de noviembre de 2007 21:11
  • Hola José Manuel;

     

    Gracias por la pronta respuesta.

     

    1. La unidad de DVD está buena, tengo instalada en el mismo PC una máquina virtual con Win XP y ésta sí lee todos los CD/DVD.  Además antes de migrar a Win Vista todo funcionaba bien.
    2. En la cadena que me enviaste no me aparecen los valores "Upperfilters" ni "Lowerfilters", te anexo los valores que me aparecen, no se si sirvan de algo:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]
    "Class"="CDROM"
    "ClassDesc"="@%SystemRoot%\\System32\\StorProp.dll,-17001"
    @="DVD/CD-ROM drives"
    "IconPath"=hex(7):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
      74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,69,\
      00,6d,00,61,00,67,00,65,00,72,00,65,00,73,00,2e,00,64,00,6c,00,6c,00,2c,00,\
      2d,00,33,00,30,00,00,00,00,00
    "Installer32"="storprop.dll,DvdClassInstaller"
    "EnumPropPages32"="storprop.dll,DvdPropPageProvider"
    "SilentInstall"="1"
    "NoInstallClass"="1"

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}\0000]
    "InfPath"="cdrom.inf"
    "InfSection"="cdrom_install"
    "ProviderName"="Microsoft"
    "DriverDateData"=hex:00,80,8c,a3,c5,94,c6,01
    "DriverDate"="6-21-2006"
    "DriverVersion"="6.0.6000.16386"
    "MatchingDeviceId"="gencdrom"
    "DriverDesc"="Unidad de CD-ROM"

     

     

    Saludos,

     

     

    jueves, 15 de noviembre de 2007 14:20
  • Lo que te dice Juan Manuel Tella Llop, es verdad, seguramente tenes instalado el Roxio Nero Burnings Rom.

    En  este caso tenes que tener si o si esa clave de registro.

     

    1.- Desde el Editor de Registro (regedit.exe) se eliminan las claves UpperFilters y LowerFilters de la llave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}.

     

    2.- Fijate tambien que este el archivo "pxhelp20.sys"  en el "c:\windows\system32\drivers\"

     

    3.- Si no esta el "pxhelp20.sys" podes descargarlo de ftp.microsoft.com.ar/so

     

    4.- En caso de que este el archivo lo podes renombrar que este inconveniente se soluciona.

     

    5.- antes de hacer el paso 3 y 4 fijate que si o si tiene que estar los valores Upperfiltters y Lowerfiltters, que si o si tienen que estar..

     

    Saludos.-

    lunes, 19 de noviembre de 2007 20:05
  • Yo tengo el mismo problema revise el registro que Uds. indican no veo UpperFilters y LowerFilters ademas veo la carpeta propiedades pero no me deja verla y no puedo editar esa carpeta. En esa misma clave existe 3 carpetas ademas de la de propiedades y son 001,002 y 003.

    Bueno si tienen alguna idea de como salir de este problemon le agradecere.

    Saludos y Gracias

     

    Miguel

     

    miércoles, 21 de noviembre de 2007 0:03
  • es un valor que esta a la derecha, no es una carpeta que esta en el registro, dentro de esa ruta esta lowefilters y upperfilters.

     

    En caso que no lo encuentres hace el paso 2 y 3.

     

    Saludos...

    miércoles, 21 de noviembre de 2007 0:10
  • Señores; se les agradece el tiempo dedicado.

     

    En el registro NO aparecen "lowefilters" ni "upperfilters" Definitivamente NO, NO y NO.  Disculpen pero es que eso de "si o si"...  El archivo "pxhelp20.sys" tampoco aparece, por lo que lo bajé de la ruta que indica Cristian y lo copié a la ruta especificada; reinicié la máquina y... ¡el problema continúa!

     

    Lo extraño es que cuando me sale el mensaje le doy cancelar, le indico al sistema que expulse el disco y lo vuelvo a insertar... ¡y ahí si funciona bien!

     

    Antes de que alguien me diga que eso es problema de la unidad lectora... ya la cambié por otra unidad DVD RW.

     

    El Roxio Nero Burnings Rom nunca ha esta instalado en mi máquina (personalmente no me gusta....).  He instalado el Nero 8, por si las moscas... la cosa sigue igual.  Es de anotar que el mismo problema lo tengo en otro PC.  Uno es en el PC del trabajo y el otro en el de mi casa, las instalaciones se han hecho con medios distintos, aunque ambos son Windows Vista Business.

     

    Saludos,

    miércoles, 21 de noviembre de 2007 15:41
  •  Nelson Montoya Escribió:

    En la cadena que me enviaste no me aparecen los valores "Upperfilters" ni "Lowerfilters",

     

    Abre el administrador de dispositivos, localiza la unidad de CD/DVD, boton derecho sobre ella, propiedades, pestaña de Controlador, y boton de detealles del controlador: ¿que ficheros aparecen allí?

     

    Un saludo,

    miércoles, 21 de noviembre de 2007 17:02
  • Solo aparece este archivo:

    C:\Windows\system32\DRIVERS\cdrom.sys

     

     

    ????

     

     

    Saludos,

    miércoles, 21 de noviembre de 2007 17:38
  • Se me olvidaba...

     

     NelsonM Escribió:

    He instalado el Nero 8, por si las moscas... la cosa sigue igual.  Es de anotar que el mismo problema lo tengo en otro PC.  Uno es en el PC del trabajo y el otro en el de mi casa, las instalaciones se han hecho con medios distintos, aunque ambos son Windows Vista Business.

     

    Nero 8 deja muchisimo que desear. Cuando saquen la 8,5 a lo mejor podemos hablar... ¿en ambas maquina con Nero 8?... Si haces una prueba de instala Vista Business en otra particion en limpio verás que el problema no pasa -presupongo que no es problema hardware-. ¿entonces?...

     

    Un saludo,

    miércoles, 21 de noviembre de 2007 18:30
  • HOLA...

    sè que desde la publicación del mensaje ha pasado tiempo...espero encontrar soluciòn.

     

    Tengo Win Vista Ultimate (y dos sesiones) y seguí las recomendaciones que todos mencionaron en esta discusión y los resultados fueron: (antes de serguir las recomendaciones estuve buscando las actualizaciones de drivers de mi unidad y no las encontrè. PIONEER DVRKD08L ATA)

     

    1. Al  buscar el famoso Lower y Upper filters en registro..no los encontrè

    2. Bajé las actualizaciones de WinVista y nada

    3. Instalé el archivo "pxhelp" y nada...reiniciè el equipo, inserté un CD y nada..luego lo saqué el CD, inicié con otra sesión y ahí sí lo reconoció, vuelvo a la otra sesión y todo bien...sin embargo, cuando reinicié nuevamente el equipo volvieron los problemas y sale "Preparar este disco en blanco".

     

    No sé si el Roxio Nero Burning Rom es el mismo Nero 7 al que se refieren y que es el ke tengo instalado...será ese el culpable?

     

    Gracias

    jueves, 23 de octubre de 2008 1:45
  •  dianaBSB2001 Escribió:

    3. Instalé el archivo "pxhelp" y nada...reiniciè el equipo, inserté un CD y nada..luego lo saqué el CD, inicié con otra sesión y ahí sí lo reconoció, vuelvo a la otra sesión y todo bien...sin embargo, cuando reinicié nuevamente el equipo volvieron los problemas y sale "Preparar este disco en blanco".

     

    El pxhelp es peligrosismo.. como casi todos los filtros, por lo que si lo instalaste SI que tienen que aparecerte o bien lowerfilters o bien uperfilters y si no lo ves es que estás mirando incorrectamente en el registro.

    La desistalacion del software de grabacion suele ser incompleta en cualquier paquete por lo que si a lo largo de la instalacion de Vista has estado instalando / desistlanado, puede pasar cualquier cosa: una desistalacion lo mejor es hacerla recuperando de un punto previo de recuperacion lo cual te dejará la maquina correcta. Pero esto, pro desgracia, no lo suele hacer casi nadie, o cuando relacion la causa / efecto, ya no puede hacerlo por no existir puntos de restauracion anterirore.

     

    Por otra parte ¿tienes una particion limpia en donde instalar otro Vista?... verás que nada mas instalarlo el problema no sucede y tampco sucede despues de actualizar con los parches, SP1, etc... por tanto hay un problema de software que el unico que podria diagnosticarlo eres tu. (el Nero 7 no causa problemas de ese estilo).

     

    Un saludo,

    jueves, 23 de octubre de 2008 11:13
  • Hola Manuel

     

    Gracias por contestar.

     

    Lo que mencionas de instalar/desinstalar no lo he hecho hasta saber si ese era el problema o no, y así lo desinstalara, lo del punto de restauración no me serviría porque apenas compré el computador, apenas lo instalé y todo funcionaba bien. Incluso ví DVD de películas y sin lío.

     

    Fue tiempo después que apareció el problema cuando una mañana inserté un CD de datos y salió el famoso mensaje y de ahí en adelante.

     

    Mencionas que Nero 7 no causa este tipo de problemas..¿qué otro software puede ser?

     

    Y lo del registro... creo entonces que definitivamente estoy mirando mal el registro.Seguí las instrucciones que publicaste:

     

     inicio -> buscar, teclea regedit (no pulses intro). Cuando te aparezca arriba, seleccionalo con el boton derecho y dale a "Ejecutar como Administrador". Dentro del el, localiza la clave:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

     

    y la verdad me perdí en el punto de: (no pulses intro). porque ¿de qué otro modo entro al editor de registro si no le doy enter?

     

    Entré de todas formas al regedit y encontré toda la ruta (en realidad varias obviamente busquè la refereida unidad CD/DVD) pero no los famosos lower/Upper filters y de todas formas no aparecen.

    viernes, 24 de octubre de 2008 1:09
  •  

    Se refiere a que en vez de darle directamente con el raton para que lo abra, que le des con el boton derecho del raton y le digas "ejecutar como administrador"... no lo se, pero creo que si entras como un usuario "normal" algunas claves del registro no puedes modificarlas..

     

    Saludos!

    viernes, 24 de octubre de 2008 11:54
  •  dianaBSB2001 Escribió:

     porque apenas compré el computador, apenas lo instalé y todo funcionaba bien. Incluso ví DVD de películas y sin lío.



    Pues si no existen las calves y al princpio te funcionaba... me huelo un problema hardware. La unica manera sería hacer copia de seguridad de tus datos y volver a instalar desde los sistemas de recuperacion que te haya dado tu OEM... probar nada mas instalar y si sigue pasando... ejercer la garantia del equipo.


    Si no pasase, a partir de ese momento crear puntos de restauracion antes de instalar nada y despues de cada instalacion ir probando. Te comento esto, porque si el culpable fuese algun software (que lo dudo por lo que has comentado), lo cazarias inmediatamente.


    Un saludo,

    viernes, 24 de octubre de 2008 13:34
  • Bueno Jose..gracias por tu atenciòn...inicié nuevamente lo del Regedit y ya encontré lo de "ejecutar como administrador" y aún así no aparecen los lower/upper filter.

     

    vamos a ver què opciòn tomo y yo creo que tendrè que hacer uso de a garantía, aunque la verdad le tengo mucha pereza a lo de formatear e instalar todo.

     

    Gracias nuevamente

     

    Diana

    domingo, 26 de octubre de 2008 3:07
  •  dianaBSB2001 Escribió:

    vamos a ver què opciòn tomo y yo creo que tendrè que hacer uso de a garantía, aunque la verdad le tengo mucha pereza a lo de formatear e instalar todo.


    Pues aunque de pereza... es la manera de comprobarlo. Que conste que no es raro que nos vendan hardware deañado ya que la bajada de precios ultimamente ha implicado una bajada de controles de calidad increible... :-P

    Un saludo,
    domingo, 26 de octubre de 2008 8:40