none
Problemas al crear sitios de Active Directory RRS feed

  • Pregunta

  • Hola a todos:

    Estoy intentando configurar dos sitios de Active Directory que corresponden a dos DC en ubicaciones  geográficas distintas. Creo los dos sitios, añado a cada sitio los DC correspondientes y el rango de direcciones ip de cada sitio. El problema es que a la hora de comprobar la replicación, me dice que: "AD no puede replicar las conexiones porque están en sitios distintos". Pero cuando meto ambos DC en un mismo sitio si me replican las conexiones.

    ¿Cuál puede ser el problema?

    Graciapor vuestro tiempo.

    miércoles, 27 de octubre de 2010 11:55

Respuestas

  • Creo que nos hemos liado :-P

    En las réplicas inter-site, ese mensaje es completament normal, es lógico, al ser DCs de diferentes sites no replican igual que los que están en el mismo; el mensaje sólo te informa de ello, ya que replicará el AD al momento, pero el SYSVOL lo hará en las horas que tú hayas establecido como permitidas para replicar entre sitios


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    • Marcado como respuesta Voltimer viernes, 12 de noviembre de 2010 15:28
    jueves, 11 de noviembre de 2010 10:48

Todas las respuestas

  • el mensaje es normal porque los DCs entre sitios diferentes sólo replican todos el contenido del SYSVOL a las horas que hayas establecido en el SiteLink  (al hacer lo que comentas fuerzas la réplica del AD como tal, pero no el SYSVOL); puedes  hacer una prueba simplem e crearte un usuario, y forzar la réplica y ver que en el otro DC aparece ya creado; a parte, siempre puedes usar el repadmin para forzar la réplica entera


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    miércoles, 27 de octubre de 2010 12:53
  • Grácias por tu respuesta!, probaré lo que me dices.

    Muchas gracias. Un saludo

    jueves, 28 de octubre de 2010 15:10
  • Buen día, tienes configurados los DC de cada sitio con su correspondiente rango de direcciones? porque si dices que están en diferentes site y cuando pones ambos DC en un mismo site la réplica se aplica correctamente quiere decir que ambos site tienen el mismo rango de IP.
    Si pudieras postear algo mas detallado para ver porque no replica correctamente seria bueno.

     

    Sludos


    Diego Caccire Windows System Administrator
    jueves, 28 de octubre de 2010 16:43
  • Los rangos de Ip son los siguientes:

    Site 1: 192.32.10.x  // DC1

    site 2: 192.101.1.X  // DC2

    DC1 es el controlador principal del dominio

    DC2 es un controlador secundario del dominio

    Gracias de nuevo por vuestro tiempo. Un saludo

    jueves, 28 de octubre de 2010 17:27
  • Tienes creados entonces los sites y cada DC está en el que debe?
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    viernes, 29 de octubre de 2010 7:38
  • Si, los sites están creados, y cada controlador de dominio está en el site que le corresponde con el correspondiente rango de direcciones Ip
    viernes, 29 de octubre de 2010 10:23
  • Hola Voltimer

    Saque lo resultado del comando abajo y ponga acá.

    dcdiag /test:replications

    Saludos


    Ismael Borche
    jueves, 4 de noviembre de 2010 20:10
  • ok, pondré los resultados en cuanto pueda. Gracias una vez mas.

    Un saludo.

    sábado, 6 de noviembre de 2010 9:34
  • Hola Voltimer

    Hay algún avanzo en la solucion de este problema? Ya sacaste los resultados?

    Saludo

    Ismael Borche
    miércoles, 10 de noviembre de 2010 15:52
  • Hola de nuevo, lo siento pero he andado algo ocupado. Intentaré postear los resultados lo antes posible, ya que me urge solucionar el problema.

    Gracias por vuestro tiempo una vez más, y lo dicho, intentaré mostrar los resultados lo antes posible.

    miércoles, 10 de noviembre de 2010 19:38
  • Aqui teneis el resultado de dcdiag /test:replications ejecutado en el DC principal del dominio. Sigue sin replicarme con los DC secundarios de las restantes ubicaciones. Me muestra este mensaje: "Una o más conexiones de AD están en DC en diferentes sitios. Active directory intentará replicar entre estas conexiones".

     

    Domain Controller Diagnosis

    Performing initial setup:
       Done gathering initial info.

    Doing initial required tests
      
       Testing server: Sevilla\SRVFILESUASEW
          Starting test: Connectivity
             ......................... SRVFILESUASEW passed test Connectivity

    Doing primary tests
      
       Testing server: Sevilla\SRVFILESUASEW
          Starting test: Replications
             ......................... SRVFILESUASEW passed test Replications
      
       Running partition tests on : ForestDnsZones
      
       Running partition tests on : DomainDnsZones
      
       Running partition tests on : Schema
      
       Running partition tests on : Configuration
      
       Running partition tests on : ris
      
       Running enterprise tests on : ris.rew

    jueves, 11 de noviembre de 2010 10:03
  • Creo que nos hemos liado :-P

    En las réplicas inter-site, ese mensaje es completament normal, es lógico, al ser DCs de diferentes sites no replican igual que los que están en el mismo; el mensaje sólo te informa de ello, ya que replicará el AD al momento, pero el SYSVOL lo hará en las horas que tú hayas establecido como permitidas para replicar entre sitios


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    • Marcado como respuesta Voltimer viernes, 12 de noviembre de 2010 15:28
    jueves, 11 de noviembre de 2010 10:48
  • Bueno, lo he comprobado y tras cumplir el tiempo de replicación de 180 minutos(por defecto), todo funciona correctamente. He creado un usuario y se ha replicado al cabo de ese tiempo a los demas DC. jajaja creo que me habia liado un poco, la verdad es que pensaba que ese mensaje que mostraba al intentar replicar significaba que habia algún tipo de error.

    Me gustaría haceros otra consulta: en un mismo site de AD(misma ubicación física) tengo dos DC. Uno hace función de DC principal del dominio y el otro proporciona un servicio web con sharepoint. Como puedo forzar a que los usuarios hagan login en el DC principal y no en el de sharepoint. El problema es que para que corriera sharepoint tuve que promocionarlo a DC, y claro ahora los usuarios hacen login tanto en el DC principal como en el de Sharepoint.

    Muchas gracias por vuestro tiempo.

    Un saludo

    viernes, 12 de noviembre de 2010 9:04
  • Voltimer, al ser una pregunta de un tema diferente, por favor, inicia un nuevo hilo. Gracias

     Y por favor, marca cuál fue la respuesta a tu pregunta


    Guillermo Delprato - Buenos Aires, Argentina
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    viernes, 12 de noviembre de 2010 10:45
    Moderador
  • Ok, lo siento, abriré un nuevo hilo para mi nueva consulta. En relación la la respuesta a mi pregunta está claro que el Sr. Javier_Inglés tenía toda la razón del mundo. jejeje.

    Una vez más muchas gracias por dedicar vuestro tiempo a los demás, sois geniales.

    Un saludo.

    viernes, 12 de noviembre de 2010 15:30