none
Enviar un documento desde una biblioteca como adjunto a un email. RRS feed

  • Pregunta

  • Hola, Tengo SharePoint Entrerprise 2010 y quisiera saber si se puede hacer para que se pueda mandar directamente desde el SharePoint un documento o varios por email como adjuntos. He leido para WSS 2003 algún codigo javascript que permite eso, pero para SharePoint Sever 2010 no he visto nada.
    martes, 8 de mayo de 2012 10:35

Respuestas

Todas las respuestas

  • Hola,

    Tienes una muy buena solución en Codeplex: http://sendemailsp2010.codeplex.com/

    Permite enviar documentos por correo electrónico desde una librería.

    Saludos.


    Tomás González. Twitter://@tgmourino

    martes, 8 de mayo de 2012 10:44
  • Buenas,

    También puedes conectar la biblioteca a outlook. Para ello, en la cinta de opciones vas a Herramientas de bibliotecas->Biblioteca-> Conectar con Outlook (es el icono de outlook, necesitas tener outlook instalado, claro)

    Saludos.


    Tomás González. Twitter://@tgmourino

    martes, 8 de mayo de 2012 10:52
  • No me interesa conectar a Outlook y sincornizar por SharePoint, porque necesito utilizar los filtros personalizados que he puesto en la biblioteca a la hora de buscar y seleccionar ficheros.

    Un saludo,

    Nota: voy a probar tu primera opción a ver que tal ;)

    martes, 8 de mayo de 2012 10:55
  • Ya esta implementado. Ahora tengo algún problema con los ActiveX... pero sigo en ello

    Muchas Gracias,

    martes, 8 de mayo de 2012 12:33
  • Hola,

    Ya tengo todo implementado en SharePoint, pero no me funciona porque me sale un error de ActiveX. He probado habilitando todo en ActiveX y me sigue dando problemas. Adjunto imagen del error.

    Pregunta, ¿Es obligatorio que el equipo cliente este unido al dominio del servidor? Desde el equipo que estoy probando no esta unido al dominio, es un equipo independiente, pero todo lo demas me funciona. El outlook que uso es 2010.

    Un saludo,

    martes, 8 de mayo de 2012 12:58
  • Hola,

    Efectivamente, el equipo tiene que estar en el mismo dominio que el servidor Sharepoint, mira la documentación:

    http://sendemailsp2010.codeplex.com/documentation

    Saludos.


    Tomás González. Twitter://@tgmourino

    martes, 8 de mayo de 2012 14:11
  • He unido mi equipo al dominio por VPN, ya que no trabajo en la misma ubicación que esta en servidor y aun asi sigue sin funcionar. Me da el mismo error.

    No se que puedo estar haciendo mal :(

    martes, 8 de mayo de 2012 15:39
  • Buenas,

    Tienes habilitado el inicio automático de sesión y usuario en las opciones de seguridad de Internet explorer?

    Esto lo obtuve de bucear por los comentarios del link que te pasé para ver la documentación de la solución. La verdad es que yo cuando la instalé no me dio ningún problema.

    Saludos.


    Tomás González. Twitter://@tgmourino

    martes, 8 de mayo de 2012 17:06