locked
winodws explorer ha dejado de funcionar RRS feed

  • Pregunta

  •  

    Buenas noches, tengo un problema con el windows explorer ya que despues de cierto tiempo de habar abierto un carpeta o algun programa el sistema se paraliza y windows me obliga a reiniciar el explorer .Esto me pasaba hace tiempo cuando tenia  512 de RAM, luego aumente a 2,5 GB y dejo de pasar este problema solo tenia problema con el COM Surrogate y no le tome importancia.

    El informe de problemas de Windows me decia que el problema era por algunos codecs del Nero 7 que tenia instalado, lo desinstale(bueno lo intente) y no se dejo ,elimine todos los archivos de C:\Archivos de  programa y trate de desinstalarlo varias veces por Panel de Control>agregar o quitar porgramas y todavia estaba ese programa con el indicador de lo que ocupa en disco, la verdad no entiendo. Tendra esto que ver con el problema de Windows Explorer??? Bueno eso es todo y gracias.

     

    Saludos

    viernes, 11 de julio de 2008 5:18

Respuestas

  •  Cesar_msdn Escribió:

    Buenas noches, tengo un problema con el windows explorer ya que despues de cierto tiempo de habar abierto un carpeta o algun programa el sistema se paraliza y windows me obliga a reiniciar el explorer .Esto me pasaba hace tiempo cuando tenia  512 de RAM, luego aumente a 2,5 GB y dejo de pasar este problema solo tenia problema con el COM Surrogate y no le tome importancia.

     

    Los fallos del explorer son en un 90% fallos de codecs (que hace gancho todos al explorador y alguno falla), y los fallos en COM Surrogate son 100% fallos de los codecs, por lo que tu caso está clarisimo.

     

    No vale conm eliminar en Archivos de programa en Nero, ya que deja muchos .ax en Common Files. (dentro tambien de archivos dep rograma) y alguno propio tambien en \windows\system32 por lo que siempre te quedarán restos.

     

    Hay una herramienta de desistalacion de Nero completo en la propia web de Nero y es la que que habria que haber ejecutado. En cualquier caso, no solo los codecs de Nero lo producen, ya que si has instalado el klipte, pasa lo mismo, etc...

     

    En general no hay que instala codecs en windows... solo un de mpeg4 (en DivX por ejemplo, ya que verá todos los MPEG4 -DivX, Xvid, etc..) uno de MPEG-2 (solo si no tenemo o Premium o Ultimate ya que sino no hace falta), y uno de AC3, por ejemplo el http://ac3filter.net  Con esto ya se ven al 99.9% de los videos. Si hace falta algo para alguno mas en particular, NUNCA instalar codeccs y usar herramientan para ver dicho video como el VLC http://www.videolan.org el cual no instala codecs en el sistema y es capaz de ver cualquier cosa de video... la que sea.

     

    Por desgracia los instaladores de los codecs los registran siempre y con gancho al explorador: el desistalarlos no vale para nada ya que nunca des-registran todos al menos  nivel de la shell, y el usar herramienta como Gspot para des-registrar, es posible, pero debe hacerlo un tecnico ya que puede estropear toda la multimedia.

     

    Espero que al menos te sirve para la siguiente instalacion ya que la actual no tendrá solucion a estas alturas. Lo de aumentar la memoria, si tenias 512, no ha venido mal a la maquina... pero la ausencia de memoria nunca provoca casques de un programa, solo lentitud en él, por lo que la solucion de aumentar no es nunca una solucion válida para un problema.

     

    Un saludo,

    viernes, 11 de julio de 2008 8:35

Todas las respuestas

  •  Cesar_msdn Escribió:

    Buenas noches, tengo un problema con el windows explorer ya que despues de cierto tiempo de habar abierto un carpeta o algun programa el sistema se paraliza y windows me obliga a reiniciar el explorer .Esto me pasaba hace tiempo cuando tenia  512 de RAM, luego aumente a 2,5 GB y dejo de pasar este problema solo tenia problema con el COM Surrogate y no le tome importancia.

     

    Los fallos del explorer son en un 90% fallos de codecs (que hace gancho todos al explorador y alguno falla), y los fallos en COM Surrogate son 100% fallos de los codecs, por lo que tu caso está clarisimo.

     

    No vale conm eliminar en Archivos de programa en Nero, ya que deja muchos .ax en Common Files. (dentro tambien de archivos dep rograma) y alguno propio tambien en \windows\system32 por lo que siempre te quedarán restos.

     

    Hay una herramienta de desistalacion de Nero completo en la propia web de Nero y es la que que habria que haber ejecutado. En cualquier caso, no solo los codecs de Nero lo producen, ya que si has instalado el klipte, pasa lo mismo, etc...

     

    En general no hay que instala codecs en windows... solo un de mpeg4 (en DivX por ejemplo, ya que verá todos los MPEG4 -DivX, Xvid, etc..) uno de MPEG-2 (solo si no tenemo o Premium o Ultimate ya que sino no hace falta), y uno de AC3, por ejemplo el http://ac3filter.net  Con esto ya se ven al 99.9% de los videos. Si hace falta algo para alguno mas en particular, NUNCA instalar codeccs y usar herramientan para ver dicho video como el VLC http://www.videolan.org el cual no instala codecs en el sistema y es capaz de ver cualquier cosa de video... la que sea.

     

    Por desgracia los instaladores de los codecs los registran siempre y con gancho al explorador: el desistalarlos no vale para nada ya que nunca des-registran todos al menos  nivel de la shell, y el usar herramienta como Gspot para des-registrar, es posible, pero debe hacerlo un tecnico ya que puede estropear toda la multimedia.

     

    Espero que al menos te sirve para la siguiente instalacion ya que la actual no tendrá solucion a estas alturas. Lo de aumentar la memoria, si tenias 512, no ha venido mal a la maquina... pero la ausencia de memoria nunca provoca casques de un programa, solo lentitud en él, por lo que la solucion de aumentar no es nunca una solucion válida para un problema.

     

    Un saludo,

    viernes, 11 de julio de 2008 8:35
  •  

    Hola Jose Manuel leio con atencion tu post y me gustria saber entonces como hago para eliminar esos ax del Nero que tu dices,los busco manualmente en common files y en system32  y los elimino o instalo la ultima version de Nero? Cn respecto al klipte no conozco ese programa y que yo sepa no lo tengo instalado.

     

    Con respecto a los otros programas tengo el AC Filter y el DivX intsalado y no he presentado problemas con ellos y si dices que el GSpot lo tiene que usar un tecnico ni siquiera voy a molestrame en mirarlo. Bueno Gracias por tus consejos y espero tu rspuesta.

     

    Un saludo

     

    Cesar.

    sábado, 12 de julio de 2008 16:00
  • Hola, César:

     

    Los codecs a los que se refiere José Manuel están en la carpeta C:\Archivos de programa\Archivos comunes\Ahead\DSFilter\ y se denominan NeVideo.ax y NeroVideoProc.ax. Con cambiarles de nombre basta. Supongo que las versiones más recientes de Nero ya no producen ese problema, pero no puedo confirmártelo porque no uso Nero.

    sábado, 12 de julio de 2008 16:13
  •  

    en principio desinstalando nero y tooodos sus componentes se eliminarian esos codecs, desinstala nero y bajate una aplicacion q hay en su pagina (sino la encuentras dilo y te la busco x otro sitio) q limpia todo rastro de nero..no instales otra version encima de la q tienes q te va a seguir pasando!

     

    los codecs, los q tienes son los correctos, con el Ac3 y el DivX vas sobradisimo y ademas son los unicos q hacen falta de verdad en windows vista....

     

    el GSpot, yo te recomiendo q te lo bajes, no para utilizarlo como a dicho jose manuel, pero es una herramienta muy util, sobre todo cuando tengas algun video q no sepas q codec necesitas para reproducirlo, GSpot te lo dice y para esto q te digo no te hace falta ser un entendido en informatica!

     

    P.D. jose manuel se va de vacaciones esta noche creo, asiq si responde ahora, preguntale todo lo q puedas antes de q se valla!!

     

    Saludos!!

    sábado, 12 de julio de 2008 16:18
  • OK gracias por el aviso, voy a buscar la herramieneta sino la pregunto por aqui.Para JOse Manuel Felices Vacas!!!!

    sábado, 12 de julio de 2008 16:26
  • Hola elss escribo para contartles que todavia tengo el problema de windows explorer, cuando quiero abrir una caroeta la ventana se torna blanc y me sale el aviso de que "windows explorer ha dejado de funcionar", la verdad esto me tiene de muy mal humor y no se q hacer, ya consegui el programa de la pag de nero y borre ("pienso yo") todos los componentes de Nero y no entiendo por que sigo con el problemita este, somo haria para verificar si se eliminaron todos esos . ax o donde los busco para cambiarles de direccion.Gracias y saludos.

    domingo, 20 de julio de 2008 5:08
  • Hola de nuevo, se me olvido esto es lo que me arroja el Informe de Problemas de Windows

    Producto

    Explorador de Windows

    Problema

    Dejó de funcionar

    Fecha

    27/03/2008 11:45 p.m.

    Estado

    Informe enviado

    Firma del problema

    Nombre de evento de problema: BEX

    Nombre de la aplicación: Explorer.EXE

    Versión de la aplicación: 6.0.6000.16549

    Marca de tiempo de la aplicación: 46d230c5

    Nombre del módulo con errores: MSVCR80.dll

    Versión del módulo con errores: 8.0.50727.762

    Marca de tiempo del módulo con errores: 45712238

    Desplazamiento de excepción: 00008a8c

    Código de excepción: c000000d

    Datos de excepción: 00000000

    Versión del sistema operativo: 6.0.6000.2.0.0.768.2

    Id. de configuración regional: 8202

    Información adicional 1: ef02

    Información adicional 2: 998c066c2cbf219abcac915f4bb51b81

    Información adicional 3: 5e4a

    Información adicional 4: f468a7c512bc517ad997e9f631474f07

    Información adicional sobre el problema

    Id. de depósito: 87734328

    Un saludo
    domingo, 20 de julio de 2008 5:09
  •  

    el msvcr80.dll es un process asociado a Microsoft Visual Studio 2005 de Microsoft Corporation. es el Microsoft C Runtime Library y es utilizado por los programas escritos con Microsoft Visual Studio 2005

     

    Causa

    Se produce este problema HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\ PendingFileRenameOperations La subclave de registro está configurada para eliminar la biblioteca Msvcr80.dll. Esta subclave de Registro está configurada al desinstalar Visual Studio 2005. La biblioteca Msvcr80.dll se encuentra en la carpeta %windir%\WinSXS. La biblioteca Msvcr80.dll se elimina cuando reinicia el equipo.
     

    Solución

    Información de revisión

    Ahora hay disponible un hotfix para el que Microsoft proporciona soporte técnico, pero que sólo se diseñó para corregir el problema descrito en este artículo Aplíquelo sólo a sistemas que experimenten este problema específico Este hotfix puede ser sometido a comprobaciones adicionales Por tanto, si no se ve gravemente afectado por este problema, nosotros recomendamos que espere al Service Pack siguiente de Visual Studio 2005 que contiene este hotfix.

    Para resolver este problema inmediatamente, póngase en contacto con Servicios de soporte técnico de Microsoft con el fin de obtener la revisión. Para una lista completa de números de teléfono de Servicios de soporte técnico de Microsoft e información acerca de costos de soporte técnico, visite el sitio Web de Microsoft siguiente:
    http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
    Nota En casos especiales, los cargos normalmente contraídos por llamadas de soporte técnico se pueden cancelar si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá su problema. Los costos habituales de soporte técnico se aplicarán a preguntas de soporte técnico y problemas que no cumplen la actualización específica en cuestión.

    Requisitos previo

    Para aplicar esta revisión, debe tener instalado Visual Studio 2005 en el equipo.

    Reinicie requisito

    No tiene que reiniciar el equipo después de aplicar este hotfix.

    Información de reemplazo de revisión

    Este hotfix no sustituye a otros hotfix

    Información de archivo

    La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla Las fechas y los tiempos para estos archivos aparecen en hora universal coordinada. La información de los archivos se convertirá a la hora local cuando la vea Para ver la diferencia entre hora UTC y hora local, utilice la ficha Zona horaria en el elemento Fecha y hora de Panel de control.
     
    esto es lo q e encontrado....pero aun asi, el nero es muy problematico y aun con la herramienta de nero,puede haber quedado algun codec por ahi q este dando problemas..mi consejo es q si puedes,formatees el equipo y empieces desde cero, sin instalar nero claro!
     
    te dejo la pagina donde e sacado la info x si te es de ayuda!:
     
    Saludos!
    domingo, 20 de julio de 2008 11:29
  • La excepción que ha ocurrido es STATUS_INVALID_PARAMETER. Seguramente alguna extensión de shell que hayas instalado, codec, o similar es el causante del problema.

     

    Mi impresión personal es que un codec instalado por Nero ha pasado algún parámetro incorrecto al explorador y de ahí que deje de funcionar. ¿Has renombrado los codecs que te indico en mi mensaje anterior? Sin echar un vistazo a un mini-volcado de memoria usando ADPlus (http://support.microsoft.com/kb/286350/es), poco más te puedo decir.

    domingo, 20 de julio de 2008 13:51
  • Buenas, gracias por sus consejos, ese hotfix que necesito me parece que es la solucion pero el amigo molpii lo pinto como algomuy grave ya que me dijo que formateara el equipo pero en el peor de los casos los hare.

     

    Tambien utilizare el ADPlus para hacer el volcado de memoria pero esa herramienta tambien me parece algo complicada, pero antes una pegunta, la utilizacion de esa herramienta no me causara mas problemas de los que ya tengo??? Dame tu opinion personal.}

     

    Con repecto a los codecs de Nero, donde los encuentro? He revisado C:\Archivos de Programa y no hay rastro de aguna carpeta del Nero, sera alguna entrada del registro que tengo que cambiar.Otra cosa eso no se me solucionaria instalando el SP1?

     

    Ese es otro problema que lo plantee antes por aqui con Jose Manuel y bueno el WU no me deja bajar una actualizacion importante previa para el SP1 y el me recomendo instalar la version individual y no por el WU, esa que pesa como 500MB.Bueno eso es todo y gracias por el soporte .Espero sus respuestas, Por cierto ya vino Jose Manuel de vacaciones???

     

    Un Saludo,

     

    Cesar Noriega

     

     

    domingo, 20 de julio de 2008 15:28
  • Como ya te indiqué, los codecs de Nero suelen estar en la carpeta C:\Archivos de programa\Archivos comunes\Ahead\DSFilter\ y se denominan NeVideo.ax y NeroVideoProc.ax. Con cambiarles de nombre basta. Supongo que las versiones más recientes de Nero ya no producen ese problema, pero no puedo confirmártelo porque no uso Nero.
    domingo, 20 de julio de 2008 21:59
  • El directorio \Ahead\DSFilter no existe en mi disco, debe haber sido borrado por la herramienta de Nero.Entonces que otra cosa podria hacer al respecto???

    martes, 22 de julio de 2008 3:48
  • Hay alguna otra cosa que podria hcer para reparar este problema, no ocurre siempre pero existe.Gracias y saludos.

    sábado, 26 de julio de 2008 5:06
  • sq tu problema esq tienes un codec invalido y al no saber su ubucacion pues....

     

    q yo sepa no hay ningun programa q te cree una lista de todos los codecs almacenados en tu ordenador y te diga cuales son los validos y cuales no, aver si alguien lo sabe y te puede ayudar!!

     

    ami esq lo unico q se me ocurre es eso, formatear (yo hice eso la primera vez, la segunda vez, con desinstalar nero me sobro), asi lo solucionas seguro, pero comprendo q *** antes de formatear, se puede intentar hacer algo y formatear como ultima medida, mas q nada xq yo estaba = q tu! por la cantidad de cosas q tenia...

     

    de todas maneras, dices q esto te pasa solo devezencuando no??

     

    esperate al lunes q es el dia q vuelve JMT (creo q es ese dia) y espera aver  q te dice!

     

    aguantas hasta entonces??

     

    Saludos!

     

     

     

    sábado, 26 de julio de 2008 11:09
  • Como  no molpii esperare a que llegue Jose Manuel ,bueno Gracias por la paciencia y un saludo!!
    domingo, 27 de julio de 2008 0:30
  • jaja nada! en su grupo de noticias jose manuel dice q "hasta el 27" pero supongo q si viene hoy se tomara el dia de descanso para desacer las maletas etc etc..vamos lo q es la vuelta a casa despues de vacaciones! supongo q con algo de suerte esta noche quizas este x aqui y sino mañana!!

     

    Saludos!

     

    domingo, 27 de julio de 2008 10:05
  •  Cesar_msdn Escribió:
    Como  no molpii esperare a que llegue Jose Manuel ,bueno Gracias por la paciencia y un saludo!!

    Te estas centrando mucho en los codecs de Nero... pero ¿que mas paquetes de codecs has instalado?

    Un saludo,
    domingo, 27 de julio de 2008 14:24