none
Consejos para montar infraestructura con mi nuevo y pequeño servidor HP ProLiant MicroServer Gen8 RRS feed

  • Pregunta

  • Buenas chicos!

    Recientemente he adquirido este pequeño y versátil servidor. Quiero sustituirlo por mi antigua NAS de Synology, instalando un Windows Server 2012 R2 (Core o GUI) con el rol de servidor de ficheros.

    Soy usuario de Microsoft y trato de tirar de esa tecnología a no se que interfiera el dinero o funcionalidades, por eso he tenido que instalar VMWare ESXi 6.0 para poder virtualizar un 3 o 4 máquinas. Mi intención es montar un servidor de archivos, un servidor dns, dhcp y firewall.

    Actualmente tengo instalado OpenVPN con el rol de DNS y DHCP. Me gustaría poder sustituirlo por un entorno Microsoft quitando el firewall ya si no me equivoco, no existe ningún software gratuito que haga la misma función.

    Lo que más prisa me corre, es migrar el Synology a Microsoft. Voy a utilizar dos discos de 2Tb pero sin RAID 1, en el primero disco lo usaré para "producción" y el segundo disco para "backup"

    Me gustaría saber como implementar una especie de sistema de HA para este servidor de ficheros. Había pensado en algo muy cutre, que es un servicio corriendo como RSYNC para sincronizar en tiempo real. A parte, reararé backup de forma externa. Con esto me aseguro que si falla un disco, tengo la otra máquina funcional. Quisiera evitar tener que montar un dominio ya que tengo pocas máquinas en casa.

    Espero vuestros consejos.

    Muchísimas gracias!

    Un saludo!


    martes, 20 de junio de 2017 10:27

Todas las respuestas

  • Hola, Antonio Rosado:

    Hay un detalle que considero importante aclarar, compañero: la máquina que señalas NO es un servidor en el sentido completo de la palabra, sino que se trata de un híbrido entre un servidor y un NAS que podría ser usado principalmente como servidor de ficheros (o "almacén digital") en entornos que no tengan demasiadas transacciones de datagramas.

    Por precio y prestaciones, es una buena opción para utilizar en entornos corporativos pequeños (menos de 30 clientes) pero no le pidas que tenga o haga las prestaciones de un servidor de verdad.. porque te llevarías muchas sorpresas desagradables. Quizá como host físico de varios servidores virtuales sería una buena opción.. en un entorno casero!; Lo que se traduce a que en un entorno corporativo, no te recomiendo alojes servicios críticos.

    Por ponerte un ejemplo sencillo, HA exige disponer de al menos, 2 dispositivos conectados a diferentes fuentes de alimentación y sus correspondientes SAI. Por supuesto, cada una corriendo ESXi (O Hyper-V server) y con 2-3 máquinas virtuales MS w2k16 R2 (o incluso MS w2k12 R2) repartiendo los roles entre ellas. Para el caso que nos ocupa, diría que la "pasta" de verdad te la gastarías en los SO's, por lo que para no arruinarte y si quisieras ampliar el servicio a más saltos, te recomiendo recurras también al servicio Azure SR, que además de ser más económico te permitiría seguir haciendo pruebas de configuración desde cualquier punto del globo.. y sincronizarlo con la maquinita de marras.

    Ahora bien, como explicarte cómo montar todo éste chiringuito no es rápido ni se hace en un único post, te sugiero mires cualquiera de los miles de manuales sobre montaje de redes que existen en el "Interné" y consultes dudas concretas sobre puntos en que te atasques, compañero.
    Para HA, te recomiendo además tengas en cuenta el mencionado Azure SR, que te podrá "caxondo".

    Más info:
    · Diseñar la Red: https://technet.microsoft.com/es-es/library/dd568932.aspx
    · Site Recovery Documentation: https://docs.microsoft.com/en-us/azure/site-recovery/
    · Azure SR: https://azure.microsoft.com/en-us/services/site-recovery/?v=17.23h

    Desiderio Ondo || Engineer

    • Marcado como respuesta Antonio Rosado jueves, 22 de junio de 2017 7:18
    • Desmarcado como respuesta Antonio Rosado lunes, 24 de julio de 2017 11:44
    miércoles, 21 de junio de 2017 11:49
  • Buenas Desiderio!

    Efectivamente, esto va a ser para casa ni se me pasa por la cabeza ponerlo en un entorno de producción :P De momento me quedo con un host por tema de presupuesto, pero quizás algún día me gustaría poner otro más.

    ¿Azure SR? mmm, voy a echar un vistazo a ver que es, porque no lo conozco. Recuerda, es para entorno domestico.

    Entiendo, cuando escribí el post me di cuenta de que sería complicado aconsejarme. Voy a empezar a montarlo como lo tengo en mente y os iré preguntando detalles.

    Lo primero que voy hacer es montar el servidor de ficheros y la VPN. En cuanto tenga esto, os lo comento.

    Trataré escribir todas las dudas en este post.

    Gracias por la info!

    Gracias compi!

    miércoles, 21 de junio de 2017 12:25
  • Estaremos encantados de ayudarte, compi..
    Mientras tanto, sería de gran ayuda que marcaras la respuesta como válida. Eso me "pone"..

    Desiderio Ondo || Engineer

    miércoles, 21 de junio de 2017 13:58
  • Buenas!

    Ya estoy de nuevo por aquí. Parece que se me está resistiendo el jubilar mi antiguo Synology y dar paso a un Windows Server 2012 R2.

    He adquirido recientemente un nuevo procesador de 4 hilos para así aumentar la capacidad de procesamiento y también he añadido un módulo de 8Gb para disponer de un total de 12Gb.

    Finalmente he decido montar la VPN directamente en un router y en VMWare montar el servidor de archivos y mi PC físico convertido a virtual haciendo passthrough de la tarjeta gráfica. Ya os contaré con detalle.

    El caso es que estoy teniendo problemas de rendimiento a la hora de copiar ficheros al Windows Server 2012 R2, tanto core como GUI.

    En un principio había leído que podía ser problema del VMWare por un problema con el driver de la controladora RAID, pero he descartado ese problema poniéndolo en modo AHCI. En un principio iba a poner RAID 1 por hardware que tiene integrado pero debido a las pruebas realizadas posteriormente y comprobando que el RAID por software (Windows) no reduce el rendimiento, he decidido eliminar el RAID por hard.

    Os detallo las pruebas que he realizado:

    - Instalé el VMWare ESXi 6.0.0 Update 2 de HP en modo RAID 1. Después instalé un Windows Server 2012 R2 como servidor de ficheros. Realice un test de velocidad que no llegaba ni a los 40 Mb/s y actualmente tengo el NAS Synology que esta en unos 50 Mb/s aprox.

    - Como he comentado, leí que había problemas con el RAID por lo que decido dejarlo en modo AHCI e instalar nativamente el Windows Server 2012 R2. Al realizar las pruebas de rendimiento, las cosas cambiaron:

    La copia era estable en unos 112MB/s.

    - Decidí de nuevo instalar el VMWawre ESXi y porteriormente instalar el Windows Server 2012 R2. Al realizar las pruebas, de nuevo la sorpresa.

    Después de unos segundos, el rendimiento bajaba bruscamente y ya no se levantaba. He leído algo que podía ser de la cache dinámica, pero lo que no entiendo si instalado nativamente va bien, como aquí no. También de forma nativa esta con 12 Gb pero me parece una barbaridad para un servidor de archivos. También el tiempo que se quedó estable aumento al ampliar de 2 Gb a 4 Gb.

    No me gustaría abandonar el servidor de archivos con Windows por no conseguir el rendimiento que quiero.

    Espero que me puedan ayudar a solucionar el problema.

    Muchas gracias por todo.

    Un saludo!

    lunes, 24 de julio de 2017 11:22
  • Buenas,

    Novedades:

    He descubierto que si no instalo las VMWare Tools la copia es estable en 113 MB/s. He probado algunas soluciones sin éxito.

    netsh int tcp set global chimney=Disabled
    netsh int tcp set global autotuninglevel=Disabled
    netsh int tcp set supplemental custom congestionprovider=none
    netsh int tcp set global ecncapability=Disabled
    netsh int ip set global taskoffload=disabled
    netsh int tcp set global timestamps=Disabled

    ¿Ideas?

    Un saludo!

    miércoles, 26 de julio de 2017 12:48
  • Antonio, si el problema sucede cuando lo instalas como virtual en VMware, y además confirmas que se produce luego de instalar las VMware Tools, entonces decididamente debes recurrir a un foro de soporte de VMware porque no es problema de Windows Server

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    miércoles, 26 de julio de 2017 13:56
    Moderador
  • He estado el fin de semana realizando pruebas de rendimiento.

    Para descartar un problema real en VMware, he instalado Hyper-V y creadas 3 máquinas virtuales:

    - Windows Server 2012 r2
    - Windows Server 2008 R2
    - Windows 7 SP1

    Las 3 máquinas tenían 1 CPU, 2 RAM y 30 HD. Para las pruebas de copia he cogido un fichero ISO de 6.5 Gb.

    Primero he copiado la ISO de mi máquina de escritorio física (Windows 10) al host, en este caso Hyper-V. La copia ha sido estable en 113 MB/s.

    La segunda prueba fue copiar desde el host Hyper-V (Windows Server 2012 R2) a las máquinas virtuales.

    - Windows Server 2012 R2: La copia ha sido inestable de 20 a 50 Mb/s aprox. ???
    - Windows Server 2008 R2: Copia estable 70 aprox. ¿Por qué esta velocidad?
    - Windows 7: Copia estable 70 Aprox. ¿Por qué esta velocidad?

    Nota: No he conseguido solucionar la inestabilidad de Windows Server 2012 R2

    Tercera prueba. Copiar de mi máquina, Windows 10 a las virtuales. Sorpresa! El rendimiento fue de 5-10 Mb/s. Buscando, di con un foro perdido que hablaba de deshabilitar un parámetro en el adaptador del host Hyper-V llamado VMQ (Virtual Machine Queues). Después de esto la copia es estable en 107 Mb/s, que no llega a los 113Mb/s pero me puedo conformar.

    En cuanto al VMWare, confirmo que he probado bastantes versiones, tanto antiguas como modernas por lo que creo que el problema debe de estar en el Windows. He visto que cambiando los parámetros mencionados más arriba en otro post, a mucha gente se le soluciona, pero no es mi caso.

    He notado que la máquina virtual se queda "tostada" a nivel de red, como si se saturara. He leído también que desactivando el SMB 3 se soluciona, ¿Alguna idea?

    Voy a probar dos cosas, añadir una segunda tarjeta de red e instalar un Linux y realizar las pruebas.

    Espero vuestra ayuda!

    Muchas gracias!

    lunes, 31 de julio de 2017 7:19
  • Buenas!

    Tengo novedades, he instalado de nuevo el ESXi y realizado unas modificaciones y ya tengo el rendimiento bueno. Pero tengo un matiz:

    Ahora tengo un Windows Server 2008 R2 con 4Gb de RAM. Cuando copio un fichero de más de su RAM, empieza a copiar a 113Mb/s cuando llega a la cantidad de la RAM , baja el rendimiento a 40 Megas aprox pero se mantiene estable.

    ¿Qué puede estar pasando?

    Muchas gracias!


    • Editado Antonio Rosado jueves, 3 de agosto de 2017 11:50 Añadir imagen
    jueves, 3 de agosto de 2017 11:09
  • Buenas,

    He seguido los pasos de este hilo https://social.technet.microsoft.com/Forums/en-US/7bd0aa5b-eb95-40a8-a56d-c6013273665c/extremely-slow-smb-network-speed-server-2012-r2?forum=winserver8gen 

    Under the advanced tab, offloading features that needed to be disabled: 

     Ipv4 checksum offload

     largesend offload V2(ipv4)

     largesend offload V2(ipv6)

     TCP Checksum offload (ipv4)

     TCP checksum offload (ipv6)

     Udp checksum offload (ipv4)

     Udp checksum offload (ipv6)

    Ha mejorado algo el rendimiento:

    ¿Se puede mejorar más?

    Muchas gracias! 

    lunes, 7 de agosto de 2017 12:34