locked
Configuración red XP Mode en Windows7 RRS feed

  • Pregunta

  • Hola:

    He instalado el virtual XP Mode en Windows 7 y quiero emplearlo para los programas P2P, al instalar el eMule no consigo que conecte, he leido un post antiguo de este foro con un tema parecido, donde respondeis esto:

    "Asumiendo que tienes un router ADSL, lo normal es tener la red de la maquina virtual en modo bridge (puente) en vez de en NAT que es el valor por defecto. Por tanto pon en laconfiguracion de la maquina virtual el que la red esté apuntando a tu tarjeta fisica de red en vez de modo NAT."

    En mi caso, en la configuración del XP Mode en Tarjeta de red tiene 4 opciones: Sin conectar - Red interna - Red compartida (NAT) -Nic de Fast Ethernet de la familia Realtek RTL8139/810x y por defecto esta "Red compartida (NAT)
    pero no conecta.

    En el router Zixel P660 tengo los puertos abiertos y en el Firewll de Windows (no empleo otro) tambien, en la maquina real funciona bien y con ID alta en cuanto lo paso a la virtual, no conecta.

    ¿que tengo mal?  ..... Saludos

    viernes, 26 de marzo de 2010 0:14

Respuestas

  • Para esa configuración, debes ir a las configuraciones de tu máquina virtual, y darle en Red, luego donde dice Adaptador 1, lo cambias de NAT al modelo de tu tarjeta de red, normalmente es el último o dos últimos.
    Sergio Calderón
    Equipo SWAT Microsoft - Windows Client
    Microsoft Student Partner
    viernes, 26 de marzo de 2010 16:26
  • Me diste el 50% de la solución, como tu indicas se tiene que ir a la configuración de la máquina virtual y en red cambiar la configuración de NAT al modelo de la tarjeta de red  instalada (modo bridge)

    Al hacer esto el router crea una IP fija en la máquina virtual, con esta IP se tienen que abrir los puertos P2P en el router y todo solucionado.

    Saludos

    sábado, 27 de marzo de 2010 10:56
  • Me diste el 50% de la solución, como tu indicas se tiene que ir a la configuración de la máquina virtual y en red cambiar la configuración de NAT al modelo de la tarjeta de red  instalada (modo bridge)

    Al hacer esto el router crea una IP fija en la máquina virtual, con esta IP se tienen que abrir los puertos P2P en el router y todo solucionado.

    Saludos

    La IP que te dal el router no es fija... sería conveniente que la "fijases" poniendo los mismo valores (en IP, puerta de enlace y DNS's) que en la actualidad te da el router.

    En tcp/ip cuando una maquina solicita una IP a un servidor DHCP (el router actua como tal) se presta un IP durante un maximo de tiempo establecido, el cual puede verse tambien con el comando:

    ipconfig /all

    A la mitad de ese tiempo se pide renovacion por el cliente... y se pregunta a la maquina DHCP si le puede dar la misma. Si el server DHCP la tiene todavia libre, le dará la misma. Pero no hay garantia de que sea así despues de pasado el tiempo de prestamo ya que le ha podido dar a otroa maquina (virtual o real...)

     

    Mi consejo en estos casos es que si el router asigna direcciones, por ejemplo, desde la 192.168.1.33 en adelante, le demos a la maquina una IP alta, por ejemplo 192.168.1.200 y sea esta con la que abrimos los puertos en el NAT o Virtual Server del router.

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    lunes, 29 de marzo de 2010 13:27

Todas las respuestas

  • Hola,

    En ninguna conexión te conecta?
    La verdad sería poco lo que podríamos ayudarte ya que el objetivo es tratar problemas con el producto relacionado, y en este caso es algo muy propio del producto eMule, podrías tratar de dejarlo por la NAT y ejecutarlo desde el 7.


    Sergio Calderón
    Equipo SWAT Microsoft - Windows Client
    Microsoft Student Partner
    viernes, 26 de marzo de 2010 2:16
  • Gracias por contestar, el producto eMule funciona en Windows7 con ID alta y es portable ,como lo paso tal cual a la maquina virtual (XP Mode) descarto que sea un problema de el.

    El eMule al intentar conectar con un servidor  pone: Your ip (81.32.171.0) ends with a 0. The edonkey protocol assigns a LOWID to you. It's OK, dont panic !
    26/03/2010 9:44:39: LowID -- Trying Again (attempts 2)

    Creo que el problema es de configuracion de la red virtual y se parace mucho a lo que dice este post : http://social.technet.microsoft.com/Forums/es-ES/windows7es/thread/d01b1e80-6759-4a0a-84b9-628fe0ae5e26

    Pero no se como se hace esto: "pon en la configuracion de la maquina virtual el que la red esté apuntando a tu tarjeta fisica de red en vez de modo NAT." y desconozco  si ademas ya que tocar algo en el router.

    Saludos

    viernes, 26 de marzo de 2010 8:59
  • Para esa configuración, debes ir a las configuraciones de tu máquina virtual, y darle en Red, luego donde dice Adaptador 1, lo cambias de NAT al modelo de tu tarjeta de red, normalmente es el último o dos últimos.
    Sergio Calderón
    Equipo SWAT Microsoft - Windows Client
    Microsoft Student Partner
    viernes, 26 de marzo de 2010 16:26
  • Me diste el 50% de la solución, como tu indicas se tiene que ir a la configuración de la máquina virtual y en red cambiar la configuración de NAT al modelo de la tarjeta de red  instalada (modo bridge)

    Al hacer esto el router crea una IP fija en la máquina virtual, con esta IP se tienen que abrir los puertos P2P en el router y todo solucionado.

    Saludos

    sábado, 27 de marzo de 2010 10:56
  • Me alegra que se te haya solucionado, gracias por confirmarlo!

    Saludos,


    Sergio Calderón
    Equipo SWAT Microsoft - Windows Client
    Microsoft Student Partner
    sábado, 27 de marzo de 2010 12:37
  • Me diste el 50% de la solución, como tu indicas se tiene que ir a la configuración de la máquina virtual y en red cambiar la configuración de NAT al modelo de la tarjeta de red  instalada (modo bridge)

    Al hacer esto el router crea una IP fija en la máquina virtual, con esta IP se tienen que abrir los puertos P2P en el router y todo solucionado.

    Saludos

    La IP que te dal el router no es fija... sería conveniente que la "fijases" poniendo los mismo valores (en IP, puerta de enlace y DNS's) que en la actualidad te da el router.

    En tcp/ip cuando una maquina solicita una IP a un servidor DHCP (el router actua como tal) se presta un IP durante un maximo de tiempo establecido, el cual puede verse tambien con el comando:

    ipconfig /all

    A la mitad de ese tiempo se pide renovacion por el cliente... y se pregunta a la maquina DHCP si le puede dar la misma. Si el server DHCP la tiene todavia libre, le dará la misma. Pero no hay garantia de que sea así despues de pasado el tiempo de prestamo ya que le ha podido dar a otroa maquina (virtual o real...)

     

    Mi consejo en estos casos es que si el router asigna direcciones, por ejemplo, desde la 192.168.1.33 en adelante, le demos a la maquina una IP alta, por ejemplo 192.168.1.200 y sea esta con la que abrimos los puertos en el NAT o Virtual Server del router.

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    lunes, 29 de marzo de 2010 13:27
  • Me diste el 50% de la solución, como tu indicas se tiene que ir a la configuración de la máquina virtual y en red cambiar la configuración de NAT al modelo de la tarjeta de red  instalada (modo bridge)

    Al hacer esto el router crea una IP fija en la máquina virtual, con esta IP se tienen que abrir los puertos P2P en el router y todo solucionado.

    Saludos

    La IP que te dal el router no es fija... sería conveniente que la "fijases" poniendo los mismo valores (en IP, puerta de enlace y DNS's) que en la actualidad te da el router.

    En tcp/ip cuando una maquina solicita una IP a un servidor DHCP (el router actua como tal) se presta un IP durante un maximo de tiempo establecido, el cual puede verse tambien con el comando:

    ipconfig /all

    A la mitad de ese tiempo se pide renovacion por el cliente... y se pregunta a la maquina DHCP si le puede dar la misma. Si el server DHCP la tiene todavia libre, le dará la misma. Pero no hay garantia de que sea así despues de pasado el tiempo de prestamo ya que le ha podido dar a otroa maquina (virtual o real...)

     

    Mi consejo en estos casos es que si el router asigna direcciones, por ejemplo, desde la 192.168.1.33 en adelante, le demos a la maquina una IP alta, por ejemplo 192.168.1.200 y sea esta con la que abrimos los puertos en el NAT o Virtual Server del router.

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    lunes, 29 de marzo de 2010 13:27
  • Hola Jose Manuel , gracias por la aclaración el router me dio  192.168.1.33 y ya le he  asignado una IP alta.

    Saludos

    viernes, 2 de abril de 2010 8:37
  • Hola Jose Manuel , gracias por la aclaración el router me dio  192.168.1.33 y ya le he  asignado una IP alta.

    Saludos

    ;-)

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    viernes, 2 de abril de 2010 8:47