none
Exchange abierto para enviar correo por telnet RRS feed

  • Pregunta

  • Buenas tardes,
    Estoy teniendo el siguiente problema. Tengo un Exchange Server2003 SP2 dentro de mi Organización. Funciona todo perfectamente.
    Hoy he descubierto lo siguiente. Haciendo un telnet desde fuera de la empresa a mi IP poública al puerto 25, responde mi Servidor Exchange (lo cual es correcto), pero al poner mail from:pepito@miempresa.com  (donde pepito es un nombre cualquiera inexistente dentro de mi organización y "miempresa" es el dominio de mi empresa) me dice Sender OK. Es decir, me toma el usuario pepito como un usuario válido y luego de eso me permite inclusive enviar un mail a cualquier lado. Es decir, que cualquier puede estar usando mi Servidor Exchange para enviar correos a mansalva.
    Yo necesito que mi Servidor de correo verifique si el usuario que están poniendo por telnet en Mail From es válido o no y no deje mandar mail a cualquier usuario que se ponga ahí. Me explico.?
    Yo ya hice pruebas de relay desde abuse.net y me da todo OK.
    Ya he verificado todo lo de este link y está todo correctamente configurado en mi Exchange:
    http://msmvps.com/blogs/exchangebloglatino/archive/2007/05/24/verificando-opciones-de-relay-en-exchange-2000-y-2003.aspx

    En fin, si alguien me puede ayudar le agradezco.
    Muchas gracias
    slds
    martes, 12 de mayo de 2009 20:40

Respuestas

Todas las respuestas

  • Hola,

    Verifica este documento

    How to block open SMTP relaying and clean up Exchange Server SMTP
    http://technet.microsoft.com/en-us/kb/kb00324958.aspx

    Gracias
    Andresl
    martes, 12 de mayo de 2009 20:46
  • Hola,

    El sender siempre puede ser cualquiera. El tema es cuando hacés el rcpt to:

    Esa dirección sí tiene que ser interna. Si es externa tiene que darte "unable to relay". Si no es así, recién ahí es un open relay.

    Slds.
    Pablo Vernocchi
    miércoles, 13 de mayo de 2009 3:14
    Moderador
  • Hol aPablo y andres,
    Gracias por sus respuestas.
    Una consulta sobre lo que decís vos Pablo. Es correcto entonces que en mail from siempre me de Sender OK así sea un usuario válido o no dentro o no de la empresa.?
    He hecho la prueba de mandar correo por telnet poniendo en rcpt to una casilla válida externa a la organización, por ejemplo de gmail. Y el correo lo manda correctamente. Por lo que tú dices en tu mail, estaría como un open relay ? He verificado minusiosamente, incluso en un blog tuyo Pablo el tema del relay, y el xchange lo tengo configurado correctamente.
    De esta manera sí cualquier persona puede estar usando mi Servidor para mandar correo, spam o lo que sea...
    Tengo el Exchange configurado como dice el siguiente blog:

    http://www.itpros.com.ar/blog/verificando-opciones-de-relay-en-exchange-2000-y-2003

    Alguna sugerencia.?
    Desde ya muchas gracias
    guillermo
    miércoles, 13 de mayo de 2009 13:05
  • Andrés,
    Ahora estoy siguiendo todas las instrucciones de tu link. Toda la parte que trata del exchange la tengo correcta, igual que le documento.
    Estoy ahora en la parte del ISA (yo tengo un ISA Server 2006 que publica al Servidor Exchange, al OWA, etc). Voy a ver de desactivar la regla de publicación del exchange y hacer el telnet a ver qué me da. Solo para detectar si el problema pasa por el ISA entonces..

    Slds
    miércoles, 13 de mayo de 2009 13:27
  • Hola,

    Es correcto que cualquiera sea el mail from. Siempre debe dar ok salvo que vos explícitamente digas que no queres recibir de esa dirección o dominio.

    Para saber si sos open relay, hacé el test: http://www.abuse.net/relay.html

    Slds.
    Pablo Vernocchi
    miércoles, 13 de mayo de 2009 14:10
    Moderador
  • ya lo había hecho Pablo.
    No hago relay.

    Resultado del abuse:

    Relay test result

    All tests performed, no relays accepted.

    slds
    miércoles, 13 de mayo de 2009 14:20
  • Entonces quedate tranquilo que no sos relay.
    Pablo Vernocchi
    miércoles, 13 de mayo de 2009 14:23
    Moderador
  • Estimados, Esto es realmente raro. Acabo de hacer las pruebas por telnet. Ahora al poner rcpt to una dirección externa a la Organización, me sale "unable to relay to ...." lo cual es correcto. No hago relay. Lo raro está en que no toqué nada, solo revisé cosas... En fin, no me voy a poner a investigar el por qué se arregló solo, pero bueno, al fin Murphy hizo una buena labor !! Muchas gracias a todos por la ayuda. Slds guillermo
    miércoles, 13 de mayo de 2009 14:28