none
Problemas de formato no legible en impresión con Easy Print (TS) en Windows 7 RRS feed

  • Pregunta

  • Recientemente empezamos a utilizar Easy Print de Terminal Server en un servidor Windows 2008 R2 en clientes Windows 7, al querer utilizar una impresora matriz de punto epson TM-U675, nos da el problema que no imprime correctamente, en un inicio pensé que podría ser la configuración de la impresora o los controladores pues inclusive hasta en la hoja de prueba las letras no salen nada legibles; el detalle es que localmente la impresora trabaja sin ningún problema, ya instale los controladores directo en el servidor y tampoco funciono.

    Adicionalmente, el mismo modelo estaba funcionando a la perfección pero con clientes Windows XP e Instale los últimos controladores, suministrados por EPSON en el cliente Windows 7.

    Agradecería mucho la ayuda al respecto.

    miércoles, 2 de julio de 2014 20:32

Respuestas

  • Hola Elkin,

    En la página del fabricante indica que los caracteres no se imprimen correctamente al utilizar Easy Print:

    https://download.epson-biz.com/epson/epson_public_document.php?name=apd_4.15E.txt

    Allí dice que debes aplicar el siguiente parche de Microsoft:

    http://support.microsoft.com/kb/946411

    Revisa lo anterior, y coméntanos si esto soluciona tus problemas.

    Salu2 desde Chile

    Franco Lopez A


    Salu2 desde Chile Franco Lopez A

    • Marcado como respuesta Uriel Almendra viernes, 4 de julio de 2014 19:54
    viernes, 4 de julio de 2014 19:04

Todas las respuestas

  • Hola Elkin,

    En la página del fabricante indica que los caracteres no se imprimen correctamente al utilizar Easy Print:

    https://download.epson-biz.com/epson/epson_public_document.php?name=apd_4.15E.txt

    Allí dice que debes aplicar el siguiente parche de Microsoft:

    http://support.microsoft.com/kb/946411

    Revisa lo anterior, y coméntanos si esto soluciona tus problemas.

    Salu2 desde Chile

    Franco Lopez A


    Salu2 desde Chile Franco Lopez A

    • Marcado como respuesta Uriel Almendra viernes, 4 de julio de 2014 19:54
    viernes, 4 de julio de 2014 19:04
  • Hola Franco,

    De antemano agradezco su respuesta, en este momento me dispongo a efectuar las pruebas pertinentes, le cometo mas adelante.


    Elkin Pinzon

    martes, 8 de julio de 2014 15:44
  • hola Franco,

    Le cuento lo efectuado en mención, 

    Descargué la revisión disponible que mencionas de http://support.microsoft.com/kb/946411/es, pero al instalarla me sale un mensaje "Ninguno de los productos a los que afecta la actualización de software está instalado en el equipo. Para salir de la instalación, haga clic en Cancelar", verificando, este es un parche que sirve para el  .NET Framework 3.0 service pack 1, al tratar de instalar el .NET Framework 3.0 service pack 1, me doy cuenta que el windows 7 ya trae el framework 3.5, verificando encuentro en http://support.microsoft.com/kb/977683/es, que esta actualizacion ya incluye los problemas solucionados en la revicion 94611.

    Te agradeceria cualquier otra sugerencia al respecto.


    Elkin Pinzon

    martes, 8 de julio de 2014 21:03
  • Hola Elkin,

    Por favor revisa lo más básico, que la cinta esté bien instalada, el tamaño de los caracteres de la impresora sea el adecuado, que el papel donde imprimas sea el apropiado, etc.

    Luego de lo anterior, los drivers de la impresora, están bien instalados en el servidor? Te consulto ya que mencionas algo acerca de los drivers pero solo para los clientes.

    Intenta realizar una impresión directamente desde el servidor desde un bloc de notas y revisa como salen los caracteres si tiene diferencias comparando con la impresión desde un equipo cliente (también desde un bloc de notas).

    Lo otro, la impresión la realizas desde una aplicación propia (desarrollada por ustedes) o es una aplicación Microsoft?

    En el vínculo del fabricante en el ítem 3 indica lo siguiente:

    En el entorno Easy Print de Windows Server 2008, no puedes imprimir las fuentes del dispositivo directamente. Sin embargo, puedes imprimir la fuente del dispositivo convertida de la fuente True Type mediante el uso de "Sustitución de Fuente" de APD. Para más información, revisa en el manual de la impresora "Character Printing (Device Font)".

    https://download.epson-biz.com/epson/epson_public_document.php?name=apd_4.15E.txt

    Revisa si corresponde a tu caso, y si puedes resolver tu problema.

    Avísanos como te va.


    Salu2 desde Chile Franco Lopez A


    martes, 8 de julio de 2014 23:33
  • Hola Franco,

    Estuve verificando cada uno de las sugerencias dadas:

    • Lo básico esta todo ok
    • Con respecto a los drivers en el servidor según tengo entendido, con la característica de impresión Easy Print, no es necesario instalar los drivers de las impresoras en los servidores TS. (no se si este equivocado).
    • Si ejecuto impresión desde un equipo local sale legible.
    • Adicional a lo anterior en las mismas condiciones la impresión desde un equipo cliente Win XP Sp3 y sale muy bien, (usando easy print de TS).
    • Con respecto a si usamos una aplicación propia, si señor así es, pero como te expreso anteriormente, en las mismas condiciones, pero con un win XP SP3 si sale la impresión con el formato legible.
    • Con respecto a convertir la fuente True Type mediante el uso de "Sustitución de Fuente" de APD", la verdad no entiendo el tema, te agradecería me orientaras al respecto.

    De antemano gracias por el tiempo dedicado al respecto, sigo atento a cualquier sugerencia adicional.

    ________________

    Elkin Pinzón


    Elkin Pinzon

    viernes, 11 de julio de 2014 20:53
  • He presentando el mismo problema aún no le he podido dar solución a pesar de Convertir la fuente True Type mediante el uso de "Sustitución de Fuente" de APD"  aplicada la impresora Epson  TM-U675 sustituir Arial Tipo de fuente usada por el Report por FontA.

    Sigo investigando para dar una pronta solución.

    martes, 16 de diciembre de 2014 20:16
  • Hola Elkin, al ser ese tipo de impresora, te recomendaría que no utilizaras easy-print, easy-print está diseñado para impresoras de escritorio standard, ese es un modelo un poco peculiar y no me extraña que tengas problemas con el.

    utiliza este driver tanto en el servidor como en el equipo cliente

    http://technet.microsoft.com/es-es/library/ff519193(v=ws.10).aspx

    para que utilice el driver, en lugar de easy-print, tendrás que cambiar una directiva de grupo, la cual por defecto prueba por easy-print, y si no funciona, busca el driver, por justo al contrario, que pruebe con el driver, y si no funciona, probar easy-print, te dejo el link explicativo de la directiva en cuestión:

    http://technet.microsoft.com/es-es/library/ff519193(v=ws.10).aspx

    Siempre que tengas driver para ambos (servidor y cliente) utilízalo, te imprimirá mucho más rápido ya que easy-print tiene mayor tamaño de spool.

    un saludo.

    miércoles, 17 de diciembre de 2014 7:58
  • Estimado, yo pasé muchas horas probando todo cuanto encontré sobre si son los controladores V3 o V4, de que si son los drivers instalados en el cliente y en el Server, de que si por GPO no utilizar primero Easy Print...etc, etc. y al final resolví desactivando impresión rápida en las propiedades de la impresora, que en mi caso era una Epson LX300+II...  Si es que en verdad existe alguna solución distinta ojalá alguien la comparta...
    martes, 25 de agosto de 2015 21:13